Fedora 33 boot not working

Leonardo_B

Active Member
Joined
Apr 15, 2020
Messages
190
Reaction score
73
Credits
1,477
I install it to external hard disk . when I try to run it from external hard disk it does a boot loop. windows work well off the internal hard drive but fedora 33 does not work off external.
 


dos2unix

Well-Known Member
Joined
May 3, 2019
Messages
1,003
Reaction score
683
Credits
5,031
What is the error that you are getting?
When installing to an external drive, it is recommended, that you use the BIOS/UEFI to select the boot device.
 
OP
L

Leonardo_B

Active Member
Joined
Apr 15, 2020
Messages
190
Reaction score
73
Credits
1,477
i going to reformat it and try again. when i click exteral hard drive to boot from it just some text that i cant read cause to so fast and then goes to black screen before booting into windows when it does not find it. is fat 32 correct format?
 

dos2unix

Well-Known Member
Joined
May 3, 2019
Messages
1,003
Reaction score
683
Credits
5,031
is fat 32 correct format?

It doesn't matter. The installer will re-format and re-create the correct partitions.
Only the /biosboot or /efi/boot partitions need to be fat32.
It will create some XFS, or BTRFS partitions also.
However, if you don't re-format the drive before re-installing, you will have to delete
the existing partitions from the previous install. (reclaim disk space).
 

dos2unix

Well-Known Member
Joined
May 3, 2019
Messages
1,003
Reaction score
683
Credits
5,031
If you have a video camera on your cell phone.
Take a video of the error. Then when you play it back, you can stop it
when the error pops up.
 
OP
L

Leonardo_B

Active Member
Joined
Apr 15, 2020
Messages
190
Reaction score
73
Credits
1,477
If you have a video camera on your cell phone.
Take a video of the error. Then when you play it back, you can stop it
when the error pops up.
it has to something with bios. cause i took a pendrive that work for install and put the os on their and did not work too. does it matter on ufei no option to go to legacy
 
Last edited:

dos2unix

Well-Known Member
Joined
May 3, 2019
Messages
1,003
Reaction score
683
Credits
5,031
UEFI is fine, does the OS work fine while you are running from the USB drive?
 

dos2unix

Well-Known Member
Joined
May 3, 2019
Messages
1,003
Reaction score
683
Credits
5,031
Can you open a console, and send output from ....

sudo fdisk -l (lowercase L)
 

dos2unix

Well-Known Member
Joined
May 3, 2019
Messages
1,003
Reaction score
683
Credits
5,031
Don't need to install yet. Just run the fdisk command above, while U are booted from USB drive.
 
OP
L

Leonardo_B

Active Member
Joined
Apr 15, 2020
Messages
190
Reaction score
73
Credits
1,477
2t hard drive i would like to use it has some prgorams on it atm. if it work i dont mind deleti everthing on it to try it again
.
 

Attachments

  • Screenshot from 2020-11-24 23-15-51.png
    Screenshot from 2020-11-24 23-15-51.png
    1.3 MB · Views: 265

dos2unix

Well-Known Member
Joined
May 3, 2019
Messages
1,003
Reaction score
683
Credits
5,031
Fast boot is fine, it won't hurt anything. You can turn it off in the BIOS/UEFI.
From the console, run

fdisk /dev/sda

then press g
then press enter.

then press w
then press enter.

This will delete everything on your internal drive.
Then try to re-install, the way you did before.
 
OP
L

Leonardo_B

Active Member
Joined
Apr 15, 2020
Messages
190
Reaction score
73
Credits
1,477
Fast boot is fine, it won't hurt anything. You can turn it off in the BIOS/UEFI.
From the console, run

fdisk /dev/sda

then press g
then press enter.

then press w
then press enter.

This will delete everything on your internal drive.
Then try to re-install, the way you did before.
i dont want to do internal drive.. i want it on external drive
 

dos2unix

Well-Known Member
Joined
May 3, 2019
Messages
1,003
Reaction score
683
Credits
5,031
There is not another drive in your picture, all I see is /dev/sda (internal drive)
and /dev/sdc (usb drive)

It's possible there is another drive, but it doesn't show in your picture.
 
OP
L

Leonardo_B

Active Member
Joined
Apr 15, 2020
Messages
190
Reaction score
73
Credits
1,477
i talking about My Passport 2626. i have m.2 not showed in picture ty for all the help so far
 

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
973
Reaction score
626
Credits
7,221
By disabling fast boot it gives yourself more of a chance to get into BIOS/boot menu. Fast Startup feature will typically prevent you from mounting the Windows partitions in Linux, since it acts basically the same as hibernating the Windows OS: Linux sees that Windows has not cleanly unmounted the Windows partitions and so some cached data might held in the hibernation data, waiting to be written to its final place in the Windows filesystem. You can keep Fast Startup enabled but that will make it more difficult to exchange files between the operating systems.

To turn off Fast Startup go to Control Panel -> All Control Panel Items -> Power Options -> System Settings, and under the title "Shutdown settings", uncheck the item "Turn on fast startup (recommended)" and click on "Save changes" at the bottom of the window.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top