Purchase Linux CDs / DVDs / Flash Drives at OSDisc.com

Welcome to Our Community

While Linux.org has been around for a while, we recently changed management and had to purge most of the content (including users). If you signed up before April 23rd please sign up again. Thanks!

Fan on PC loud/fast problem

Discussion in 'General Linux' started by Cemented_ENS, Apr 14, 2018 at 1:22 AM.

  1. Cemented_ENS

    Cemented_ENS New Member

    Joined:
    Saturday
    Messages:
    2
    Likes Received:
    0
    Hello everyone im new to the linux forums and i need some help i dont know what to do.


    (log in to hide this advertisement)
    My PC fan is running at high speed and its loud i thought it was my GPU but when i installed the drivers it showed no signs of fixing it so that was not the problem, i have the feeling that its a fan that is just running and nothing is controlling it with Windows 10 the fans are all under control.

    Can some one help me here please, so basically the fan on the back of my PC is running very fast and i cant find a way to fix it or some software that will control it and tone it down.

    Thank you.
     
  2. JasKinasis

    JasKinasis Well-Known Member

    Joined:
    Apr 25, 2017
    Messages:
    183
    Likes Received:
    296
    Without knowing anything about what distro you are running, or what hardware you have - take a look at this article from the Arch wiki. Even if you aren't running Arch, it contains enough fan control information to get you started.

    https://wiki.archlinux.org/index.php/Fan_Speed_Control
     
    atanere likes this.
  3. Cemented_ENS

    Cemented_ENS New Member

    Joined:
    Saturday
    Messages:
    2
    Likes Received:
    0

    That feels a bit to complex i wasnt able to move on my OS is RedHat.

    however i have managed to silence the fan
    but without installing any software what happened was that on the dual boot menu the fans always
    kick up to the highest once you boot up the computer and i was reading my partitions and the fan just
    slowed down entirely this isnt anything new that dual boot menu can slow down the fans just like windows
    but i found it odd that at the current state of the fan in the dual boot menu the linux os would boot silent.

    So basically at the dual boot menu i would wait for the fan to slowdown and then launch RedHat and that helped.

    But why wont this do it normally once RedHat is launched? is there some software i can install for the fan to automatically
    slow down? i also tried Fedora which also has this problem on my PC but in the end i settled for RedHat.
     
  4. JasKinasis

    JasKinasis Well-Known Member

    Joined:
    Apr 25, 2017
    Messages:
    183
    Likes Received:
    296
    OK, so you are running Red-Hat/RHEL.
    But you still haven't told us anything about your hardware. With a bit of hardware information, we might be able to give you a more precise answer.

    I'll refer you to this link, which tells you the type of hardware information to include when asking for help:
    Getting hardware information from linux to help forum staff

    In leiu of any hardware information:
    The lm-sensors package would be a good start.
    Try looking for and installing it via your package manager. Offhand, I'm not sure what RHEL uses ATM, but I'll assume that it's dnf - as per Fedora and most other Red-Hat based distros.

    So to find the package name for lm-sensors:
    Code:
    sudo dnf search lm-sensors
    If lm-sensors doesn't yield a result try with an underscore in the search term instead of the hyphen. e.g. lm_sensors

    Then see if it is already installed:
    Code:
    sudo dnf info [package name from search result]
    Where [package name from search result] is the package name for lm-sensors that you obtained from the previous 'dnf search'.

    I haven't ran any Red-hat based distros for many years, so I am guessing that the command
    Code:
    dnf info [package name]
    will tell you whether the package is already installed or not.... I could be mistaken.

    If you don't already have it, install it using 'sudo dnf install [name of package]'.

    Once you have lm-sensors (or if you already have it) you could try re-detecting the sensors:
    Code:
    sudo sensors-detect
    
    That will ask you a series of questions and will then try to detect sensors on your machine.

    Once you (hopefully) have some sensors set up - start the sensor monitoring daemon - if it isn't already running:
    Code:
    sudo service sensord start
    
    Then you should be able to see values from the detected sensors using:
    Code:
    sudo sensors
    or
    Code:
    sudo watch sensors
    Which will continuously monitor and display sensor output until you press ctrl+c to quit.

    Hopefully the current fan-speed will appear somewhere in the output. The fan speed should be listed as a value in RPM (rotations per minute)
    If it does appear - then great.... Try using the fancontrol script and see if you can tweak the fan settings.

    If it doesn't show any fan info - then you will need to look into things further.
     
    atanere likes this.

Share This Page