Fallback Mode after switching graphics card (Linux Mint)

Alexzee

Well-Known Member
Credits
6,602
G'day Will and welcome to linux.org :)

Just a holding post for you at the moment as this is not my area of expertise, but the folder generated from your download - does it contain a file named install.txt or readme.txt ?

These can shed a little light on the procedure.

I expect Alex or other will be along sooner or later - depends on how they are spending their Easter :)

HTH

Chris Turner
wizardfromoz
Hey Wizard,
Happy Easter!

I went to that Github page to download the driver so I could take a look at all of the files. For some reason the green download button is missing. Tried 3 times.

Bizarre or what?
 


willpowell

New Member
Credits
124
I have read the general case Install.txt and says to type `./configure; make; make install'

Tried typing ./configure and `./configure' and get error and > respectively (see photo attached)

Searched for hours about this error and followed tutorials like this with little success.

I am praying its an easy fix. Been spending far too much time on this! Help really appreciated, everything seems so complex to a linux noob
 

Attachments

willpowell

New Member
Credits
124
Hey Wizard,
Happy Easter!

I went to that Github page to download the driver so I could take a look at all of the files. For some reason the green download button is missing. Tried 3 times.

Bizarre or what?
Yes, that confused me. Had to download whole file by clicking “code” then download
 

Alexzee

Well-Known Member
Credits
6,602
I have read the general case Install.txt and says to type `./configure; make; make install'

Tried typing ./configure and `./configure' and get error and > respectively (see photo attached)

Searched for hours about this error and followed tutorials like this with little success.

I am praying its an easy fix. Been spending far too much time on this! Help really appreciated, everything seems so complex to a linux noob
In order for ./configure to work for you, you have to be in the right directory.

If that driver (name of folder) is in your Downloads directory you have to type the whole path to that file so it can find the instructions. So you would cd to that directory and than the command line interpreter will see it.

cd /home/username/Downloads/(name of driver folder)
Than press Enter. Upon pressing enter the command line will show you that you are at:
/home/username/Downloads/(name of driver folder)~$

Than type ./configure at the command line prompt.
And it should take off. It might take a while to finish. Once it's finished, than type make.
When make finishes than type sudo make install.

Thanks for posting the Install file.
 

Alexzee

Well-Known Member
Credits
6,602
IF configure fails you may not have build-essentials installed.
To check to see if you have build-essentials installed run this command and the system will tell you if it's installed or not.
***IF it's installed it will show you a directory and a list in the terminal.***

dpkg -L build-essential

If build-essential is not installed than install it with this command:
sudo apt install install build-essential
 

willpowell

New Member
Credits
124
IF configure fails you may not have build-essentials installed.
To check to see if you have build-essentials installed run this command and the system will tell you if it's installed or not.
***IF it's installed it will show you a directory and a list in the terminal.***

dpkg -L build-essential

If build-essential is not installed than install it with this command:
sudo apt install install build-essential
I do have the correct directory. I have installed build-essential but still same error :(
 

Attachments

Alexzee

Well-Known Member
Credits
6,602
Ok linux-master is the main folder, so type ls so I can see the output.
Like so:
cd Downloads/linux-master/
Than when you get the prompt type ls than post the output.

Also can you post the ReadMe file?
 

Alexzee

Well-Known Member
Credits
6,602
Here you are, thank you for persisting
Thanks:-:)
It looks like all of the necessary files are there in the main folder so that's good!

Now while you're at the ~/Downloads/linux-master$
Type ./configure

Configure should take off.
IF it doesn't try the full path like so:

cd /home/username/Downloads/linux-master Press Enter
Than type ls to show all the files and hit Enter than type ./configure
 

willpowell

New Member
Credits
124
Thanks:-:)
It looks like all of the necessary files are there in the main folder so that's good!

Now while you're at the ~/Downloads/linux-master$
Type ./configure

Configure should take off.
IF it doesn't try the full path like so:

cd /home/username/Downloads/linux-master Press Enter
Than type ls to show all the files and hit Enter than type ./configure
Unfortunately same result, I don't want to keep you, don't worry if it's not something obvious.
 

Attachments

Alexzee

Well-Known Member
Credits
6,602
I was able to download the driver and I've got the same results as you.
When I attempt to run ./configure from the direct path to the driver configure doesn't take off like it should.

The install.txt file say's on line 1:

1. `cd' to the directory containing the package's source code and type
`./configure' to configure the package for your system.

I've done that twice and configure isn't doing it's job.
Something is not right and I'm not sure what it is.

@debian:~/Downloads/linux-master$ ./configure
bash: ./configure: No such file or directory
 

Alexzee

Well-Known Member
Credits
6,602
I have the exact same files as you willpowell.

debian:~/Downloads/linux-master$ ls

arch CREDITS fs Kbuild LICENSES net security virt
block crypto include Kconfig MAINTAINERS README sound
certs Documentation init kernel Makefile samples tools
COPYING drivers ipc lib mm scripts usr

The only think that I can think of is that files or a file is missing to make the process go correctly.
 

Alexzee

Well-Known Member
Credits
6,602
We have 3 members here that are good with building from src.

Maybe JasKinasis, Lord Boltar and dos2unix can assist here with this driver.
 

willpowell

New Member
Credits
124
I have the exact same files as you willpowell.

debian:~/Downloads/linux-master$ ls

arch CREDITS fs Kbuild LICENSES net security virt
block crypto include Kconfig MAINTAINERS README sound
certs Documentation init kernel Makefile samples tools
COPYING drivers ipc lib mm scripts usr

The only think that I can think of is that files or a file is missing to make the process go correctly.
Appreciate you trying for yourself! Have contacted those 3 members to see if they have any ideas
 

Lord Boltar

Active Member
Credits
2,434
Ubuntu Radeon driver is here it is a deb file


or here - https://www.amd.com/en/support/graphics/legacy-graphics/ati-radeon-x-series/ati-radeon-x3xx-series

Another option is below

1. Boot the laptop.
2. Press & Hold the "Shift" key immediately after the BIOS screen finishes, until the Grub menu appears.
3. Select Advanced Options for LM, then press Enter.
4. Select "Recovery Mode", then press Enter.
4. Laptop boots to "Recovery Mode".
5. Edit Grub in Terminal: sudo gedit /etc/default/grub
6. Enable the following line (or add if not listed):
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noacpi"
7. Disable all other "GRUB_CMDLINE_LINUX_DEFAULT="xxxxxx" lines by adding "#" and a space, before the lines.
8. Click "Save".
9. Update Grub in Terminal: sudo update-grub.
10. In Terminal: reboot
11. If Grub menu appears, select "normal boot".
 
Last edited:

Alexzee

Well-Known Member
Credits
6,602
Installing the .deb pkg will be so much easier willpowell-:)

Thanks Lord Boltar!
 

willpowell

New Member
Credits
124
Ubuntu Radeon driver is here it is a deb file


or here - https://www.amd.com/en/support/graphics/legacy-graphics/ati-radeon-x-series/ati-radeon-x3xx-series

Another option is below

1. Boot the laptop.
2. Press & Hold the "Shift" key immediately after the BIOS screen finishes, until the Grub menu appears.
3. Select Advanced Options for LM, then press Enter.
4. Select "Recovery Mode", then press Enter.
4. Laptop boots to "Recovery Mode".
5. Edit Grub in Terminal: sudo gedit /etc/default/grub
6. Enable the following line (or add if not listed):
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noacpi"
7. Disable all other "GRUB_CMDLINE_LINUX_DEFAULT="xxxxxx" lines by adding "#" and a space, before the lines.
8. Click "Save".
9. Update Grub in Terminal: sudo update-grub.
10. In Terminal: reboot
11. If Grub menu appears, select "normal boot".
Thank you for your insight.

Unfortunately the 2 easier methods do not work. (First one is already installed, 2nd crashes)

After entering grub and selecting LM (recovery mode) I get to this screen (see photo). I assumed you just resume normal boot?
It boots normally and alerts that video hardware acceleration is not running (but I’m not in fallback mode!). I followed steps 5 to 10 in terminal (it was set to “quiet splash” without the “noacpi” part. I saved and rebooted but has not fixed it unfortunately.

Did I do anything wrong? Tried drop to root shell prompt but that didn’t work. If not, is there any way of disabling video hardware acceleration as this did not cause a fallback?

Thanks again
5E9C0561-87ED-4219-A719-2EB48A208654.jpeg
AC070CFA-58F9-4FE7-9E20-D1A804D2C51E.jpeg
 

Alexzee

Well-Known Member
Credits
6,602
It would probably be a lot easier to download the .deb pkg and install that.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
13,656
Did I do anything wrong? Tried drop to root shell prompt but that didn’t work
Yes, when the option to drop to root shell prompt is highlighted, you need to OK it.

Press Tab and OK will highlight, so you have two items highlighted - drop to root shell prompt and OK

Press Enter.

You will go to a black screen with 2 options, press Enter for maintenance.

Your prompt will change to show you are Root.

Follow the rest of the instructions @Lord Boltar gave.

Cheers

Chris Turner
wizardfromoz
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Staff online


Latest posts

Top