Failed to start Load/Save Screen Backlight Brightness of amdgpu_bl1

nanoone

New Member
Credits
60
Hello everyone

Today I reinstalled Manjaro KDE

Previously, all things were fine, but now I have a problem(AGAIN)

When I boot I see this error:

Code:
Failed to start Load/Save Screen Backlight Brightness of amdgpu_bl1.
And also my brightness is ALWAYS set to 100% after each boot which is so annoying

After that, I tried to start the service manually:

Code:
sudo systemctl start [email protected]_bl1.service



Job for [email protected]_bl1.service failed because the control process exited with error code.

See "systemctl status [email protected]_bl1.service" and "journalctl -xe" for details.
Then I checked the systemd:

Code:
systemctl status [email protected]_bl1.service



● [email protected]_bl1.service - Load/Save Screen Backlight Brightness of amdgpu_bl1

Loaded: loaded (/usr/lib/systemd/system/[email protected]; static)

Active: failed (Result: exit-code) since Wed 2020-12-09 17:01:57 +0330; 10s ago

Docs: man:[email protected](8)

Process: 2355 ExecStart=/usr/lib/systemd/systemd-backlight load amdgpu_bl1 (code=exited, status=1/FAILURE)

Main PID: 2355 (code=exited, status=1/FAILURE)



Dec 09 17:01:57 Mtn-Lap systemd[1]: Starting Load/Save Screen Backlight Brightness of amdgpu_bl1...

Dec 09 17:01:57 Mtn-Lap systemd-backlight[2355]: Requires a subsystem and sysname pair specifying a backlight device.

Dec 09 17:01:57 Mtn-Lap systemd[1]: [email protected]_bl1.service: Main process exited, code=exited, status=1/FAILURE

Dec 09 17:01:57 Mtn-Lap systemd[1]: [email protected]_bl1.service: Failed with result 'exit-code'.

Dec 09 17:01:57 Mtn-Lap systemd[1]: Failed to start Load/Save Screen Backlight Brightness of amdgpu_bl1.
Since I'm using a hybrid laptop(amd/nvidia) I decided to install [optimus-switch-amd-sddm](https://github.com/dglt1/optimus-switch-amd-sddm)

Even after didn't work

I also added `acpi_backlight=vendor` to my grub, no luck

My specs:

Code:
System: Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2

wm: kwin_x11 dm: SDDM Distro: Manjaro Linux

Machine: Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-ec1xxx v: N/A serial: <superuser/root required>

Chassis: type: 10 serial: <superuser/root required>

Mobo: HP model: 87B1 v: 31.17 serial: <superuser/root required> UEFI: AMI v: F.02 date: 05/14/2020

Battery: ID-1: BAT0 charge: 28.5 Wh condition: 46.9/46.9 Wh (100%) volts: 11.1/11.6 model: Hewlett-Packard Primary

type: Li-ion serial: N/A status: Discharging cycles: 422

CPU: Info: 6-Core model: AMD Ryzen 5 4600H with Radeon Graphics bits: 64 type: MT MCP arch: Zen rev: 1

L2 cache: 3072 KiB

flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 71897

Speed: 1984 MHz min/max: 1400/3000 MHz boost: enabled Core speeds (MHz): 1: 2144 2: 2081 3: 2218 4: 2211 5: 2420

6: 2420 7: 1383 8: 1383 9: 1383 10: 1383 11: 1383 12: 1382

Graphics: Device-1: NVIDIA TU117M vendor: Hewlett-Packard driver: N/A bus ID: 01:00.0 chip ID: 10de:1f99

Device-2: Advanced Micro Devices [AMD/ATI] Renoir vendor: Hewlett-Packard driver: amdgpu v: kernel bus ID: 05:00.0

chip ID: 1002:1636

Device-3: Luxvisions Innotech Limited HP TrueVision HD Camera type: USB driver: uvcvideo bus ID: 3-3:3

chip ID: 30c9:0013 serial: 0001

Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: amdgpu resolution: 1920x1080~60Hz s-dpi: 96

OpenGL: renderer: AMD RENOIR (DRM 3.39.0 5.9.11-3-MANJARO LLVM 11.0.0) v: 4.6 Mesa 20.2.3 direct render: Yes

Audio: Device-1: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Hewlett-Packard

driver: N/A bus ID: 05:00.5 chip ID: 1022:15e2

Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel

bus ID: 05:00.6 chip ID: 1022:15e3

Sound Server: ALSA v: k5.9.11-3-MANJARO

Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel

port: e000 bus ID: 02:00.0 chip ID: 10ec:8168

IF: eno1 state: down mac: b0:5c:da:42:34:3f

Device-2: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: Hewlett-Packard driver: rtw_8822ce

v: N/A port: d000 bus ID: 03:00.0 chip ID: 10ec:c822

IF: wlo1 state: up mac: 70:66:55:bb:04:b7

Device-3: Realtek 802.11ac WLAN Adapter type: USB driver: btusb bus ID: 1-4:3 chip ID: 0bda:b00c

serial: 00e04c000001

Drives: Local Storage: total: 476.94 GiB used: 7.38 GiB (1.5%)

ID-1: /dev/nvme0n1 vendor: Toshiba model: KBG40ZNV512G KIOXIA size: 476.94 GiB speed: 31.6 Gb/s lanes: 4

serial: 306PEEC9PBV1 rev: HP00AE00 scheme: GPT

Partition: ID-1: / size: 275.15 GiB used: 7.35 GiB (2.7%) fs: ext4 dev: /dev/nvme0n1p4

Swap: Alert: No Swap data was found.

Sensors: System Temperatures: cpu: 48.1 C mobo: N/A gpu: amdgpu temp: 46.0 C

Fan Speeds (RPM): N/A

Info: Processes: 262 Uptime: 5m Memory: 7.21 GiB used: 1.26 GiB (17.4%) Init: systemd v: 246 Compilers: gcc: 10.2.0

Packages: pacman: 1046 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.08
 


nanoone

New Member
Credits
60
Ok I managed to solve the problem by myself
I was looking for what was causing the problem that I found this:
Code:
sudo systemctl status [email protected]:amdgpu_bl0

● [email protected]:amdgpu_bl0.service - Load/Save Screen Backlight Brightness of backlight:amdgpu_bl0
     Loaded: loaded (/usr/lib/systemd/system/[email protected]; static)
     Active: failed (Result: exit-code) since Thu 2020-12-10 19:22:42 +0330; 23s ago
       Docs: man:[email protected](8)
    Process: 956 ExecStart=/usr/lib/systemd/systemd-backlight load backlight:amdgpu_bl0 (code=exited, status=1/FAILURE)
   Main PID: 956 (code=exited, status=1/FAILURE)

Dec 10 19:22:42 Mtn-Lap systemd[1]: Starting Load/Save Screen Backlight Brightness of backlight:amdgpu_bl0...
Dec 10 19:22:42 Mtn-Lap systemd-backlight[956]: amdgpu_bl0: Failed to write system 'brightness' attribute: No such device or address
Dec 10 19:22:42 Mtn-Lap systemd[1]: [email protected]:amdgpu_bl0.service: Main process exited, code=exited, status=1/FAILURE
Dec 10 19:22:42 Mtn-Lap systemd[1]: [email protected]:amdgpu_bl0.service: Failed with result 'exit-code'.
Dec 10 19:22:42 Mtn-Lap systemd[1]: Failed to start Load/Save Screen Backlight Brightness of backlight:amdgpu_bl0.
Ok so I simply tried to run that manually
Code:
sudo systemctl start [email protected]:amdgpu_bl0
And that's it!!!!!
It solved the problem
But I had to create a systemd service so that it runs on every boot
I searched a lot and found these two links:
1. https://forum.manjaro.org/t/how-do-i-make-a-systemd-service-and-enable-it/21699
2. https://bbs.archlinux.org/viewtopic.php?pid=1934974#p1934974

Then I tried to combine them and I wrote this service:
Code:
sudo nano /etc/systemd/system/startup-brightness.service

[Unit]
Description= Fixing screen brightness on boot

[Service]
Type=oneshot
ExecStart=/opt/fix-brightness.sh

[Install]
[email protected]:amdgpu_bl0.service
And then:
Code:
sudo systemctl enable --now startup-brightness
The problem with saving brightness is now **SOLVED**
But still I see the error on boot screen
That's the only problem left
I have three questions:
1. How can I edit that service so that I don't need to write another script to just run that one line of code
2. Why didn't the systemd do that itself?
3. If the problem is solved, then why do I still see that error on boot screen? Is that because of the line
`[email protected]:amdgpu_bl0.service` ?
 

ionutflorin09

New Member
Credits
18
I have the same issue on Ubuntu 20.04 installed on a Vivobook laptop. I believe it started after an update but I don't know exactly which one.

Thank you for the service start hack, my previous fix was to add the "acpi_backlight=vendor" to grub and setting a fixed brightness value at startup by using the "/etc/rc.local" file:

Code:
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.

echo 100 > /sys/class/backlight/amdgpu_bl0/brightness

exit 0
My fix now includes the grub entry and in the rc.local file I just start again the service:
Code:
systemctl start [email protected]:amdgpu_bl0
exit 0
This seems to work. After the reboot the brightness value is restored and if I unplug the charger, the brightness stays the same, doesn't go all the way down.

Btw, I found this issue:

Seems related but no fix so far. Also, it looks like an old issue...
 

nanoone

New Member
Credits
60
I have the same issue on Ubuntu 20.04 installed on a Vivobook laptop. I believe it started after an update but I don't know exactly which one.

Thank you for the service start hack, my previous fix was to add the "acpi_backlight=vendor" to grub and setting a fixed brightness value at startup by using the "/etc/rc.local" file:

Code:
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.

echo 100 > /sys/class/backlight/amdgpu_bl0/brightness

exit 0
My fix now includes the grub entry and in the rc.local file I just start again the service:
Code:
systemctl start [email protected]:amdgpu_bl0
exit 0
This seems to work. After the reboot the brightness value is restored and if I unplug the charger, the brightness stays the same, doesn't go all the way down.

Btw, I found this issue:

Seems related but no fix so far. Also, it looks like an old issue...
I'm glad that helped :)
Oh since I'm using manjaro I don't use rc.local but that's great!!
I'd be pleased if you could write a systemd one :)
yeah I saw that bug and it seems that's too old. I have no Idea why the bug still exists(Kernel 5.10.13-2)
 

ionutflorin09

New Member
Credits
18
I'm glad that helped :)
Oh since I'm using manjaro I don't use rc.local but that's great!!
I'd be pleased if you could write a systemd one :)
yeah I saw that bug and it seems that's too old. I have no Idea why the bug still exists(Kernel 5.10.13-2)
I'm a software engineer but not very savvy on linux systems. I read this link and your approach seems fine https://linuxconfig.org/how-to-create-systemd-service-unit-in-linux

I know that rc.local is kinda deprecated and not supported on all distros but the solution is hacky anyways.

Messed around a little bit with the systemd services and came up with this:
Code:
[Unit]
Description=Dummy service for attempting to start the problematic amdgpu_bl0 service

[Service]
Type=oneshot
ExecStart=systemctl start [email protected]:amdgpu_bl0

[Install]
WantedBy=multi-user.target
This seems to work on my machine and you don't need a separate script file for that line.

The first service run attempt is still with error, you can see it in the boot logs (journalctl -b), but the second run is succesfully :)
 
Last edited:

nanoone

New Member
Credits
60
I'm a software engineer but not very savvy on linux systems. I read this link and your approach seems fine https://linuxconfig.org/how-to-create-systemd-service-unit-in-linux

I know that rc.local is kinda deprecated and not supported on all distros but the solution is hacky anyways.

Messed around a little bit with the systemd services and came up with this:
Code:
[Unit]
Description=Dummy service for attempting to start the problematic amdgpu_bl0 service

[Service]
Type=oneshot
ExecStart=systemctl start [email protected]:amdgpu_bl0

[Install]
WantedBy=multi-user.target
This seems to work on my machine and you don't need a separate script file for that line.

The first service run attempt is still with error, you can see it in the boot logs (journalctl -b), but the second run is succesfully :)
Nicely done!!!
Also you can remove that error by simply replace 'oneshot' with 'simple' in '[service]' part
Now you can post that in https://bugzilla.kernel.org/show_bug.cgi?id=203905 as a workaround and others also appreciate it as I do :)
 

nanoone

New Member
Credits
60
I found another workaround and it's easier than EVER and it's done via mkinitcpio


First, what's mkinitcpio(https://wiki.archlinux.org/index.php/Mkinitcpio)?



The initial ramdisk is in essence a very small environment (early userspace) which loads various kernel modules and sets up necessary things before handing over control to init. This makes it possible to have, for example, encrypted root file systems and root file systems on a software RAID array. mkinitcpio allows for easy extension with custom hooks, has autodetection at runtime, and many other features.

So go ahead and edit with sudo nano /etc/mkinitcpio.conf


Then add the "amdgpu" in the modules section like this:


MODULES=(amdgpu)


After that, simply run sudo mkinitcpio -P so that it regenerates mkinitcpio for all kernels


This solved my issue, I hope it works for others too :)_
 

Alfalfa

New Member
Credits
28
I couldn't find this startup-brightness.service in my system .
My kernel is 5.8.0.63
Lennovo idea pad gaming 3 , Ubuntu 20.04 .

Failed to start load/save screen backlight brightness of backlight :amdgpu_bl0

Can u elaborate the solution
 

Alfalfa

New Member
Credits
28
I couldn't find this startup-brightness.service in my system .
My kernel is 5.8.0.63
Lennovo idea pad gaming 3 , Ubuntu 20.04 .

Failed to start load/save screen backlight brightness of backlight :amdgpu_bl0

Can u elaborate the solution
I did it with this ...........

cat /etc/systemd/system/startup-brightness.service

[Unit]
Description=Set lower brightness on startup
[email protected]:amdgpu_bl0.service

[Service]
Type=oneshot
ExecStart=/bin/bash -c 'echo 25 > /sys/class/backlight/amdgpu_bl0/brightness'
ExecStart=systemctl start --now [email protected]:amdgpu_bl0

[Install]
[email protected]:amdgpu_bl0.service
WantedBy=multi-user.target
 

LinuxEN

New Member
Credits
19
cat /etc/systemd/system/startup-brightness.service

[Unit]
Description=Set lower brightness on startup
[email protected]:amdgpu_bl0.service

[Service]
Type=oneshot
ExecStart=/bin/bash -c 'echo 25 > /sys/class/backlight/amdgpu_bl0/brightness'
ExecStart=systemctl start --now [email protected]:amdgpu_bl0

[Install]
[email protected]:amdgpu_bl0.service
WantedBy=multi-user.target

!!!!!!!!-----------------------------------------------------!!!!!!
Just add this in your file...
 

Alfalfa

New Member
Credits
28
cat /etc/systemd/system/startup-brightness.service

[Unit]
Description=Set lower brightness on startup
[email protected]:amdgpu_bl0.service

[Service]
Type=oneshot
ExecStart=/bin/bash -c 'echo 25 > /sys/class/backlight/amdgpu_bl0/brightness'
ExecStart=systemctl start --now [email protected]:amdgpu_bl0

[Install]
[email protected]:amdgpu_bl0.service
WantedBy=multi-user.target

!!!!!!!!-----------------------------------------------------!!!!!!
Just add this in your file...

Thank you very much.
 

Alfalfa

New Member
Credits
28
cat /etc/systemd/system/startup-brightness.service

[Unit]
Description=Set lower brightness on startup
[email protected]:amdgpu_bl0.service

[Service]
Type=oneshot
ExecStart=/bin/bash -c 'echo 25 > /sys/class/backlight/amdgpu_bl0/brightness'
ExecStart=systemctl start --now [email protected]:amdgpu_bl0

[Install]
[email protected]:amdgpu_bl0.service
WantedBy=multi-user.target

!!!!!!!!-----------------------------------------------------!!!!!!
Just add this in your file...
So it will create new file "startup-brightness.service" in system folder. Currently in my system folder this "startup-brightness.service" is absent.

After doing following steps :
edit /etc/default/grub
add acpi_backlight=native to GRUB_CMDLINE_LINUX_DEFAULT.
then run sudo update-grub.

I am able to login to system after a while , but still that flashing err messages exists while . Hope adding the file "startup-brightness.service" will solve my boot flashing problem.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!


Latest posts

Top