/etc/fstab

starfox101

New Member
Joined
Oct 23, 2021
Messages
7
Reaction score
0
Credits
60
Could someone spot the problem. I have NFS working, but it will not stand a reboot. /etc/fstab config:
"192.168.1.138:/volume3/TVshow mnt/synology/TVshow nfs defaults 0 0" This fails . NFS is started using:
sudo mount 192.168.1.138:/volume3/TVshow mnt/synology/TVshow

Thanks
 


SlowCoder

Gold Member
Gold Supporter
Joined
May 2, 2022
Messages
456
Reaction score
314
Credits
3,611
maybe you need to specify your mountpoint at root?
Code:
192.168.1.138:/volume3/TVshow /mnt/synology/TVshow nfs defaults 0 0
                              ^
 
Last edited:
OP
S

starfox101

New Member
Joined
Oct 23, 2021
Messages
7
Reaction score
0
Credits
60
Thanks for the reply, I'll give that a shot!

Still NOGO Just will not auto start!
 
Last edited:

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,900
Reaction score
3,527
Credits
35,667
Try changing adding "_netdev", so that it looks like this.
Code:
192.168.1.138:/volume3/TVshow /mnt/synology/TVshow nfs defaults,_netdev 0 0
 
OP
S

starfox101

New Member
Joined
Oct 23, 2021
Messages
7
Reaction score
0
Credits
60
thanks again, still a no go! I've tried most of the newer google search examples
 

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,900
Reaction score
3,527
Credits
35,667
Possible it's attempting to mount before network is active?
That's what I was thinking, that's what the "_netdev" option is for.

Can you try running the following with the previous option still active in fstab.
Code:
sudo systemctl daemon-reload
Then try again? If that doesn't work can you manually mount the nfs share and then show the output of the following?
Code:
mount | grep nfs
 
OP
S

starfox101

New Member
Joined
Oct 23, 2021
Messages
7
Reaction score
0
Credits
60
restarted using: 192.168.1.138:/volume3/TVshow /mnt/synology/TVshow nfs defaults,_netdev 0 0
sudo systemctl daemon-reload: no change

mount | grep nfs:
192.168.1.138:/volume3/TVshow on /mnt/synology/TVshow type nfs4 (rw,relatime,vers=4.1,rsize=131072,wsize=131072,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,clientaddr=192.168.1.45,local_lock=none,addr=192.168.1.138,_netdev)
 

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,900
Reaction score
3,527
Credits
35,667
You could try specifically adding the version in the fstab to see if that does anything, but it seems more like that it tries to mount it before the network is up even with the "_netdev" option enabled. Try this first and see what happens, I think the defaults option is not needed since those only use the defaults. So try this.
Code:
192.168.1.138:/volume3/TVshow /mnt/synology/TVshow nfs _netdev 0 0
Then if That doesn't work try this.
Code:
192.168.1.138:/volume3/TVshow /mnt/synology/TVshow nfs _netdev,vers=4.1 0 0
And if that doesn't work try this.
Code:
192.168.1.138:/volume3/TVshow /mnt/synology/TVshow nfs auto,x-systemd.automount,x-systemd.mount-timeout=30,_netdev 0 0
 
OP
S

starfox101

New Member
Joined
Oct 23, 2021
Messages
7
Reaction score
0
Credits
60
192.168.1.138:/volume3/TVshow /mnt/synology/TVshow nfs auto,x-systemd.automount,x-systemd.mount-timeout=30,_netdev 0 0

This was the last attempt, still a nogo. I noticed there is a difference in ubuntu 20.04 and 22.04 NFS. I am on 20.04. May look into an upgrade. Thanks much for the help!
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Staff online

Members online


Top