Errors when installing elementary on Lenovo ideapad 5

mvandoo

New Member
Joined
Jan 17, 2021
Messages
3
Reaction score
2
Credits
30
Hi There,

Hoping some one can help me out. I am new to installing linux on a pc. I got a new lenovo ideapad 5. I am trying to install elementary using a boot usb created with rufus as mentioned in the elementary.io website. I get the errors that I attached in the screen shot. I would really appreciate any ideas to solve this.
The error with the TPM goes away if I disable the intel trust. I read in forums about disabling fast boot but that option is not there in my bios screen(screenshots attached).
I also tried with secure boot disabled and got the same errors.
 

Attachments

  • boot-error.jpg
    boot-error.jpg
    2.3 MB · Views: 177
  • IMG-0086.jpg
    IMG-0086.jpg
    4.5 MB · Views: 158
  • IMG-0087.jpg
    IMG-0087.jpg
    4.4 MB · Views: 169
  • IMG-0088.jpg
    IMG-0088.jpg
    3.2 MB · Views: 210


KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
3,998
Reaction score
3,677
Credits
32,123
I forget where it is for Elementary - but I'm pretty sure it's an E. That you need to press E sometime during one of the boot choices...

At some point during the boot, there's a spot for 'advanced options' or similar.

Basically, you want to see if adding 'noapic' as a boot parameter will get you into the OS. If it does, it's considered a temporary solution.

Your computer is new, so full kernel support may not be in the kernel Elementary has. You can try a rolling release distro with a new kernel just to check to see if that helps. You don't have to install it - you can just test to see if it boots and works.

OpenSUSE Tumbleweed might do well enough for testing that.
 
OP
M

mvandoo

New Member
Joined
Jan 17, 2021
Messages
3
Reaction score
2
Credits
30
Hi there,

Thank you for the reply. I got elementary working by pressing ctrl+alt+f1 and going into the shell. Then had to do a lot of manual package installations. I ended up having various kinds of issues with display, audio etc.. Mine is intel graphics and not nvidia - may be that's causing the trouble. Anyway I decided to go for ubuntu instead and it worked. Thanks!
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Latest posts

Top