Error: No server is specified


New Member
May 15, 2021
Reaction score
I have a Dell Inspiron 5585 with a 500gb nvMe drice and a PNY 120gb ssd. I am boot ing into 3 os, Windows 10 Enterprise on the nvMe and Kodachi 8.5. Zorin OS 16 beta on the PNY. All seem to be working fine and I have access to each os. At first I was getting two error messages: 1. error: can't find command 'hwmatch' and 2. error: no server is specified. Press any key to continue... I did a boot repair and that seems to have fixed issue 1. Issue 2 is still there. Any ideas? My first time here so I hope I picked the right topic.

My first time here
Welcome! Specifically... which of your 3 operating systems is presenting the 'no server' error? All of them? Or are you seeing it at the GRUB menu before choosing which system to boot?
Thanks, I am seeing it at the GRUB menu before choosing OS. BTW, My PNY SSD with Zorin OS is encrypted if that helps.
Dual- and multi-booting with Windows 10 is often a fragile thing. And I seem to encounter many cases where NVMe and eMMC drives have problems with Linux. I personally have current problems with eMMC, so I want to be very cautious that you do not make this situation worse such that you lose access to any of the OS'es since they are all working for you. The need to "press a key continue" is only a slightly annoying delay and not really a serious "problem."

To me, it is quite unusual to see an error like "no server" before any OS has started... and therefore no networking is yet enabled. Some motherboards have the ability to use ethernet so they can easily update the system BIOS. A couple of things to try:

1. Connect the Dell to your router with an ethernet cable and then boot it up. Does the error go away?

2. Go into your BIOS settings and explore every section... looking for anything that might need internet connectivity. If you find something that does, can you disable it?

Google isn't giving much information on this. If the things above don't help, can you take a photo of the error and post it here? There may be a clue in some of the text shown as the GRUB process runs, and just before the error.
Thanks Stan, I tried the ethernet cable, no help. The error does go away after about 10 seconds or you can press any key to continue. I guess my OCD can live with it. Here is a list of what is "Enabled" in my BIOS under Advance tab. PowerNow! Virtualization. Integrated NIC. USB Emulation. Adapter Warnings. Camera. Security Tab: Firmware TPM. UEFI Firmware Capsule Updates.
UEFI Firmware Capsule Updates
Looks like a possible cause. Can you disable it? This is exactly the kind of thing I was talking about. Be sure to save changes and reboot.
Last edited:
Another quirky thing... Windows 10 does not really shut down when you tell it to. Instead, it goes into hibernation. This usually causes a different problem for Linux users, but it makes me wonder if it might be affecting you with this issue.

If disabling the UEFI Firmware Updates in BIOS doesn't help.... boot into Windows, and then exit from Windows with a "restart," and not a "shut down." The "restart" keeps Windows from hibernating, so it's a very simple test to see if the "no server" error goes away.
Last edited:
Well, somewhere along the way I totally broke Windows. I think it was last night when I ran some terminal commands to "fix" the hwmatch error. That error is gone and so is Windows. I think my best bet is going to be running Zorin and Kodachi on my laptop and just use Windows on my desktop for the apps that only run on Windows. Thanks for helping!
Sorry to hear that... I hoped it wouldn't come to that. But I did caution that it can be a pretty fragile relationship keeping them working together. (Blame Windows 10! ;))

You may possibly get Windows back, if you want to try, by booting into Linux and giving the command:
sudo update-grub

By chance did the Windows crash make the 'no server' error go away? Or any of the other possible fixes?

It's a tough way to learn, but this is really a good education in your Linux journey.
Understand that! Not the first time i have broken it. No, the error did not go away. I'll try the update command
Good luck!
That got my Windows back. I'll just have to live with the error message. Everything else seems to be working.
Glad that part worked, at least. Everything dealing with Windows can be hit or miss, it seems.

Yeah, it's not a significant problem, but we can try a little more if you want. Up to you. If you can take a photo of the error, I'm guessing it shows more text above it, and that may offer a clue. We could try looking at some log files and see if anything shows there (which may also show in the photo). It's kind of like a fox chasing a rabbit... sometimes you get supper, and sometimes you go hungry! :oops:

Maybe others will jump in with better ideas too.
I'm game if you are! Worst case I end up reinstalling everything again. Here is exactly what is on the screen, top left corner. error: no server is specified. Press any key to continue...that's all. Press any key or wait 10 seconds it goes to where I can select the OS.
I'm game if you are! Worst case I end up reinstalling everything again.
I hope it doesn't go that badly, but I appreciate your adventurous spirit! :)

I was hoping the error would be at the bottom of the screen with a wall of text above it. o_O:(

Let's start with dmesg while I try to look up anything else that may help. This command provides a lot of output, so let's save it to a file on your desktop, like this:
dmesg -T > /home/hurley/Desktop/dmesg.txt

Change 'hurley' if you use a different user name on the Dell. Then use the 'Attach files' button on the lower left to attach the dmesg.txt file here. The -T option gives a readable date and time stamp.

I'm using Zorin 15.3, so it should be about the same as your version 16 beta. Along with dmesg, let's also get the boot.log
sudo cat /var/log/boot.log > /home/hurley/Desktop/bootlog.txt
Again, change the username, if needed, and attach the file here with dmesg.
Last edited:
OK, it will take me a bit to try to go through those, and I've got to feed the wife (or better if she feeds me) in just a bit. Will be back in awhile. And maybe someone else will jump in with more/better ideas.
Just so y'all know, there's a free (no registration needed, even) paste service located here:

Feel free to use it to share large amounts of text, without needing to download anything. It has a few neat features, but registration is optional.
I have found a few other issues with Zorin. May be an issue with the beta version. The Appearance I had set up has changed. I can select what I want but it does not change. Also, if the computer goes to sleep or i close the lid all I get when i wake it up is the time. Nothing I do will get me past that. If not related to the above issue we will wait on this one.

Members online

Latest posts