Error msg. when I try to connect to SoftEther server using OpenVPN

rudrani1971

New Member
Credits
216
Happy Sunday folks,

I tried following the instructions of another VPN to connect to SoftEther using Terminal:

> sudo openvpn <configfile.opvn>
> password

and this is the error msg I got:

WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.

I clicked on the link and did my best to read it. The jargon got me so swamped I spaced out for a minute or two. All the article did was confuse the living Hell outta me.

If anyone can help me with this issue in layman's terms, I'd truly appreciate it.

Hope everyone has had an awesome weekend, especially Caturday! =^. . ^=
 


f33dm3bits

Gold Member
Gold Supporter
Credits
24,745
Certificates can be validated to ensure that the TLS connection can be trusted, for websites the verification happens by the Root certificates in your browser. With an openvpn server this can also be done by generating generating certificates a certain way and than setting certain configuration options for your openvpn client. From the documentation you linked those options would be these.
Code:
remote-cert-tls server
ns-cert-type server
If you don't know how to configure these options I would contact your vpn provider, SoftEther and they should be able to help you out.
 

dcbrown73

Well-Known Member
Credits
2,874
I would recommend using SoftEther's VPN client instead of OpenVPN's. SoftEther is very easy to use. I used to run a server on a Raspberry Pi for my home network. It comes with a server and a client to make things easy.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Latest posts

Top