epiphany browser just hangs after being opened -- won't go to any website that I enter in address bar

Straitsfan

New Member
Joined
Dec 13, 2021
Messages
3
Reaction score
0
Credits
66
Hello. Did an update to my Linux elementary OS. Tried to open epiphany browser, but it just hangs there -- there's some kind of spinning icon in the tab. When I enter web site address, nothing happens. Just hangs there. Anyone else have this problem, and any suggestions?

I'm using brave right now, but not sure it's optimal for Linux. Are there any other browsers that work well? The videos on youtube in Brave seem to run a bit slower -- sometimes the audio is out of sync, and/or the images have just the slightest amount of slowness -- not as smooth as on OS X
 


KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
6,428
Reaction score
5,706
Credits
51,740
and any suggestions?

I have a pretty low opinion of eOS, because of things like this. I've always found troubles with it, from random crashes to applications just no longer working - including the browser.

Any browser is fine. Performance shouldn't be too different if you actually measured the performance. They're pretty similar in the various benchmarks people do.

Personally, I'd pick a different OS. eOS is a 'heavy' OS for an older Apple device. I'd try Lubuntu or Xubuntu to see if those meet your goals more easily. Both have a recent LTS (22.04) available. Both are official Ubuntu flavors. If you do try Lubuntu, use the lubuntu.me address.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Members online


Top