Encrypted install for FEREN only available on HDD and not SSD

1bit

New Member
Joined
May 10, 2019
Messages
28
Reaction score
9
Credits
83
Hi all,

I have 2 PC's a Win10Prox64 one and a LinuxFeren x64 one, now on the Linux's 500GB HDD it offered up full drive encryption which I made use of, meaning should my drives be pulled they wouldn't get my files etc it will all be gobbledegook, so I decided to replace the 500GB Seagate HDD with a 250GB Samsung EVO 840, I installed my Linux Feren on the Samsung EVO 840 SSD to find that drive encryption was not offered?

can anyone guide me to a decent performing SATA 250GB (OS) drive that will support drive encryption under Linux Feren>?

side note - I've noticed over the years that the SAMSUNG MAGICIAN software seems to be even more buggy with each release, and having to get older versions some time ago to get certain options to appear, I have a 1TB EVO 860 in my Windows PC and SM says for that it does NOT support drive encryption either?? yet the internet and Samsung say it does>?

can anyone help? I just want drive encryption on an SSD for Linux Feren - windows would be nice too - but ATM Feren is more important

thanks
 
Last edited:


KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
4,003
Reaction score
3,681
Credits
32,162
Disk encryption should be a function of the OS and offered during the installation phase. I've never installed Feren, but I'd go back through the installer to see if you missed an option.

It's usually something like this:

Lubuntu Testing [Running] - Oracle VM VirtualBox_002.png
 
OP
1

1bit

New Member
Joined
May 10, 2019
Messages
28
Reaction score
9
Credits
83
ahh i didnt see that, thanks..
but on the HDD it was a totally different setup scenario, even the 5 "desktop" choices didn't appear like they did on the HDD - i'll re-try and report
thanks again
 
OP
1

1bit

New Member
Joined
May 10, 2019
Messages
28
Reaction score
9
Credits
83
I tried, no 'check' button for encryption, last time it was right in yer face and obvious, i want THAT but on SSD not HDD??? and this time it looked like there were fewer options? dunno if cos FEREN is already installed on it - i choose both UEFI and non-EUFI boot options from my VENTOY stick which has linux distros ISOs on to install them from, and i used it before with encryption so it aint that

all i can do is one of three options and none include encryption.
at a total loss here
ive posted this on 6 forums and this is the only reply ive got in so far
 

KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
4,003
Reaction score
3,681
Credits
32,162
Hmm... Let me grab a copy of Feren and see what I can find.

This will take a minute - as I'm otherwise engaged this weekend. So, if someone else wants to step in and check it out in VBox that's cool too. I'll just be checking the installation process to see if encryption is in there (where it should be).
 
OP
1

1bit

New Member
Joined
May 10, 2019
Messages
28
Reaction score
9
Credits
83
thank Kgill - i have Vbox and could try it again on HDD and see if its only an option for HDD's and not for older 250GB Samsung 840 EVO SSD

im willing to buy a cheapo 250GB one but MUST work with the encryption option
 
OP
1

1bit

New Member
Joined
May 10, 2019
Messages
28
Reaction score
9
Credits
83
at a total loss, cos in Vbox on HDD install its identical as before: and is the same if I
nEZ56jfvJ5.jpg
choose my Samsung 1TB 860 EVO as the install location
 
OP
1

1bit

New Member
Joined
May 10, 2019
Messages
28
Reaction score
9
Credits
83
I think I know my issue

basically, you need to turn on and off full disk encryption with samsung magician BEFORE you install the OS, so I need a second USB stick to put SECURE ERASE on and then also enable ENCRYPTION on samsung magician before installing FEREN... i THINK thats what it could be

so no encryption option is appearing as it hasnt been 'activated' on the 840 EVO
 
OP
1

1bit

New Member
Joined
May 10, 2019
Messages
28
Reaction score
9
Credits
83
..according to crappy SM (which has been iffy AF since its inception among ALL drrives) says my 840 EVO supports NOTHING in the app - no encryption, no secure erase, no rapid mode - ive secure erased it twice before lol, im trying to get Samsung Magician 4.1 as that was the only one that would work with m,y 840 EVO and I can NOT find a mirror

I do NOT TRUST latest/later versions of Samsung Magician from 4.1 onwards
 

KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
4,003
Reaction score
3,681
Credits
32,162
Encryption should be a process of the OS. It should support encryption regardless of the hardware.

The option is completely missing from Feren's installer. I've gone through every option that I could find and it's not there.

Frankly, if encryption is important to you, I'd highly recommend finding a distro that lets you encrypt during the installation process - which is pretty much every major distro. I have no idea why Feren would remove this, but remove it they did. There are surely other KDE distros based on Ubuntu to pick from.

Now, it is possible to encrypt after installation, but it's pretty tricky and not something I'd recommend unless one is a very advanced user. I do not recommend trying this, unless you're willing to risk data loss. If you must, here are some directions:

 
OP
1

1bit

New Member
Joined
May 10, 2019
Messages
28
Reaction score
9
Credits
83
I won't be doing that but thanks for the help as I'm ALMOST a Linux noob, almost lol

I've had it connected via USB to this windows PC, deleted, created a partition and reformatted it, and still, when I launch SM 4.5 (the only version closest to 4.1 I could find) it said "WE CAN NOT DETECT ANY SAMSUNG SSDs ON THIS DEVICE"..??? (there's TWO, one on USB and the system OS on SATA) and only the performance test is allowed (lit up as an option) and the both the SATA and SATA-to-USB SSD's show up in the list?? when chosen none of the options are available and that's where I'm stuck on testing, so I can ENABLE Encryption which it states you must do before you install an OS.

I'm starting to believe its because encryption hasn't been enabled on the 250GB 840 EVO drive and I can't get a version of SM (Samsung Magician) that works correctly, so I can enable it, then the option to encrypt the OS at an OS level may appear, cos it was 100% there on my first ever try on a 500GB HDD, it may have been off the disk install, I'm not 100% sure if it was the version I put on my VENTOY USB INSTALLERS I used the first time or was it the disk version? I'm gonna retry it on the 500GB HDD direct (again) on the Linux system and see if 'encryption' appears again
...if not then I must be getting confused with ALL other distros I've been trying but could swear on my granny's life it WAS there.. and as you say nearly all distros offer it.

EDIT: I'm getting a 2nd USB stick today to put Secure Erase on, this resets the SSD back to factory condition, this may help or be part of the issue.

thanks for helping me out I really do appreciate it, of 6 forums this one is the only one that's been of any help so far, and you have put in a lot of effort so thanks... buy you a beer :)
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top