• We had to restore from a backup today after a failed software update. Backup was from 0000 EDT and restored it at 0800 EDT so we lost about 8hrs. Today is 07/20/2024. More info here.

Enable Ethernet/SSH using Buildroot [Solved]

It appears the the "auto eth0" line is in the config file twice.
It is needed once.
I may suspect a lack of packages installed during the build. I didn't include ssh packages and I don't know which one are relevant in the case of Buildroot. You can find a list here and hope that it can be helpful.


It appears that the "auto eth0" line is in the config file twice.
It is needed once.
Found it. First here is a list of packages I installed. The most important one iis openssh

a) In Developement tools For now I am sure that we will be needing: cvs, make, gperf, git,server support, pkg conf and libtool

b) in Interpreter languages and scripting: luajit, micropython, nodejs, perl, python3

c) in Networking applications: bridge-utils, ethtool, openssh,putty,ifupdown scripts

d) text editors and viewers: nano,optimize for size

e) Hardware Handler: fconfig, iostat,lmsensors, sensors, pwmconfig...


f.1) Compression and decompression: unrar, zip, lzip

f.2) Database: Mysql support

f.3) Filesystem: liconfig, libfuse, libconfuse

f.4) avascript: duktape, jQuery, jsmin, json-javascript

f.5) JsonXML: cJSON, json-c,json-glib, jsoncpp, libjson,libbson,libyaml,yaml-cpp

f.6) Text and terminal handling: ncurses programs,fmt

f.7) others: qlibc, libdaemon

cd ../etc/networks -->
nano interfaces

and follow my lead while modifying the file:

# Configure Loopback
auto lo
iface lo inet loopback

# Configure eth0 with static IP
auto eth0
iface eth0 inet static
#YourIP-Asdress but the last decimals have to be different from the ones included in your IP-Adress

address ...X...X...X...
#Your Broadcast address referred to Bcast in the MobaXterm window after you ifconfig -a
Bcast ...X...X...X...
network ...X...X...X...
#Your netmask that is generally fix

# Configure eth0 with dhcp IP
# auto eth0
# iface eth0 inet dhcp
Since we are using SSH to connect the board, it is useful to adjust some intern parameters and modify some files.

cd ../etc/ssh/
nano sshd_config
#Here Change the following line and remove the "#"
# Authentication:

#LoginGraceTime 2m
PermitRootLogin yes
#StrictModes yes
#MaxAuthTries 6
#MaxSessions 10

# To disable tunneled clear text passwords, change to no here!
#PasswordAuthentication yes
PermitEmptyPasswords yes

PermitRootLogin yes

In the same directory:

nano ssh_config

# Host *
# ForwardAgent no
# ForwardX11 no
PasswordAuthentication no
Hello Everyone

I built a Buildroot image for my STM32MP157C-DK2 and I would like to enable Wifi and Ethernet.

Are there some specific packages that I need to install before doing so ?

I found this article here but I it is specific for an STM32 device with OpenSTLinux so I don't know if it is also possible to apply this method.

I worked with embedded Linux before and I always had a direct connection to ethernet through SSH. in my case ifconfig does not output an IP-Adress for eth0.

Any suggestion on how I should proceed in order to have Ethernet and then Wifi operating on my device?

Thank you.

p.s I am using a remote controle software: MobaXterm for SSH access
I am building buildroot image for x86_64 with network capabilities (wifi ) and syslinux as bootloader and flashing it on SATA/NvMe Drive , i have already added all the pacakages and the driver needed for our network adaptor, but i am getting following error at boot time :
loading bzImage ...ok
loading rootfs.cpio.xz....ok
failed to read block 0x7.
Any suggestion what i am leaving in buildroot or where can be the issue.