E: Sub-process /usr/bin/dpkg returned an error code (1) while installing elementary-tweaks

Joined
Jun 5, 2021
Messages
66
Reaction score
41
Credits
451
I have tried to install elementary tweaks in 'elementary os 6.1 jolnir' like here and the following is the output
Bash:
[email protected]:~$ sudo apt install elementary-tweaks
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  libgranite5
The following NEW packages will be installed:
  elementary-tweaks libgranite5
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 269 kB of archives.
After this operation, 1,708 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://ppa.launchpad.net/philip.scott/elementary-tweaks/ubuntu focal/main amd64 elementary-tweaks amd64 1.0-0~202010170103~ubuntu6.0.1 [102 kB]
Get:2 http://mirrors.ubuntu.com/mirrors.txt Mirrorlist [413 B]                 
Get:3 http://ubuntu.mirror.snu.edu.in/ubuntu focal/universe amd64 libgranite5 amd64 5.3.0-1 [167 kB]
Fetched 269 kB in 3s (98.7 kB/s)           
(Reading database ... 123628 files and directories currently installed.)
Preparing to unpack .../libgranite5_5.3.0-1_amd64.deb ...
Unpacking libgranite5:amd64 (5.3.0-1) ...
dpkg: error processing archive /var/cache/apt/archives/libgranite5_5.3.0-1_amd64.deb (--unpack):
 trying to overwrite '/usr/share/metainfo/granite.appdata.xml', which is also in package libgranite-common 6.2.0+r2223+pkg122~ubuntu6.1
Selecting previously unselected package elementary-tweaks.
Preparing to unpack .../elementary-tweaks_1.0-0~202010170103~ubuntu6.0.1_amd64.deb ...
Unpacking elementary-tweaks (1.0-0~202010170103~ubuntu6.0.1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/libgranite5_5.3.0-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
[email protected]:~$
later I have tried
Bash:
sudo ls -l /var/lib/dpkg/info | grep -i elementary-tweaks
sudo rm /var/lib/dpkg/info/elementary-tweaks.*
sudo apt remove --purge elementary-tweaks
and yet the output is still the same. Please help me with this error
 

Attachments

  • ERROR.txt
    4.1 KB · Views: 110


OP
Harshith Reddy
Joined
Jun 5, 2021
Messages
66
Reaction score
41
Credits
451
I also tried to install it via synaptic package manager and it shows this error
screenshot-from-2022-02-25-07-54-35-png.11897
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Members online


Top