Dummy sound

Thurlapati koushik

New Member
Joined
Dec 9, 2018
Messages
1
Reaction score
0
Credits
0
I have a Lenovo ThinkPad lap. Recently I have installed openSuse on it. Initially it worked well. But it was unable to play h264 mpeg4 videos. I tried to fix it and finally played the video by the command
zypper in vlc-codec
But later audio was disabled and behaved differently
At the startup it shows up dummy sound. When we connect headphones and remove it then it shows Intel hda audio output (in purvoncon) and worked properly.
Help me solve this.
Thanks.
 


CptCharis

Well-Known Member
Joined
Feb 27, 2018
Messages
562
Reaction score
465
Credits
970
Hello guys ! I have same problem suddenly I lost all hardware from my sound Hardware list:

Screenshot at 2019-01-02 12-30-23.png



but as you can see the output of inxi command, drivers are there:

Screenshot at 2019-01-02 12-30-42.png


any idea? Thanks
 

JasKinasis

Well-Known Member
Joined
Apr 25, 2017
Messages
1,513
Reaction score
2,149
Credits
10,880
I had a problem with dummy audio a while ago that I fixed myself. I posted a thread about it here:
https://www.linux.org/threads/audio-using-dummy-device.18859/

From experience - when audio is being routed through the dummy sound device, and you are unable to see your sound-card in the Alsa or pulseaudio settings - it is usually because Alsa or Pulse are unable to access the sound-card because some other processes is using the device and is blocking access.

To find out which processes have the sound-card open, you can use the command:
Code:
sudo lsof /dev/snd/*

That will tell you which processes are using the sound card.

In my case it was the MIDI daemon Timidity.
For some reason, on startup - timidity was opening the sound-card and blocking Alsa and Pulseaudio from being able to access it. Causing the audio to be routed through a dummy device.

To fix the problem, I simply uninstalled Timidity and then restarted alsa and pulse.

So use lsof - as per my example and see what processes are using the sound-card. Then try shutting those processes down and then restart alsa and pulse. Or uninstall the program that is blocking access and then either restart alsa and pulse - or reboot!
 

CptCharis

Well-Known Member
Joined
Feb 27, 2018
Messages
562
Reaction score
465
Credits
970
I had a problem with dummy audio a while ago that I fixed myself. I posted a thread about it here:
https://www.linux.org/threads/audio-using-dummy-device.18859/

From experience - when audio is being routed through the dummy sound device, and you are unable to see your sound-card in the Alsa or pulseaudio settings - it is usually because Alsa or Pulse are unable to access the sound-card because some other processes is using the device and is blocking access.

To find out which processes have the sound-card open, you can use the command:
Code:
sudo lsof /dev/snd/*

That will tell you which processes are using the sound card.

In my case it was the MIDI daemon Timidity.
For some reason, on startup - timidity was opening the sound-card and blocking Alsa and Pulseaudio from being able to access it. Causing the audio to be routed through a dummy device.

To fix the problem, I simply uninstalled Timidity and then restarted alsa and pulse.

So use lsof - as per my example and see what processes are using the sound-card. Then try shutting those processes down and then restart alsa and pulse. Or uninstall the program that is blocking access and then either restart alsa and pulse - or reboot!
I remember this post @JasKinasis
Actually I found the opportunity to upgrade to 19.1 Tessa and everything went fine.
Thanks for your time.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Staff online

Members online


Top