Dummy Output - OMEN by HP Laptop 16-k0061tx (Ubuntu22.04)

ubenty

New Member
Joined
Mar 10, 2023
Messages
2
Reaction score
0
Credits
23
Hello.
I installed Ubuntu to my OMEN PC and everything goes well except one thing.
I have a problem similar to this post(https://www.linux.org/threads/dummy-output-omen-by-hp-laptop-15-dh0xxx-popos-system.39629/) but I'm using Ubuntu.
My Output Device is 'dummy output' and Input Device is none.

Below is the output of 'inxi -A'.

"""
$ inxi -A
Audio:
Device-1: Intel Alder Lake PCH-P High Definition Audio
driver: snd_hda_intel
Device-2: NVIDIA GA104 High Definition Audio driver: snd_hda_intel
Sound Server-1: ALSA v: k5.19.0-35-generic running: yes
Sound Server-2: PulseAudio v: 15.99.1 running: yes
Sound Server-3: PipeWire v: 0.3.48 running: yes
"""

Do I need to remove PulseAudio with the command `sudo apt purge pulseaudio`, like described on similar post?
And what should I do?

Please help me. Thank you.
 

Attachments

  • Screenshot from 2023-03-12 13-35-58.png
    Screenshot from 2023-03-12 13-35-58.png
    91.5 KB · Views: 212


I see you are referencing the GUI. Usually I control these things in the terminal and the following is how I'd approach it in the first instance. It's all in user domain with no root commands necessary.

You can try disabling and stopping pulseaudio to enable the installed pipewire to service the sound.
Code:
systemctl --user stop pulseaudio.service
systemctl --user disable pulseaudio.service

systemctl --user stop pulseaudio.socket
systemctl --user disable pulsaudio.socket
Check with:
Code:
systemctl --user status pulseaudio
which might look something like:
Code:
○ pulseaudio.service - Sound Service
     Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; enabled; preset: enabled)
     Active: inactive (dead)
TriggeredBy: ○ pulseaudio.socket
to show it's "dead".

Check pipewire and wireplumber:
Code:
[flip@flop]$ systemctl --user status pipewire
● pipewire.service - PipeWire Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; enabled; preset: enabled)
     Active: active (running) since Sun 2023-03-12 05:30:59 AEDT; 14h ago
TriggeredBy: ● pipewire.socket
   Main PID: 1118 (pipewire)
      Tasks: 2 (limit: 9434)
     Memory: 9.9M
        CPU: 47.756s
     CGroup: /user.slice/user-1000.slice/[email protected]/session.slice/pipewire.service
             └─1118 /usr/bin/pipewire

Mar 12 05:30:59 fen systemd[1101]: Started pipewire.service - PipeWire Multimedia Service.

[flip@flop]$ systemctl --user status wireplumber
● wireplumber.service - Multimedia Service Session Manager
     Loaded: loaded (/usr/lib/systemd/user/wireplumber.service; enabled; preset: enabled)
     Active: active (running) since Sun 2023-03-12 05:30:59 AEDT; 14h ago
   Main PID: 1119 (wireplumber)
      Tasks: 4 (limit: 9434)
     Memory: 33.9M
        CPU: 5.318s
     CGroup: /user.slice/user-1000.slice/[email protected]/session.slice/wireplumber.service
             └─1119 /usr/bin/wireplumber
<snip>

If pipeware and wireplumber aren't "running", start them. From your output I suspect they are running.

If there's still a problem, to find out what is controlling your sound devices, run:
Code:
lsof /dev/snd/*

If things are in good order, the output could be something like:
Code:
COMMAND    PID USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
pipewire  1118  flip   46u   CHR  116,1      0t0  342 /dev/snd/seq
pipewire  1118  flip   47u   CHR  116,1      0t0  342 /dev/snd/seq
wireplumb 1119  flip   25u   CHR 116,16      0t0  551 /dev/snd/controlC0
wireplumb 1119  flip   27u   CHR 116,10      0t0  531 /dev/snd/controlC1

This is what I have installed to make it all work:
Code:
[flip@flop]$ dpkg -l | awk '/^ii/ {print $2}' | grep pulse
libpulse-mainloop-glib0:amd64
libpulse0:amd64
libpulsedsp:amd64
pipewire-pulse
pulseaudio
pulseaudio-utils

[flip@flop]$ dpkg -l | awk '/^ii/ {print $2}' | grep pipe
libpipeline1:amd64
libpipewire-0.3-0:amd64
libpipewire-0.3-common
libpipewire-0.3-modules:amd64
pipewire:amd64
pipewire-bin
pipewire-pulse
although pulseaudio is now unnecessary. It's a vestige I haven't removed yet.
 
Last edited:
Perhaps this will help although it didn't work for me.

My sound stopped working after an update which changed the kernel from an LTS kernel to the HWE stack kernel.

The LTS long term support kernel supported my sound card where the HWE stack short term kernel no longer supported my sound card.

I dumped Ubuntu 22.04.2 and installed a Linux distro which uses the LTS kernel and supports my sound card.

Good going Ubuntu developers and hardware manufactures for a stupid move and decision.

One less Linux distro I will no longer send any money to.
 
I'm sorry but it doesn't work for me.

I decided to use WSL2 to my working environment.

Thank you.
 
After looking around on this issue, here are a couple of solutions which may be useful in your case:


The other main change I see is that users apply is to update their kernels, but note this: https://www.linux.org/threads/solved-dummy-output-no-audio-after-os-update.42572/
 
Last edited:


Top