Dual booting with Windows and Pop OS

Hbayram

Member
Credits
257
Yes, that is correct! Just one thing the menu is displayed as 80 lines so the text is really small. İs there a way to switch to 40 so it is more readable?
 


f33dm3bits

Gold Member
Gold Supporter
Credits
24,609
Can you make a picture of what you mean, I don't quite understand what you mean?
 
Last edited:

wizardfromoz

Administrator
Staff member
Gold Supporter
Credits
17,806


(Wizard appears in a puff of smoke, trips over a screenshot of a tiny Grub Menu, curses)

I'm a bit late to the party, had medical issues to attend to last couple of days. Regrets.

G'day @Hbayram and welcome to linux.org :)

My friend @f33dm3bits has looked after you well, he is a clever bugger.

My Pop_OS is an 18.04 upgraded to 20.04, but it has had grub from the beginning, not systemd-boot.

I am aware of the instructions given you, from prior reading, to change from one to the other, but I have not had occasion to use them.

BUT


(Wizard's but follows usually not far behind him) I can assist with the grub menu size.

STEPS


1. First take a snapshot of your system using Timeshift.

2. Save a copy of your file /etc/default/grub . You can do this at the console level, or use a GUI text editor, according to your preference.

If at Terminal, it might be Nano, or Vim or other, if at a GUI level, default Text Editor on Pop_OS's GNOME desktop environment is gedit.

Name the file with an extension of .bak or .save so you can find it easily if you need to rename to the original.

So if you go GUI it might be

Code:
sudo cp -a /etc/default/grub /etc/default/grub.bak

# then (this is a comment of mine, not a command)

sudo gedit /etc/default/grub
I'll come back in a few minutes with further details on the steps.

Cheers

Chris Turner
wizardfromoz
 

wizardfromoz

Administrator
Staff member
Gold Supporter
Credits
17,806
In your opened file of /etc/default/grub , mine shows a few lines like this, so find the similar part of yours

Code:
# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
# CRAP Obsolete use videoinfo
#GRUB_GFXMODE=640x480
Note mine has the additional comment starting with Crap, just my gesture of defiance :)

Almost every Linux Distro known has this line, and it is obsolete. Manjaro is one of only a handful that have it right. So

STEPS (Cont.)


3. When you boot to your blue grub menu, at the bottom will be a line or two, choose the one 'c' for command, it will drop you to a black and white screen with grub prompt.

There, you can try vbeinfo, it will likely tell you the command is not found.

Type in and enter

Code:
videoinfo
and it will list resolutions available to your monitor or laptop screen, with the one in use asterisked. Mine looks like this



You can see mine is on 1920 x 1080.

Take a list or a phone pic while you are there if you like, it can be handy.

Exit by pressing escape back to grub menu or entering reboot. Then

4. The lower the resolution, the larger your font will appear in your grub menu.

So in /etc/default/grub , a logical starting point is with the line

Code:
#GRUB_GFXMODE=640x480
Just delete the # comment at the beginning to try that and you can always experiment further.

5. Save the file, and always after doing so run

Code:
sudo update-grub
before rebooting, or it will not take effect until you do.

BTW as well as the Grub menu, size of your splash icon, if any, may be enlarged, but your desktop session will not be affected.

Let us know how you go, and enjoy your Linux.

Wiz
 

f33dm3bits

Gold Member
Gold Supporter
Credits
24,609
Please find attached.
@wizardfromoz just explained in his last reply how to change the resolution of the grub which makes the font bigger. So that should solve your problem with the font being small on the grub screen.

The other option I found would be the play around with grub-mkfont, replacing ? with a number.
1. sudo grub-mkfont -s ? -o /boot/grub/fonts/unicode.pf2
2. sudo update-grub

I think the option @wizardfromoz explained is the easier option and is the one I would pick for myself if I wanted a bigger font in grub and a smaller grub screen, also because changing the resolution of the grub screen solves the problem from two different angles. I would only use the grub-mkfont option if I actually changed the grub font to a different font type, which I have never done. My way of doing thing is: KISS. Keep It Simple Stupid, in other words don't make thing unnecessarily hard on yourself.
 
Last edited:

wizardfromoz

Administrator
Staff member
Gold Supporter
Credits
17,806
Nice one @f33dm3bits :) - I saw /boot/grub/fonts/unicode.pf2 earlier in my day when I was in Pop_OS but did not proceed further.

So there you go @Hbayram - a couple of tips from Australia and Europe to play with.

Have fun

Wizard out for my evening DownUnder
 

f33dm3bits

Gold Member
Gold Supporter
Credits
24,609
Glad to have helped you out. I'm glad you got your system setup working as you want now, enjoy your PopOS!
 

Hbayram

Member
Credits
257
Been using MS-DOS since version 2 and windows 1.0. but, now that I am retired I wanted to dive into Linux.

Thank you all so much. Even the people and community of system76/pop os couldn't help me.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
24,609
Been using MS-DOS since version 2 and windows 1.0. but, now that I am retired I wanted to dive into Linux.

Thank you all so much. Even the people and community of system76/pop os couldn't help me.
Is your desktop or laptop a System76 system?
 

f33dm3bits

Gold Member
Gold Supporter
Credits
24,609
No, it is an Asus laptop.
I was just wondering because I have heard from other people that System76 has good support when you buy your hardware from them.
 

Hbayram

Member
Credits
257
Althought I love pop os, I haven't been impressed by their community.. they have a chat at for community support. But, my requests was mostly being ignored.

The second distro I was considering was Manjaro.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
24,609
Althought I love pop os, I haven't been impressed by their community.. they have a chat at for community support. But, my requests was mostly being ignored.

The second distro I was considering was Manjaro.
I have read through the Manjaro and EndeavourOS forums and they seem like friendly communities as well. I forgot to welcome you to the community here, if you like and are planning on sticking around feel free to create an introduction topic in the introduction section.
 

captain-sensible

Well-Known Member
Credits
14,330
The second distro I was considering was Manjaro.
@Hbayram we touched on Arch derivative here:

 

ccoto

New Member
Credits
6
I had the same issue with PopOS 20 (installed first) and Win10 and this fixed the issue, it's now showing up the boot up menu properly. Thanks so much

I didn't do a dual-boot setup just a PopOS install with systemd-boot but I figured out how to install grub and to get it working. This is what I did.
1. Install Grub packages: sudo apt install grub-efi
2. Run grub-install: sudo grub-install
3. Copy grub efi file to pop efi location: sudo cp /boot/grub/x86_64-efi/grub.efi /boot/efi/EFI/pop/grubx64.efi
4. Remove systemd-boot: sudo bootctl remove
5. Set time-out in /etc/default/grub to 10 seconds, so this line
Code:
GRUB_TIMEOUT=10
6. Update grub: sudo update-grub
7. Reboot and you should now get a grub menu.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!


Latest posts

Top