Dual boot XP and Puppy- Can't boot XP

F

FitBoot

Guest
Hi.
I am new to this foum (and a few others) and to Linux. With the help of others, I finally got Puppy properly installed and up and running. (whew!).
Using Grub4Dos, I have a new boot loader and can successfully choose Pup at boot.
But although XP shows up in the boot menu, chooing it simply yields a prompt that the machine is trying to start hda0,0 (where it's located, and blinking cursor - no further progress.

My menu.lst file is posted at pastebin at pastebin.com/7RYjUL5B

Please help me get back to being able to boot XP and dual boot this system.

Thanks so much!!

Charla
 


V

Victor Leigh

Guest
The trick to dual booting Windows and Linux is always to install the Windows first, then the Linux. And put your Windows in the primary partition. Wipe out everything and start again. I know it can work because I have made it work. Many times.

btw why do you use Windows XP? I have tried Windows 8 and it's lighter than Windows XP. At the moment, Windows 8 is free, too.
 
F

FitBoot

Guest
Hi Vistor,
Thanks very much.
Yes, Windows is installed first (and has worked fine including everything giving me the option to choose it when I tried Ubuntu briefly - it's too heavy for olde rsystem)
So I just need to know what's wrong in the bootloader that I can no longer get XP to fully load and run.

I use XP b/c ithink it's about the last quality thing MS delivered AND I use software critical to me that will not run on anything after that.
Good to go there - not looking for any updates from MS.
Just want to get the dual boot responding properly.

Thank you!!
 
B

Bill

Guest
FitBoot, I would download a boot loader call GAG here http://gag.sourceforge.net/. Burn it and reboot. It will run off of the installation disk. Just don't select the save changes option and your computer will be unchanged the next time you boot. Select "Add new" or however it is worded, select the Windows partition, don't give it a password and give it whatever icon you want. Go back to the main menu and try to boot that partition up. If it boots, then Grub has issues. If it does not, then Windows probably has issues. At least this will tell us which one likely has the issues.

Let me know how this works.
 
V

Victor Leigh

Guest
Just thought of something. Run Grub4Dos again and see whether Windows is detected as a bootable partition. By default, the Windows option always shows in the menu even if Windows is not detected.
 
F

FitBoot

Guest
Hi Victor,
Just ran Grub4Dos bootloader config again. Yes, it shows Windows XP Pro. New menu.lst follows:

# menu.lst produced by grub4dosconfig-v1.7.2
color white/blue black/cyan white/black cyan/black
timeout 10
default 0

# Frugal installed Puppy

title Lupu 528 (sdb1/puppy528)
find --set-root --ignore-floppies --ignore-cd /puppy528/initrd.gz
kernel /puppy528/vmlinuz psubdir=puppy528 pmedia=atahd pfix=fsck
initrd /puppy528/initrd.gz

title Lupu 528 (sdb1/puppy528) RAM mode\nBoot up Puppy without pupsave
find --set-root --ignore-floppies --ignore-cd /puppy528/initrd.gz
kernel /puppy528/vmlinuz psubdir=puppy528 pmedia=atahd pfix=ram,fsck
initrd /puppy528/initrd.gz

# Windows
# this entry searches Windows on the HDD and boot it up
title Windows\nBoot up Windows if installed
errorcheck off
find --set-root --ignore-floppies --ignore-cd /bootmgr
chainloader /bootmgr
find --set-root --ignore-floppies --ignore-cd /ntldr
chainloader /ntldr
find --set-root --ignore-floppies --ignore-cd /io.sys
chainloader /io.sys
errorcheck on

# Boot from Partition Boot Sector

title Microsoft Windows XP Professional (sda1:pBS)
uuid AE10CB0010CACE91
chainloader +1

title Lupu 528 (sdb1:pBS)
map (hd1) (hd0)
map (hd0) (hd1)
map --hook
uuid 56683dc8-1067-481a-9a31-c42ee5c3dbf4
chainloader +1

# additionals

title Find Grub2\nBoot up grub2 if installed
find --set-root --ignore-floppies --ignore-cd /boot/grub/core.img
kernel /boot/grub/core.img

title Grub4Dos commandline\n(for experts only)
commandline

title Reboot computer
reboot

title Halt computer
halt

Trying reboot now to see what happens or if anything changed. Will report.
Thank you so much for your assistance.

Charla
 
F

FitBoot

Guest
Update

Okay, Chose Windows XP at boot and startup currenlt still stuck with message:
"Setting root to (Hd0,0
Filesystemtype is NTFS, partition type0x83

Any ideas?

Thank you very much,

Charla
 
B

Bill

Guest
You may not like this option, but this is my opinion. Get am XP iso file, burn it to a disk, boot the disk, repair XP, then boot an Ubuntu live disk, reinstall grub2, and you should be good to go.
 

Members online


Latest posts

Top