dnf/yum (Curl could not resolve proxy, while no proxy in use only routing on another PC to provide internet access) error/problem

My Linux installation has a problem, that spits errors out, whenever the build in repo updater gets activated. An example: I'm trying to execute a command, that is not available. When the package manager tries to show what package I would have to install to use the command I get this error message:
Code:
Die Suche nach der Datei ist fehlgeschlagen: cannot update repo 'fedora-modular': Cannot prepare internal mirrorlist: Curl error (5): Couldn't resolve proxy name for https://mirrors.fedoraproject.org/metalink?repo=fedora-modular-31&arch=x86_64 [Unsupported proxy syntax in 'http://:8080/']; Last error: Curl error (5): Couldn't resolve proxy name for https://mirrors.fedoraproject.org/metalink?repo=fedora-modular-31&arch=x86_64 [Unsupported proxy syntax in 'http://:8080/']
For information:
Code:
Die Suche nach der Datei ist fehlgeschlagen:
means, that the search after the file went wrong.
The irony is, that I am not using a proxy, I'm only routing my network traffic on another PC.
I hope somebody knows a solution to this, because every other help didn't work.
Yes, I have cleared all environment variables.

Thanks

P.S.: I am using Fedora 31 with KDE And I'm sorry, if I posted this in the wrong subforum
 


dos2unix

Well-Known Member
Credits
1,466
Can you give output from 'dnf repolist'
and 'ls /etc/yum.repos.d'

Also perhaps ... 'grep enabled /etc/yum.repos.d/*repo'
 
For the first one:
Code:
Paketquellen-ID                                          Paketquellen-Name:
adobe-linux-i386                                         Adobe Systems Incorporated
adobe-linux-x86_64                                       Adobe Systems Incorporated
brave-browser-rpm-release.s3.brave.com_x86_64_           created by dnf config-manager from https://brave-browser-rpm-release.s3.brave.com/x86_64/
fedora                                                   Fedora 31 - x86_64
fedora-cisco-openh264                                    Fedora 31 openh264 (From Cisco) - x86_64
fedora-modular                                           Fedora Modular 31 - x86_64
google-chrome                                            google-chrome
rpmfusion-free                                           RPM Fusion for Fedora 31 - Free
rpmfusion-free-updates                                   RPM Fusion for Fedora 31 - Free - Updates
rpmfusion-nonfree                                        RPM Fusion for Fedora 31 - Nonfree
rpmfusion-nonfree-steam                                  RPM Fusion for Fedora 31 - Nonfree - Steam
rpmfusion-nonfree-updates                                RPM Fusion for Fedora 31 - Nonfree - Updates
updates                                                  Fedora 31 - x86_64 - Updates
updates-modular                                          Fedora Modular 31 - x86_64 - Updates
virtualbox                                               Fedora 31 - x86_64 - VirtualBox
Sorry, if the descriptions is German
For the second one:
Code:
/etc/yum.repos.d/adobe-linux-i386.repo:enabled=1
/etc/yum.repos.d/adobe-linux-x86_64.repo:enabled=1
/etc/yum.repos.d/brave-browser-rpm-release.s3.brave.com_x86_64_.repo:enabled=1
/etc/yum.repos.d/_copr_phracek-PyCharm.repo:enabled=0
/etc/yum.repos.d/_copr_phracek-PyCharm.repo:enabled_metadata=1
/etc/yum.repos.d/fedora-cisco-openh264.repo:enabled=1
/etc/yum.repos.d/fedora-cisco-openh264.repo:enabled_metadata=1
/etc/yum.repos.d/fedora-cisco-openh264.repo:enabled=0
/etc/yum.repos.d/fedora-modular.repo:enabled=1
/etc/yum.repos.d/fedora-modular.repo:enabled=0
/etc/yum.repos.d/fedora-modular.repo:enabled=0
/etc/yum.repos.d/fedora.repo:enabled=1
/etc/yum.repos.d/fedora.repo:enabled=0
/etc/yum.repos.d/fedora.repo:enabled=0
/etc/yum.repos.d/fedora-updates-modular.repo:enabled=1
/etc/yum.repos.d/fedora-updates-modular.repo:enabled=0
/etc/yum.repos.d/fedora-updates-modular.repo:enabled=0
/etc/yum.repos.d/fedora-updates.repo:enabled=1
/etc/yum.repos.d/fedora-updates.repo:enabled=0
/etc/yum.repos.d/fedora-updates.repo:enabled=0
/etc/yum.repos.d/fedora-updates-testing-modular.repo:enabled=0
/etc/yum.repos.d/fedora-updates-testing-modular.repo:enabled=0
/etc/yum.repos.d/fedora-updates-testing-modular.repo:enabled=0
/etc/yum.repos.d/fedora-updates-testing.repo:enabled=0
/etc/yum.repos.d/fedora-updates-testing.repo:enabled=0
/etc/yum.repos.d/fedora-updates-testing.repo:enabled=0
/etc/yum.repos.d/google-chrome.repo:enabled=1
/etc/yum.repos.d/rpmfusion-free.repo:enabled=1
/etc/yum.repos.d/rpmfusion-free.repo:enabled=0
/etc/yum.repos.d/rpmfusion-free.repo:enabled=0
/etc/yum.repos.d/rpmfusion-free-updates.repo:enabled=1
/etc/yum.repos.d/rpmfusion-free-updates.repo:enabled_metadata=1
/etc/yum.repos.d/rpmfusion-free-updates.repo:enabled=0
/etc/yum.repos.d/rpmfusion-free-updates.repo:enabled=0
/etc/yum.repos.d/rpmfusion-free-updates-testing.repo:enabled=0
/etc/yum.repos.d/rpmfusion-free-updates-testing.repo:enabled_metadata=0
/etc/yum.repos.d/rpmfusion-free-updates-testing.repo:enabled=0
/etc/yum.repos.d/rpmfusion-free-updates-testing.repo:enabled=0
/etc/yum.repos.d/rpmfusion-nonfree-nvidia-driver.repo:enabled=0
/etc/yum.repos.d/rpmfusion-nonfree-nvidia-driver.repo:enabled_metadata=1
/etc/yum.repos.d/rpmfusion-nonfree-nvidia-driver.repo:enabled=0
/etc/yum.repos.d/rpmfusion-nonfree-nvidia-driver.repo:enabled=0
/etc/yum.repos.d/rpmfusion-nonfree.repo:enabled=1
/etc/yum.repos.d/rpmfusion-nonfree.repo:enabled_metadata=1
/etc/yum.repos.d/rpmfusion-nonfree.repo:enabled=0
/etc/yum.repos.d/rpmfusion-nonfree.repo:enabled=0
/etc/yum.repos.d/rpmfusion-nonfree-steam.repo:enabled=1
/etc/yum.repos.d/rpmfusion-nonfree-steam.repo:enabled_metadata=1
/etc/yum.repos.d/rpmfusion-nonfree-steam.repo:enabled=0
/etc/yum.repos.d/rpmfusion-nonfree-steam.repo:enabled=0
/etc/yum.repos.d/rpmfusion-nonfree-updates.repo:enabled=1
/etc/yum.repos.d/rpmfusion-nonfree-updates.repo:enabled_metadata=1
/etc/yum.repos.d/rpmfusion-nonfree-updates.repo:enabled=0
/etc/yum.repos.d/rpmfusion-nonfree-updates.repo:enabled=0
/etc/yum.repos.d/rpmfusion-nonfree-updates-testing.repo:enabled=0
/etc/yum.repos.d/rpmfusion-nonfree-updates-testing.repo:enabled_metadata=0
/etc/yum.repos.d/rpmfusion-nonfree-updates-testing.repo:enabled=0
/etc/yum.repos.d/rpmfusion-nonfree-updates-testing.repo:enabled=0
/etc/yum.repos.d/virtualbox.repo:enabled=1
The content of /etc/yum.repos.d/fedora-modular.repo is:
Code:
[fedora-modular]
name=Fedora Modular $releasever - $basearch
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Modular/$basearch/os/
metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-modular-$releasever&arch=$basearch
enabled=1
#metadata_expire=7d
repo_gpgcheck=0
type=rpm
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=False

[fedora-modular-debuginfo]
name=Fedora Modular $releasever - $basearch - Debug
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Modular/$basearch/debug/tree/
metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-modular-debug-$releasever&arch=$basearch
enabled=0
metadata_expire=7d
repo_gpgcheck=0
type=rpm
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=False

[fedora-modular-source]
name=Fedora Modular $releasever - Source
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Modular/source/tree/
metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-modular-source-$releasever&arch=$basearch
enabled=0
metadata_expire=7d
repo_gpgcheck=0
type=rpm
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=False
That's were all the enabled=0's come from

Thanks
 
Last edited:

dos2unix

Well-Known Member
Credits
1,466
That's a lot of repo's, I'm impressed.

Just for a test, what if you try disabling the fedora-modular repo, and then re-running the
command. (I know, you don't want to leave it disabled).
If everything else works, then I'm guessing either your repo file or you gpg-key got messed up.

after this. dnf clean all

then run your regular update or install comands.
 
  • Like
Reactions: Rob
I disabled it and this is the output:
Code:
[[email protected] ~]$ yarn
bash: yarn: Befehl nicht gefunden...
Die Suche nach der Datei ist fehlgeschlagen: cannot update repo 'updates': Cannot prepare internal mirrorlist: Curl error (5): Couldn't resolve proxy name for https://mirrors.fedoraproject.org/metalink?repo=updates-released-f31&arch=x86_64 [Unsupported proxy syntax in 'http://:8080/']; Last error: Curl error (5): Couldn't resolve proxy name for https://mirrors.fedoraproject.org/metalink?repo=updates-released-f31&arch=x86_64 [Unsupported proxy syntax in 'http://:8080/']
[[email protected] ~]$ dnf clean all
95 Dateien entfernt
[[email protected] ~]$ yarn
bash: yarn: Befehl nicht gefunden...
Die Suche nach der Datei ist fehlgeschlagen: cannot update repo 'updates': Cannot prepare internal mirrorlist: Curl error (5): Couldn't resolve proxy name for https://mirrors.fedoraproject.org/metalink?repo=updates-released-f31&arch=x86_64 [Unsupported proxy syntax in 'http://:8080/']; Last error: Curl error (5): Couldn't resolve proxy name for https://mirrors.fedoraproject.org/metalink?repo=updates-released-f31&arch=x86_64 [Unsupported proxy syntax in 'http://:8080/']
 


Staff online

Members online


Top