Solved Disable transparenthugepage

Solved issue

solidsnake

New Member
Joined
Oct 6, 2021
Messages
15
Reaction score
1
Credits
280
I am trying to disable transparent hugepage on the server.

in the following command output it says to add transparent_hugepage=never".

When I ran this command, the UUID part did not come as follows. So I did some research and found that it belongs to the swap directory so I added it (I think I made a mistake)

Code:
[root@dataserver~]# cat /etc/default/grub
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="resume=UUID=94279fa2-b457-46c9-b782-6a60a76416e2 rhgb quiet transparent_hugepage=never"
GRUB_CMDLINE_LINUX="rhgb quiet"
GRUB_DISABLE_RECOVERY="true"

Code:
cat /sys/kernel/mm/transparent_hugepage/enabled
when I run this command I get the following output.

Code:
[always] madvise never

In order for the setting to be made correctly, it should come as follows.

always madvise [never]

Where do I need to delete or add parameters in the output below?

Code:
[root@dataserver~]# cat /etc/default/grub
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="resume=UUID=94279fa2-b457-46c9-b782-6a60a76416e2 rhgb quiet transparent_hugepage=never"
GRUB_CMDLINE_LINUX="rhgb quiet"
GRUB_DISABLE_RECOVERY="true"
 


I am trying to disable transparent hugepage on the server.



In order for the setting to be made correctly, it should come as follows.

always madvise [never]

Where do I need to delete or add parameters in the output below?
The kernel docs suggest the following:
Transparent Hugepage Support for anonymous memory can be entirely disabled
(mostly for debugging purposes) or only enabled inside MADV_HUGEPAGE
regions (to avoid the risk of consuming more memory resources) or enabled
system wide. This can be achieved with one of::

echo always >/sys/kernel/mm/transparent_hugepage/enabled
echo madvise >/sys/kernel/mm/transparent_hugepage/enabled
echo never >/sys/kernel/mm/transparent_hugepage/enabled
Those settings should be able to be set in /etc/sysctl.conf using the format which that file requires which is evident from the settings already present in the file.
 
The kernel docs suggest the following:

Those settings should be able to be set in /etc/sysctl.conf using the format which that file requires which is evident from the settings already present in the file.

i do this step and now the never option seems to be selected.

Code:
cat /sys/kernel/mm/transparent_hugepage/enabled
always madvise [never]

I'm not really sure if it happened
 
i do this step and now the never option seems to be selected.

Code:
cat /sys/kernel/mm/transparent_hugepage/enabled
always madvise [never]

I'm not really sure if it happened
It looks like the setting has been set from that output. Presumably we have to trust the kernel.
 
It looks like the setting has been set from that output. Presumably we have to trust the kernel.
After restarting the server, it went back to what it was before.

I did the same on 3 servers but I don't understand why this happened on this server?
 
in the following command output it says to add transparent_hugepage=never".
After adding that to your grub configuration you need to update you grub, by running the following, path may differ depending on what distribution you are using.
Code:
grub2-mkconfig -o /boot/grub2/grub.cfg (BIOS)
grub2-mkconfig -o /boot/efi/EFI/redhat/grub.cfg (UEFI)
Then reboot your system.
 
Bunu grup yapılandırmanıza ekledikten sonra grubunuzu güncellemeniz gerekir, aşağıdakileri çalıştırarak yol, kullandığınız dağıtıma bağlı olarak farklılık gösterebilir.
[KOD]
grub2-mkconfig -o /boot/grub2/grub.cfg (BIOS)
grub2-mkconfig -o /boot/efi/EFI/redhat/grub.cfg (UEFI)
[/KOD]
Daha sonra sisteminizi yeniden başlatın.
tavsiye için teşekkürler

Efi sistemi kullanıyordum ve efi sistemi için ayarların farklı olabileceğini düşünmüyordum.

Kafamı karıştıran şeylerden biri sistemimde GROUP_CMDLINE_LINUX parametresinde hiçbir şey olmaması.

Diğer sistemlerimde "UUID'yi sürdür" ifadesi var ve genellikle takas alanının UUID numarası çıkıyor.
GRUB_CMDLINE_LINUX=devam=UUID=

Code:
cat /etc/default/grub
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="$(sed 's, yayın .*$,,g' /etc/system-release)"
GRUB_DEFAULT=kaydedildi
GRUB_DISABLE_SUBMENU=doğru
GRUB_TERMINAL_OUTPUT="konsol"
GRUB_CMDLINE_LINUX = "hgb sessiz"
GRUB_DISABLE_RECOVERY = "doğru"
 
This is an English speaking forum, please reply in English I don't understand your latest reply?
 

Staff online

Members online


Top