Difficulty getting WiFi Dongle to work in Kali on Virtual Box (Seen similar thread but poster won't give decent details)


New Member
Aug 18, 2021
Reaction score
Ok so as I mentioned I've seen someone else post this issue regarding their NetGearA6210 but there aren't many detail on that person's particular problem. People seemed willing to help but the original poster seemed unresponsive.


I am running Kali Linux 2021.2 from their premade VirtualBox .ova file off the website. The host system is running Windows 10 Home build 19042.685
I am trying to get my NetGear A6210 WiFi adapter to work but have been unsuccessful thus far after watching videos and reading forums nothing has seemed to work. I'm not brand new to Linux although I am a bit inexperienced, especially with Kali.

Here's what I've tried:

Created a filter for the adapter.
I've set the filter to "Yes" under remote
I've created a new filter and manually entered the Vendor and Product ID
When I boot Kali in VBox, after the OS fully loads, I plug in my adapter, select NetGear under devices, then I hear the Windows disconnect sound as I should, then the USB icon in VBox flashes with a red dot, then doesn't change to green and goes away. Afterward, nothing happens and nothing is shown.

I'd love to dive more into Linux, and especially move over my RE and programming things to Linux rather than continue to fuss with Windows. Any help is appreciated thank you!

Welcome to the Forum,
When running in virtual box you can not use the wifi Virtualbox uses the host's wifi or networking.
It does not directly work with wifi.
From Vritualbox forums: "VirtualBox does not offer a WiFi adapter to any VMs, it's only Ethernet adapters, i.e. wired ones.

The only way that you could access a WiFi network over WiFi would be to use a USB WiFi adapter, which 1) you'd have to capture in your VM, and 2) you wouldn't be able to use on your host."
Thanks for the welcome and the response,

Yes I am attempting to use the NetGear A6210 USB Wifi adapter through VirtualBox, I've added a device filter and have tried to Capture the USB. VirtualBox claims it's captured, but I'm not seeing anything in Kali that shows it's recognized, even with lsusb
If you want to actually learn Linux start with a distribution such as Ubuntu or Mint, Kali is a distribution for those who know what they are doing and can solve most of their own problems when it comes to Linux.
to get your WIFI working you need tow things
  • First The WIFI adapter must be connected by USB
  • 2nd kali Linux supported WIFI adapter
to get your WIFI working you need tow things
  • First The WIFI adapter must be connected by USB
  • 2nd kali Linux supported WIFI adapter

I think that's where I'm messing up at, I don't think it's inherently supported by Kali, I'm searching for a driver now... Thanks!
If you have assigned that usb wifi adapter to your virtual system you can try using this driver, I'm not sure if it still works for more recent kernels because it hasn't been updated in 4 years. The instructions of how to install it are in the README.md.
In short.
git clone https://github.com/jurobystricky/Netgear-A6210
cd Netgear-A6210
sudo make install
Then reboot your system and see if it recognizes it, if that works I would use dkms so that when you have a kernel update it will automatically rebuild the kernel module for it.

Members online