Purchase Linux CDs / DVDs / Flash Drives at OSDisc.com

Welcome to Our Community

While Linux.org has been around for a while, we recently changed management and had to purge most of the content (including users). If you signed up before April 23rd, 2017 please sign up again. Thanks!

  1. Follow us on twitter - we shoot all of our new original content out as well as random messages. https://twitter.com/linuxdotorg
    Dismiss Notice

dhcpcd crashes on Raspberry pi

Discussion in 'Linux Networking' started by charles linquist, Mar 14, 2019.

  1. charles linquist

    charles linquist New Member

    Joined:
    Oct 27, 2018
    Messages:
    5
    Likes Received:
    0
    I'm using a RPi 3 (Stretch) to connect to the internet via a Verizon 4G/LTE USB 'dongle'
    (Pantech UML295) , which presents itself as eth1. On first power up, the Raspberry always hangs at
    'A start job is running for dhcpcd on all interfaces (20s / 1min 42sec)'. At this point, the dongle has a green LED, indicating that a connection has been made, but the Raspberry doesn't respond and the only remedy is a power cycle. Subsequent power cycles (within 10 minutes or so) result in success - the system boots properly and the internet connection is made. I assume there is some 'lease time' in Verizon's network that is allowing it to boot properly the second and subsequent times. But I need it to connect the first time - and every time. Is there something that I could adjust, or some log file that I could access that might tell me what is going on?


    (Log in to hide this advertisement)

     

Share This Page