Dependency error while installing wine

Tobiothan

New Member
Credits
0
Hello Everyone,

Linux Mint 19.1 Cinnamon; version 4.0.10;

I have had linux for over a year now, and I'm finally committing to installing wine. However I am running into the same issues I always have, and I am in way over my head regarding fixing them. Below has been my process so far.

sudo dpkg --add-architecture i386
wget -nc https://dl.winehq.org/wine-builds/winehq.key
sudo apt-key add winehq.key
sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main'
sudo apt install --install-recommends winehq-stable

This last command provides the following output

The following packages have unmet dependencies:
libfaudio0 : Depends: libsdl2-2.0-0 (>= 2.0.8) but it is not going to be installed
libfaudio0:i386 : Depends: libsdl2-2.0-0:i386 (>= 2.0.8) but it is not going to be installed
winehq-stable : Depends: wine-stable (= 5.0.0~bionic)
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

So I started with libsdl2-2.0-0:i386 as both of the other dependencies listed it as a dependency.

sudo apt install --install-recommends libsdl2-2.0-0:i386

The results:

The following packages have unmet dependencies:
libfaudio0 : Depends: libsdl2-2.0-0 (>= 2.0.8) but it is not going to be installed
libsdl2-2.0-0:i386 : Depends: libasound2:i386 (>= 1.0.27)
Depends: libpulse0:i386 (>= 0.99.1) but it is not going to be installed
Depends: libsndio6.1:i386 (>= 1.1.0) but it is not going to be installed
Depends: libwayland-client0:i386 (>= 1.9.91) but it is not going to be installed
Depends: libwayland-cursor0:i386 (>= 1.0.2) but it is not going to be installed
Depends: libwayland-egl1-mesa:i386 (>= 10.0.2) or
libwayland-egl1:i386
Depends: libxcursor1:i386 (> 1.1.2) but it is not going to be installed
Depends: libxi6:i386 (>= 2:1.2.99.4) but it is not going to be installed
Depends: libxinerama1:i386 but it is not going to be installed
Depends: libxkbcommon0:i386 (>= 0.5.0) but it is not going to be installed
Depends: libxrandr2:i386 (>= 2:1.2.99.3) but it is not going to be installed
Depends: libxss1:i386 but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

So I went through and ran install on everything in that list, but all of them return

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
libfaudio0 : Depends: libsdl2-2.0-0 (>= 2.0.8) but it is not going to be installed
libfaudio0:i386 : Depends: libsdl2-2.0-0:i386 (>= 2.0.8) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

and by the end of it, nothing appears to have changed. After some Googling I ran

sudo dpkg -i libfaudio0_19.07-0~bionic_amd64.deb libfaudio0_19.07-0~bionic_i386.deb

Hoping this would install those dependencies, but the results (below) suggest they need the same dependencies. And now I have two broken packages sitting in my package manager.

(Reading database ... 325416 files and directories currently installed.)
Preparing to unpack libfaudio0_19.07-0~bionic_amd64.deb ...
Unpacking libfaudio0:amd64 (19.07-0~bionic) over (19.07-0~bionic) ...
Preparing to unpack libfaudio0_19.07-0~bionic_i386.deb ...
Unpacking libfaudio0:i386 (19.07-0~bionic) over (19.07-0~bionic) ...
dpkg: dependency problems prevent configuration of libfaudio0:amd64:
libfaudio0:amd64 depends on libsdl2-2.0-0 (>= 2.0.8); however:
Package libsdl2-2.0-0 is not installed.

dpkg: error processing package libfaudio0:amd64 (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libfaudio0:i386:
libfaudio0:i386 depends on libsdl2-2.0-0 (>= 2.0.8).

dpkg: error processing package libfaudio0:i386 (--install):
dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Errors were encountered while processing:
libfaudio0:amd64
libfaudio0:i386

Any help is appreciated. :)
 


Vrai

Well-Known Member
Credits
1,635
Just checking:
Did you see the notes here;
and here;
regarding installing Wine on Ubuntu 18.04/Linux Mint 19.x.
"do not provide FAudio, which is a dependency of current Wine. Follow the instructions in https://forum.winehq.org/viewtopic.php?f=8&t=32192 to install FAudio from the OBS. "

and follow the advice?
 

Tobiothan

New Member
Credits
0
Hello Vrai,

Thank you for taking the time to type out a response for me. I think you put everything in an understandable place for me to figure this out.

I have had all of those pages open throughout the process, and have been trying to do everything in the correct order. The OBS page was the most daunting so I had been avoiding it, but going back to it. everything makes more sense after seeing these errors.

Solution:

Going through the OBS downloads area, it successfully downloads the FAudio for amd64, but I receive a Red error bar at the top of the FAudio for i386 stating:

Error: Cannot install 'libsdl2-2.0-0:i386'

I had to command line install libsdl2-2.0-0:i386 after installing FAudio for amd64, then install FAudio for i386, then go back to FAudio for amd64 to install 2 additional packages.

Which seems a bit strange, but the wine installer seems to have worked after that, and I have wine on my computer.
 

Vrai

Well-Known Member
Credits
1,635
Awesome!
Good for you for sticking with it, doing the work, and getting stuff working!
Very impressive :)
Good job - well done.

P.S. I think I learned the most about running Linux when I was trying to fix stuff which did not work or was broke. I guess that makes sense though.
 


Members online


Latest posts

Top