Dell latitude xt mouse buttons not working *please help


New Member
Mar 20, 2023
Reaction score
having issues with linux on my latitude xt where the buttons below the touchpad dont work, but the buttons above do (has similar trackstick setup to thinkpads)
im able to use the mouse this way just fine but its just annoying not being able to use the full function of the laptop, and not having the buttons working is a real headache.

this had lubuntu 18.0.4 installed and had zero mouse issues but the touchscreen and stylus/pen didnt work. Ended up installing linuxmint xfce for a more modern, but still lightweight linux distro and thats when the mouse issue started.

distros where lower buttons worked
lubuntu 18.0.4

all distros ive tried where lower mouse buttons didnt work
newest version of lubuntu
linuxmint xfce
peppermint os

tested antiX (legacy version) and the live version on a usb drive gave me full mouse function, oddly enough after installation the buttons stopped working.

now ive installed zorin os lite and its amazing, battery is at 16% capacity (replacing soon, got the laptop for free) and lasts 21 minutes where as its only ever lasted 4-5 minutes on the other distros and runs slightly cooler ive found.

very new to linux but now that my testing and problem solving has some more useful information and weight to it, im hoping someone with much more knowledge than me can see what the issue is and how to fix it.

thank you for reading!

Members online