Dell Latitude D630 Laptop install challenge



atanere

Well-Known Member
Yes, It lives! And we got the printer driver working as well, All by myself. Thanks.
Great! As you get the hang of it, you'll continue to find it easier to fix issues by yourself... you and Google. That's a big part of the learning process: properly phrasing your questions to Google. That is mostly how we help others... looking for other cases of similar problems and how they were solved. It helps us to keep learning too. :D

Cheers
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
I guess that means the wireless is working now! :cool::cool::D:D
And at that point is where I say to Stan (@atanere ) "And that's another fine mess we've got ourselves out of, Stanley!" (paraphrasing a couple of other comedians who were more famous).

I have to go pick up my girl from her art group and fill up the car with petrol for a 2-day road trip she is taking, but when I get back, if the OP (@Old Carpenter Guy , ie Harry) & Staff will indulge me, I would like to summarise the problem and the successful steps taken. I will also provide a series of links that were most helpful to me (No, I did not solve this on my own, lol), and go back as far as I can edit (possibly my entry point at #3 on page 1), and note that the solution was to be found in the later stages. This may be of considerable help to any of The Viewers with similar problems.

Cheers, and keep on rocking with Linux, guys and gals :cool:

Wizard
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
DISCLAIMER

linux.org , despite its name, is not an official organ nor arm of Linux. It subsists on advertising revenues, and subscriptions from some of its Members. The Helpers within this website, and Staff Members whom help keep the place from getting ragged around the edges, are not paid. They are volunteers whom give freely of their time, simply because of their love and enjoyment of Linux in all its shapes and forms, and a desire to help others to achieve their goals.


WIZARD’S GLOSSARY

Wiki - a website or database developed collaboratively by a community of users, allowing any user to add and edit content.

TSOHK - “The School of Hard Knocks” - an imaginary institute where the students are

  • self-taught
  • self-experienced and
  • self boo-booed (a lot in Wizard’s case :))

OP – two (2) meanings
  1. The Original Poster, the person whom started the thread and
  2. The OP’s Original Post, their 1st Post in the thread – the context will tell.


BACKGROUND

The OP has a Dell Latitude with 2 GB of Memory and an 80 GB Hard-drive.

Detailed elsewhere, he has succeeded

  1. in installing Xubuntu-16.04.3-desktop 32-bit on a Packard Bell EasyNote E4710 laptop with 768 MB RAM and a 30 GB HDD. Initially he was looking at Linux Mint 17.0 ‘Qiana’
  2. in installing a Linux Mint 18.3 ‘Sylvia’ on his friend’s laptop, a Toshiba Notebook, designed for Windows Vista, had an AMD Turion(TM) X2-dual-core mobile RM-70, 2.00 ghz processor, along with 3GB ram and 64-bit architecture AND HERE
  3. in installing Linux Mint 18.3 ‘Sylvia’ with the Cinnamon DE on another old laptop he has acquired, a Dell Latitude D630 (circa 2008) with 2 GB RAM and an 80 GB HDD
This latter challenge brings us into this Thread, and the problem Old Carpenter Guy, aka Harry, faces, is not due to any shortcomings on his own part, but rather on the limitations imposed by the manufacturer, Broadcom, of his WiFi chip, in not accommodating Linux.

It was determined from the output of

Code:
inxi -Fxs
that the chip was a Broadcom BCM4312 with 802.11 b/g capability and additional information indicated “LP-PHY”, which, as noted by @atanere (Stan) “makes it a bit special”.

This also put the card into a category of “STA” (I am not familiar with this term) which also is known as bcmwl-kernel-source (the wl part refers to wireless software in the Linux Kernel).

On the basis of this information, a link to this page

http://antojose.com/content/solved-how-get-broadcom-bcm4312-80211bg-lp-phy-wirelesswlanwifi-adapter-working-ubuntu-1404

was provided, followed by a link to this page

https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx

These links were well researched, and had a level of currency about them – as in recent input, not money, lol.

The antojose page had in its comments input from 6th December 2015, 9th July 2017 and even 7th March 2018 just past. We try not to give out obsolete information here, in Oz we have a saying “My name is Billy, not Silly”, and I believe that that applies to all of the people here whom help :p

Interestingly enough, if the OP had had this problem with the Linux Mint 17.0 ‘Qiana’ he originally installed on his Packard Bell elsewhere, those methods would likely have worked.

For The Viewers with old Broadcom cards and drivers, the Linux Mint 17 series (17.0 ‘Qiana’, 17.1 ‘Rafaela’, 17.2 ‘Rebecca’ and 17.3 ‘Rosa’) were all built based on Ubuntu’s 14.04 ‘Trusty Tahr’ releases. Being LTS (longterm support), they have currency until April 20 2019, over a year away at time of writing.

So if you are in that category, you may well find these work.

The OP is using Linux Mint 18.3, and the 18 series from LM (18.0 ‘Sarah’, 18.1 ‘Serena’, 18.2 ‘Sonya’’ and 18.3 ‘Sylvia’) are based on Ubuntu’s 16.04 ‘Xenial Xerus’ series.

Somewhere between “Trusty” and “Xenial” (not sure when), linux-firmware-nonfree was made obsolete, and likewise for firmware-b43-lpphy-installer

… has been incorporated into firmware-b43-installer , as is shown with the message the OP got in one of his screenshots :

Package firmware-b43-lpphy-installer is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
firmware-b43-installer

My highlighting.


SUMMARY

So I just took up and ran with the ball after Stan had done a whole lot of the legwork.

What was cool for me was that it worked, because what I know about WiFi (and hardware in general) can be written on the back of a standard postage/postal stamp and leaving room for the entire King James Bible to be transcribed, so I lucked in, lol.


REGRETS

  1. That it took 40 days to solve this problem
  2. That a lady named Tammy, from western Canada, came in partway through and was unable to get a satisfactory answer in a short timeframe, but if she has got an answer elsewhere in the meantime, she might share it with us so that we can add it to our Wiki?


LINKS, CREDITS & CITATIONS

I had not provided these prior to now, because I wanted to see if they worked first, so as to not “muddy the waters” for The Viewers.

First and foremost

CREDIT 1

https://ubuntuforums.org/showthread.php?t=2364232 – Hadaka, from this site, had excellent advice, we did not need to use it all.

BUT (Wizard always has a but) – should the OP’s solution fall over, then the command

Code:
sudo modprobe b43
will likely work. But only for the current session. This can be made more permanent, ie to work from startup.

CREDIT 2

https://andym3.wordpress.com/the-broadcom-wireless-card-guide/

… very good for identifying your Broadcom device, sadly the blog was abandoned in 2012, but with comments as recent as 2014, dates back to 2011.

Also includes instructions on how to install b43-fwcutter amongst different Distros and Families, to extract the necessary parts from the proprietary Windows Broadcom driver.

CREDIT 3

Likewise

http://linuxwireless.sipsolutions.net/en/users/Drivers/b43/

CREDIT 4

If the problem persists, but is solved for a session with the use of

Code:
sudo modprobe b43
then this link https://askubuntu.com/questions/393936/broadcom-b43-driver-again-why-modprobe-b43-manually suggests going to Root via

Code:
sudo i
or I use

Code:
sudo su
and entering the following:

Code:
sudo -i
echo b43  >>  /etc/modules
exit
Congratulations to all and sundry, and to Harry, I am SERIOUSLY looking forward to

On to the next challenge installing a Linksys router to a Satellite to power up another tired old laptop.
Cheers all

Chris Turner
wizardfromoz (get it right, Harry)
 


Members online


Latest posts

Top