Debian Grub 1.99 alters BIOS (confirmed after formatting hard disk)



Hi, I am a long time Windows user and recently try this Debian Wheezy OS. Burn Debian ISO in Windows environment and then select DVD ROM drive to boot first in BIOS.

The first installation of Debian (GNOME) was with multi-boot option that allows booting from hard disk and DVD drive. I then realise my BIOS was altered when the ACER Phoenix BIOS F2 button fails to response but there is the F12 button to select a unique multi-boot environment. I was then able to boot to FreeDOS to install a DOS environment which I then use to load a CD containing DOS BIOS which I then use to flash the ACER provided BIOS. My ACER Phoenix BIOS was restored. I still don't think Debian OS installation can actually alter my BIOS.

The second installallation of Debian (KDE) was only with hard disk booting option. I use ReFIND, hoping to boot to CentOS DVD but the Anaconda boot to command line interface and I don't know what to do do initiate the CentOS disc installation. I then use Live GParted to partition and format the hard disk, hoping the Grub 1.99 will be removed and my original BIOS restored. When I reboot, my BIOS F2 continue not to work with no multi-boot selection (F12) and then the BIOS shows "Operating System not found".

Is the BIOS altered to BIOS-UEFI?

what can I do now? Use my other computer to:-
Try to boot USB operating system?
Try to boot USB Grub?
Try to boot Phoenix Crisis (WINCRIS.exe)?

You've posted this everywhere but without enough information for anyone to help you.

grub2 handles BIOS boot partitions so that should not be the issue. Bootloaders don't write to the BIOS, nor do they write any files into recovery partitions. In fact grub stage 1 lives entirely in the mbr, the other grub stages reside within the OS' file system.

Without any solid info, I can only speculate that it's some kind of vendor specific boot menu or recovery partition which you are overwriting at the partitioning stage...

Once you have the system restored to normal. why not boot from a live cd and post the output of 'fdisk -l' this will gives some idea of the existing partitioning schema.
I bought this Acer laptop in 2011.

I updated my bios to the latest version before installing Debian Wheezy. Maybe the new BIOS contains the disk-loaded UEFI implementation (Developer's UEFI Environment) called DUET or UEFI DUET. Link:

Then during the installation of Wheezy, I used the auto-partition of the entire hard disk. Before that, I tried to manually partition my hard disk but I later encounter the statement that contained something like "use swap for better performance?" (Not sure if I confuse it with CentOS partitioning tool which I tried on another computer).

Now, when I took out my hard disk, I am still not able to enter BIOS setup and later encounter "Operating System not found".

I'm going to read topics to reflash my BIOS at BIOS startup. Need to learn how to reflash the BIOS myself rather than sending the laptop back for servicing and then encounter the same issue again with disk partioning during OS installation.
If you upgraded the BIOS with the upgrade utility from Acer than you are not using DUET. Acer would not use this as an upgrade for regular users.

Again, partitioning the HDD does NOT change the BIOS. Not even a UEFI will be affected by HDD partitions(except that you won't be able to boot if the UEFI BOOT partition is removed). I am using UEFI, partitioning the HDD or removing partitions does not effect it. I think you flashed your BIOS/UEFI with the wrong image. Or something messed up during the flash. Grub cannot change the BIOS. UEFI is not effected by HDD partitions, not in this way. "No operatig system found" is normal if you take the HDD out.

Members online