Debian doesn't boot to GUI

f33dm3bits

Gold Member
Gold Supporter
Credits
5,996
But in this case there is also Intel video card. How to configure /etc/X11/xorg.conf.d/10-nvidia.conf for my laptop?
You should be able to switch off the intel video card in your bios/uefi. Maybe it's tripping over that? I think you have the options between hybrid, or discrete. I think hybrid is nividia and discrete intel, try switching it to hybrid, and then boot and see what happens.
 


iskander

New Member
Credits
157
I have a single video card. I'm asking how to configure /etc/X11/xorg.conf.d/10-nvidia.conf for my laptop, because in prashantpro's case it's configured for two video cards.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
5,996
I have a single video card. I'm asking how to configure /etc/X11/xorg.conf.d/10-nvidia.conf for my laptop, because in prashantpro's case it's configured for two video cards.
You can try leaving intel in there and see what happens, I can't remember if xorg only picks up the devices it can actually find, but you could try it like this. If not you could try it like this:
Code:
Section "ServerLayout"
       Identifier "layout"
       Screen 0 "nvidia"
   EndSection

   Section "Device"
       Identifier "nvidia"
       Driver "nvidia"
       BusID "01:00:0"
       Option "RegistryDwords" "EnableBrightnessControl=1"
   EndSection

   Section "Screen"
       Identifier "nvidia"
       Device "nvidia"
       Option "AllowEmptyInitialConfiguration"
   EndSection
You will probably have to replace BusID with what you have by finding it using lspci | grep -i nvidia from the console.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
5,996
Indeed it's strange, because live Linux Mint and Ubuntu boots well.
Then use Ubuntu 20.04 (LTS) or Linux Mint 20(LTS), they have long term support since stable is what you are looking for and they are Debian based since you are used to Debian.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
5,996
Thanks for your help, but I want to know how to fix such problems.
You learn how to do stuff by trying to fix problems yourself and from experience, not by having other people trying to solve your problems. Read documentation/wiki, try to install the drivers from repositories, if that doesn't work try to install the drivers manually. Live boot from another distribution to see if it works there, if it does then see what drivers are being used so that you have a comparison and can try installing the same drivers. Search log files or system journal for error messages, google the errors you don't understand, try running a command on the command-line and see what happens. Try to manually start your graphical environment and see what errors you come across, if you don't understand the error google the error.
Instead of using the nvidia driver trying using the nouveau driver and see if that works. Find out if your graphics cards has any support for anything special, ie bumbelbee, look what you can find about that. There are lots things you can do you just have to be creative. Have you even tried installing the nouveau driver? --> xserver-xorg-video-nouveau , did you try installing firmware-misc-nonfree?
 
Last edited:

Condobloke

Well-Known Member
Credits
4,560
There is some good advice for you @iskander, You will be a much better Linux user, by being part of the solution.
 

iskander

New Member
Credits
157
Sorry, I dont' want to bother anyone. But before buying laptop in description wasn't mentioned "amd/ati picasso (rev c2)" GPU. So after typing lspsi, I get
Code:
lspci | greo VGA
01:00.0 VGA compatible controller: NVIDIA Corporation TU117M [GeForce GTX 1650 Mobile / Max-Q] (rev a1)
05:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Picasso (rev c2)
I'm interested is there way to disable AMD GPU or to use both of them? I tried to search something in the web, but didn't find something useful.
P.S- Sorry for my poor English.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
5,996
You're not a bother I was just trying to get the point across the whole topic you are basically trying asking other people what to do to solve your problem instead of figuring out what to do yourself. Figuring out how to do it yourself is where you get experience and where you learn from. That being the reason why I explained in different ways how you could work on solving the problem yourself since you said you want to learn how to fix such things yourself.

I don't see how a laptop would be able to use both. You could try disabling the one you don't want to use in the bios/uefi. Try disabling the nvidia card because the drivers for most AMD graphics cards should be in the kernel now days.
 
Last edited:

f33dm3bits

Gold Member
Gold Supporter
Credits
5,996
If that AMC/ATI Picasso graphics cards is an integrated graphics card then yes the nvidia card will be better for gaming. But if you want to game on your system with Linux you are better off use Ubuntu or a rolling release distribution. I know this because I used to run ScientificLinux as my daily driver, and I ran into problems with old libraries and software, I then switched to Ubuntu as my daily driver it became better. I finally switched to Arch a bit over a year ago and it's been the best gaming experience I've had out of all the Gnu/Linux distributions I've ran. So in short for good gaming under Linux you want bleeding edge software and Debian doesn't provide bleeding edge.
 
Last edited:


Members online


Latest posts

Top