CUPS and canon printer in manjaro



Robodoctor

New Member
Credits
71
Which model you are using? Go with your web-browser at 'http://localhost:631/help'. You find more information at printers in linux. You can try to add new printer under the point administration -> printer -> add printer (need root access) and search at drivers-list if your model is available. Otherwise you must install the correct kernel module from canon.
Good luck.
 

nictou

New Member
Credits
11
I got my Pixma MX535 network Scanner/Printer working on wifi after many fruitless CUPS tutorials. The article i found the information was on greg's weblog. It did everything in the GUI instead of CLI ( still learing), but got it done...
  1. install cnijfilter-yourprinter in the AUR (mine is cnijfilter-mx530series)
  2. install cups-bjnp (something "special" Cannon ... idk)
  3. go Print Settings and unlock (padlock top right)
  4. add printer and at enter device URI
  5. enter bjnp://[printer-ip]:8611 (for me bjnp://192.168.188.10:8611)
... my printer is connected to my wireless ap and works flawless now. It worked on win10 and scanning with skanlite on manjaro also worked fine... just printing over wlan was borked (usb direct worked).​
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top