Configuring Debian 11 WIFI Card

mikelosat

New Member
Joined
Sep 21, 2021
Messages
26
Reaction score
2
Credits
181
Hi friends, I installed on my notebook the new version of Debian 11, I noticed that compared to the 10 many names have changed, to give an example from WLAN0 to WLPS20, etc.
Some commands such as "ifconfig" have disappeared and you can restore them by installing "net-tools", etc etc.
I'm having trouble connecting my realtek 8822ce wifi card to my router. I noticed that so many commands and paths have changed.

I managed through the GUI to enter the parameters, the connection is established but apparently the DNS does not solve the addresses despite having compiled the resolv.conf file with nameserver 1.1.1.1, 1.0.0.1.

Can anyone help me



Thank you
 
Last edited:


OP
M

mikelosat

New Member
Joined
Sep 21, 2021
Messages
26
Reaction score
2
Credits
181
It's amazing, I still can't get my rtl8822ce wifi network card to work in 5G mode. The 2.4G mode works great with my ar750 ext router. when I try to connect to the 5g network it's as if the DNS doesn't resolve the names.

I don't know what to try anymore, can anyone suggest something?
 

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,000
Reaction score
964
Credits
9,856
Try installing the firmware-realtek .deb package. That should help.

Move to the bottom of the page and click on "all" and choose the mirror.
It should show you firmware-realtek_20210315-3_all.deb
Save the file to your Downloads directory.
Install the .deb package and reboot.

 
OP
M

mikelosat

New Member
Joined
Sep 21, 2021
Messages
26
Reaction score
2
Credits
181
Yes I already uploaded to usb while installing debian the realtek firmware collection. The package .deb is newer than what you suggested to me and despite this the 5g mode does not work.
 

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
978
Reaction score
630
Credits
7,255
Might want to try and install iwd
Code:
sudo apt install iwd
Configure NetworkManager to use iwd
Code:
sudo gedit /etc/NetworkManager/conf.d/iwd.conf
Note - where it says gedit you may have to substitute for your text editor

adding those two lines:

[device]
wifi.backend=iwd

Disable wpa_supplicant and reboot:
Code:
sudo systemctl mask wpa_supplicant
Code:
reboot
There is a known timing issue where NetworkManager sometimes does not show any wireless networks after a reboot, you can restart iwd to make them re-appear:
Code:
sudo systemctl restart iwd

You can always change it back if it doesn't work
 

dos2unix

Well-Known Member
Joined
May 3, 2019
Messages
1,005
Reaction score
686
Credits
5,053
NetworkManger doesn't really use resolv.conf anymore. Oh it'll eventually print out meta data to it
(sometimes hours or even days, or a couple of reboots later)

What is the output of nmcli con show

I'm guessing you'll have something similar to wlps20 (sometimes it might be System wlps20)

Whatever the name here is... you can configure the dns like this.

nmcli con mod wlps20 ipv4.dns '8.8.8.8,8.8.4.4'

you may have to reboot for it to take effect.
 

dos2unix

Well-Known Member
Joined
May 3, 2019
Messages
1,005
Reaction score
686
Credits
5,053
Might want to try and install iwd
Code:
sudo apt install iwd
Configure NetworkManager to use iwd
Code:
sudo gedit /etc/NetworkManager/conf.d/iwd.conf
Note - where it says gedit you may have to substitute for your text editor

adding those two lines:

[device]
wifi.backend=iwd

Disable wpa_supplicant and reboot:
Code:
sudo systemctl mask wpa_supplicant
Code:
reboot
There is a known timing issue where NetworkManager sometimes does not show any wireless networks after a reboot, you can restart iwd to make them re-appear:
Code:
sudo systemctl restart iwd

You can always change it back if it doesn't work

Interesting, I've never had to do this, but it would be worth trying it.
 
OP
M

mikelosat

New Member
Joined
Sep 21, 2021
Messages
26
Reaction score
2
Credits
181
Might want to try and install iwd
Code:
sudo apt install iwd
Configure NetworkManager to use iwd
Code:
sudo gedit /etc/NetworkManager/conf.d/iwd.conf
Note - where it says gedit you may have to substitute for your text editor

adding those two lines:

[device]
wifi.backend=iwd

Disable wpa_supplicant and reboot:
Code:
sudo systemctl mask wpa_supplicant
Code:
reboot
There is a known timing issue where NetworkManager sometimes does not show any wireless networks after a reboot, you can restart iwd to make them re-appear:
Code:
sudo systemctl restart iwd

You can always change it back if it doesn't work

I followed the steps you have me
suggested, after restarting the service "NetworkMangaer" is no longer running and I can no longer find any network.

I gave the command : sudo systemctl restart iwd

output: Failed to restart iwd.service: Unit iwd.service not found
 
OP
M

mikelosat

New Member
Joined
Sep 21, 2021
Messages
26
Reaction score
2
Credits
181
Can you give output of
iw list | grep dBm
here is the output, as you see the frequencies are detected but there is no transmission in 5ghz of packets.
IMG_20210924_170725.jpg
 

dos2unix

Well-Known Member
Joined
May 3, 2019
Messages
1,005
Reaction score
686
Credits
5,053
Great, that means your card can be a wifi client on every 2.4Ghz and 5Ghz channel it sees.
However, it cannot be an access point (hotspot) on all 5Ghz channels.
If the channel says no IR after it, that means that channel is not allowed "Initiate Radiation"
on that channel. All that really means is, I can't broadcast an SSID on that channel.

If you type

nmcli dev wifi list

Do you see your router's SSID?

If not, try this...

nmcli radio wifi on

if it still doesn't work try this...

nmcli dev wifi rescan

(this can only be ran every so often, if you try too often, it will complain)

nmcli dev wifi list

It should list any SSIDs that are in range.
If you see yours, try this...

sudo nmcli --ask dev wifi connect (SSID)
Password:

Type in your wifi SSID password. You should be good.
 
Last edited:
OP
M

mikelosat

New Member
Joined
Sep 21, 2021
Messages
26
Reaction score
2
Credits
181
NetworkManger doesn't really use resolv.conf anymore. Oh it'll eventually print out meta data to it
(sometimes hours or even days, or a couple of reboots later)

What is the output of nmcli con show

I'm guessing you'll have something similar to wlps20 (sometimes it might be System wlps20)

Whatever the name here is... you can configure the dns like this.

nmcli con mod wlps20 ipv4.dns '8.8.8.8,8.8.4.4'

you may have to reboot for it to take effect.
I can not type it because after giving the command :

sudo systemctl mask wpa_supplicant

the service is masked

I tried to enable the NetworkManager service but it does not restore
 
OP
M

mikelosat

New Member
Joined
Sep 21, 2021
Messages
26
Reaction score
2
Credits
181
Great, that means your card can be a wifi client on every 2.4Ghz and 5Ghz channel it sees.
However, it cannot be an access point (hotspot) on all 5Ghz channels.
If the channel says no IR after it, that means that channel is not allowed "Initiate Radiation"
on that channel. All that really means is, I can't broadcast an SSID on that channel.

If you type

nmcli dev wifi list

Do you see your router's SSID?

If not, try this...

nmcli radio wifi on

if it still doesn't work try this...

nmcli dev wifi rescan

(this can only be ran every so often, if you try too often, it will complain)

nmcli dev wifi list

It should list any SSIDs that are in range.
If you see yours, try this...

sudo nmcli --ask dev wifi connect (SSID)
Password:

Type in your wifi SSID password. You should be good.

1. I see both networks both 2.4 and 5ghz
 
Last edited:

dos2unix

Well-Known Member
Joined
May 3, 2019
Messages
1,005
Reaction score
686
Credits
5,053
Might want to try and install iwd

I agree it's probably better than wpa_supplicant. But it seems it's not ready for primetime on all distro's?

Works great on my Fedora and Ubuntu systems. Not not so much on my redhat.
Seems it wants libc 2.3x or newer?
 
OP
M

mikelosat

New Member
Joined
Sep 21, 2021
Messages
26
Reaction score
2
Credits
181
I agree it's probably better than wpa_supplicant. But it seems it's not ready for primetime on all distro's?

Works great on my Fedora and Ubuntu systems. Not not so much on my redhat.
Seems it wants libc 2.3x or newer?

as you can see the connection in 5ghz mode happens successfully but it is as if the DNS does not solve the names .
 

dos2unix

Well-Known Member
Joined
May 3, 2019
Messages
1,005
Reaction score
686
Credits
5,053
as you can see the connection in 5ghz mode happens successfully but it is as if the DNS does not solve the names .

Two ways to fix that.
But the first question is... can you connect? (even with no dns).

first things first.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top