Cinnamon Clock Font Size Too Small

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Nemo is the File Manager for Cinnamon Desktop Environment (as Windows had Explorer, then Files).

Just click or double-click Computer or Home icons, or off Start Menu Files, and you will get into it.

In Nemo, at Home Folder, click on Menu View - Show Hidden Files/folders, or use shortcut Ctrl-h and files and folder will be revealed.

Cheers

Wizard out for the night
 


atanere

Well-Known Member
I don't really need to learn all the terminal stuff.
No, not all of it. But you will likely need to learn some... at least how to copy/paste commands that you discover on the web, or that others are trying to help you with. The command line is still very relevant and useful... even Windows still has theirs. And Windows is now beginning to include a Linux command line too, as crazy as that may seem!


Don't know what Nemo is or what applet - label actually I don't understand any of it
Not to worry. Just pace yourself, as Wizard said. Much of Linux is now very intuitive and is controlled in the GUI, like Windows. But there are many differences with Linux too, and it takes time.


both Stan's and my approaches work on it so should translate to a full install.
Yes, Wizard and I are both telling you the same thing, except he is working on the original theme and the web instructions I found recommend that you make a copy to work on instead. Both will work to increase your clock size. Much of Linux can be customized with config files, such as the cinnamon.css file that is being focused on at the moment. And sometimes there is no GUI setting that will do what you want, as it seems to be the case for the clock. But with Linux... there are always options!

One simple option might be to install a different clock program. I've recently installed gnome-clocks. It puts an icon on the panel that you need to open to check the time, but it opens a window so that the size should be plenty for you. The benefit I wanted was that it allows multiple clocks in different time zones (plus alarm clock, and timer). So I know when Wizard is sleeping... or should be sleeping! o_O:D This program should be available in your Software Manager or Synaptic Package Manager, if you want to try it out.

Cheers
 

YeahRight

Member
Hi... Actually I wouldn't mind trying what you guys mention first to do before I try a different clock program though I do really appreciate your help and everyone else. Other than this clock issue I'm fine with how Linux Mint looks. Many of the software that came with Mint already uninstalled them. I only have just a few installed, why have the software installed if you aren't never going to use them. For what I use a computer for I don't think I will ever need terminal not saying its a bad thing but truthfully I don't see the need for it, who knows maybe I'm wrong, time will tell. Though I'm glad the option is available and there help if I ever need it thanks to all here.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
So I know when Wizard is sleeping... or should be sleeping! o_O:D
(Indiana Stan worries me some days)

Hey Yeah

I have installed Tina today and will start looking at compiling a video tomorrow morning my time, probably.

Cheers and out

Wiz
 

YeahRight

Member
Nemo is the File Manager for Cinnamon Desktop Environment (as Windows had Explorer, then Files).

Just click or double-click Computer or Home icons, or off Start Menu Files, and you will get into it.

In Nemo, at Home Folder, click on Menu View - Show Hidden Files/folders, or use shortcut Ctrl-h and files and folder will be revealed.

Cheers

Wizard out for the night
Hi...I try your suggestion and when I try to follow your steps this the problem I'm having. When I right click on Cinnamon folder I don't have the Administrator option so I can't see this folder or file Cinnamon.css and I also do have a checkmark on Show hidden files
 

atanere

Well-Known Member
When I right click on Cinnamon folder I don't have the Administrator option so I can't see this folder or file Cinnamon.css
It does not say "Administrator." Near the middle of the right-click context menu, it offers "Open in Terminal" or "Open as Root".... and you want to choose "Open as Root." Then, after it opens the cinnamon folder as root, you can simply double-click the cinnamon.css file and it should open in a text editor (with root privileges). Use CTRL-F in the text editor and start typing (without quotes) "applet-label" and the editor will take you straight to the section you need to add the new font-size value (either pt or em values). Then do a File -> Save on the file, leave the file open, and hit CTRL-ALT-ESC to see the clock change size immediately. If your screen (and panel) goes totally black, just hit CTRL-ALT-ESC again and it should restore. If not big enough, go back to the file, increase the value, save it again, and reload the desktop again until you're happy.

All of the above is assuming you are editing the theme that you are currently using... whether it is the default Mint-Y-Dark or whether you switched to a copy in your home folder.
 

atanere

Well-Known Member
OK, your attachment pic helps. It tells us you are totally in the wrong place. :D I apologize if the instructions to copy your theme into the home folder confused you. It seems that is where you are trying to edit the theme, but you did not copy the theme there correctly. I'd say just delete the .cinnamon folder that is in your home folder for now.

And let's start again... (at least until Wizard gets a video of this process, but maybe that won't be necessary). The steps below should get you to make the clock changes to your current theme (the default Mint-Y-Dark).

1. Open Nemo, your file manager. Near the top, there is an "up arrow" (below the View menu). Click it until you cannot go up anymore. You should see many folders like bin, boot, etc, home, tmp, usr, var (and more probably). If you don't see these folders, stop and let's go over this again.

2. Scroll down to the usr folder and double-click it to enter it.

3. Scroll down to the share folder and double-click it to enter it.

4. Scroll down to the themes folder and double-click it to enter it.

5. Scroll down to the Mint-Y-Dark folder and double-click it to enter it. Don't mix this up with other Mint-Y folders. It must be Mint-Y-Dark.

6. Now... right-click on the cinnamon folder and choose Open as Root.

7. Double-click on the cinnamon.css file to open it with the text editor.

8. Hit CTRL-F (opens a small Find search box) and type (without quotes) "applet-label"

9. Below the font-weight line, add a new line and insert "font-size: 18pt;" -- no quotes, but it does need the colon and semi-colon as shown, and as matches the other entries in this file. Don't capitalize anything.

10. Hit CTRL-S to save the file. Do not close it in case you want to adjust the size.

11. Hit CTRL-ALT-ESC to reload the desktop. If the screen goes black and doesn't restore, hit CTRL-ALT-ESC again and it should come back. (This seems to happen to me regularly.)

12. If the 18pt font is too big or too small, change it in the file, CTRL-S to save it again, and CTRL-ALT-ESC to reload the desktop.

Done!

Yes?
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Nicely put m'man :)

I'm good for doing the video today, on a fresh install of Tina, but it can take me 2 hours to put together and upload a 10 minute vid, so we'll see how we go with this, else video tomorrow.

Hey Yeah -

9. Below the font-weight line, add a new line and insert "font-size: 18pt;" -- no quotes, but it does need the colon and semi-colon as shown, and as matches the other entries in this file.
You'll note some of the lines have a different colour to them. This is a programming convention, to help the Geeks (and us) find things more quickly.

When you get to the point where you have typed in

font-size

and then add the colon to make it

font-size:

... you will see it change colour to that of the line above's text, that means you have the syntax correct. Likewise with the point size or em size.

If you made a mistake and typed 18pts;

instead of

18pt:

... you would see the "s" in a different colour.

With the em value it is based on percentages with the default as 100%.

So the current (small) size is 1 (for 100%, no change).

1.2em is 20% larger, 2.5em would be as big as 250%, that is 150% larger

I just like the points because I understand them better, and it fits with the syntax as well.

Confused? Don't blame you, welcome to Linux and you are doing fine :)

Friday here in Oz, so

Avagudweegend

Wizard
 

YeahRight

Member
OK, your attachment pic helps. It tells us you are totally in the wrong place. :D I apologize if the instructions to copy your theme into the home folder confused you. It seems that is where you are trying to edit the theme, but you did not copy the theme there correctly. I'd say just delete the .cinnamon folder that is in your home folder for now.

And let's start again... (at least until Wizard gets a video of this process, but maybe that won't be necessary). The steps below should get you to make the clock changes to your current theme (the default Mint-Y-Dark).

1. Open Nemo, your file manager. Near the top, there is an "up arrow" (below the View menu). Click it until you cannot go up anymore. You should see many folders like bin, boot, etc, home, tmp, usr, var (and more probably). If you don't see these folders, stop and let's go over this again.

2. Scroll down to the usr folder and double-click it to enter it.

3. Scroll down to the share folder and double-click it to enter it.

4. Scroll down to the themes folder and double-click it to enter it.

5. Scroll down to the Mint-Y-Dark folder and double-click it to enter it. Don't mix this up with other Mint-Y folders. It must be Mint-Y-Dark.

6. Now... right-click on the cinnamon folder and choose Open as Root.

7. Double-click on the cinnamon.css file to open it with the text editor.

8. Hit CTRL-F (opens a small Find search box) and type (without quotes) "applet-label"

9. Below the font-weight line, add a new line and insert "font-size: 18pt;" -- no quotes, but it does need the colon and semi-colon as shown, and as matches the other entries in this file. Don't capitalize anything.

10. Hit CTRL-S to save the file. Do not close it in case you want to adjust the size.

11. Hit CTRL-ALT-ESC to reload the desktop. If the screen goes black and doesn't restore, hit CTRL-ALT-ESC again and it should come back. (This seems to happen to me regularly.)

12. If the 18pt font is too big or too small, change it in the file, CTRL-S to save it again, and CTRL-ALT-ESC to reload the desktop.

Done!

Yes?
I didn't copy anything. What am I supposed to copy and from where? And you want me to delete the Cinnamon folder from pic, but wouldn't that give me computer problems afterward?
 

Attachments

atanere

Well-Known Member
Your pic shows your home folder, with the .cinnamon folder inside it (you created that).

Keep clicking the "up arrow" (under the View menu option) until you can't go up anymore. And go back to my instructions and start again.

I am 99.9% sure that you did not change your theme at any point in this process. You can check by clicking your Start Menu button, and start typing Themes... it will pull up the Themes manager. Check it, and you should see that you are still using Mint-Y-Dark.
 

YeahRight

Member
Your pic shows your home folder, with the .cinnamon folder inside it (you created that).

Keep clicking the "up arrow" (under the View menu option) until you can't go up anymore. And go back to my instructions and start again.

I am 99.9% sure that you did not change your theme at any point in this process. You can check by clicking your Start Menu button, and start typing Themes... it will pull up the Themes manager. Check it, and you should see that you are still using Mint-Y-Dark.
hang on I'm stuck at what I need to do here #9 in your post pic28
 

Attachments

atanere

Well-Known Member
Don't search the cinnamon folder.... open it as root. Inside that folder is a FILE called cinnamon.css. Double click on that to edit. (That's step #7)

You're almost there!
 

YeahRight

Member
Your pic shows your home folder, with the .cinnamon folder inside it (you created that).

Keep clicking the "up arrow" (under the View menu option) until you can't go up anymore. And go back to my instructions and start again.

I am 99.9% sure that you did not change your theme at any point in this process. You can check by clicking your Start Menu button, and start typing Themes... it will pull up the Themes manager. Check it, and you should see that you are still using Mint-Y-Dark.
Yes you're correct I am using that but I never did change anything from the beginning
 

atanere

Well-Known Member
I figured you didn't change it, and I don't think your theme would work if you did... because you didn't set it up correctly. Never mind that now. What you are changing now is the main theme that you are currently using. So at the end of the instructions, the clock will change after you reload the desktop.

You should have a bigger clock any minute now.... any MINUTE! I'm so funny! :D:D:D
 

atanere

Well-Known Member
Close, but not yet. Put two spaces in front of font-size (but it may not matter). What DOES MATTER is that you need a semi-colon at the end of that line. Very important! After you make those changes, CTRL-S to save it, and then CTRL-ALT-ESC (twice if needed) to reload the desktop and see your clock.
 

Members online


Top