change in boot up and shut down duration, with false "sleep"

gwapo

New Member
Joined
Nov 26, 2022
Messages
4
Reaction score
1
Credits
53
Hi, this is not an emergency, more of an annoying quirk that started some time ago and i am not aware of what started it. i have not changed any hardware or replaced anything. i presumed i had deleted something or turned something off by mistake. with this in mind i have since done a total re-install of Ubuntu, twice, thinking some update may fix the issue but it has not. My P.c used to boot up in seconds and shut down even faster, now i have to wait after the password prompt for the PC to go into sleep mode and come out of it again to boot up, and when shutting down it takes several minutes for the power button to shut off, as the machine seems to again go into the sleep mode before shut down.

So. going through the full routine. i turn on the PC, it' turns on as normal to the password prompt. i fill in the password and then immediately i get the "no video input", soon followed by "entering sleep mode". Then the screen goes black as if entering sleep mode. However it does not go into sleep mode. What happens is i see the monitor power button turning on and off 4 times by itself, then the PC opens normally. during this whole time i get no lights flashing on the keyboard at all but the keyboard works fine. Shutting down i get the same messages

If anyone has an idea what could have started this or how to bypass this "sleep mode" diversion i would be grateful. Of course i have checked all cables are fixed tightly. Ive tried ideas on youtube about removing all cables, pressing the power button then putting cables back, but this did nothing to help this problem.

I just thought i'd ask, like i said, this is not a serious issue and i can still use the PC perfectly once it eventually decides to open, it just annoys me how fast my linux machine used to be to start up and shut down compared to now, which is as bad as Windows
 


Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,564
Reaction score
1,270
Credits
13,778

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
5,617
Reaction score
4,696
Credits
34,228

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
5,617
Reaction score
4,696
Credits
34,228

wizardfromoz

Administrator
Staff member
Gold Supporter
Joined
Apr 30, 2017
Messages
8,149
Reaction score
7,035
Credits
31,506
G'day @gwapo and welcome to linux.org :)

I would follow the advice provided by Alex and Brian above (#2 to #4) first, and then if there are still delays, Ubuntu's notorious Unattended Upgrades function may prove to be a culprit, if so, I can tell you how to disable it if you wish.

So go with them first and let us know how you go.

Good luck and

Avagudweegend

Chris Turner
wizardfromoz
 
OP
G

gwapo

New Member
Joined
Nov 26, 2022
Messages
4
Reaction score
1
Credits
53
This may help:

In "Settings", "Power", there is a section "Power Saving Options". Set "Automatic suspend" to "Never" to prevent the computer to go into sleep state.


This is a screen shot of current settings. i have it already set to never have a black screen. there is no option for "sleep mode" as such, but i presume the black screen has that covered. thanks for the suggestion.
 

Attachments

  • Screenshot from 2022-11-27 10-00-49.png
    Screenshot from 2022-11-27 10-00-49.png
    48.5 KB · Views: 32

wizardfromoz

Administrator
Staff member
Gold Supporter
Joined
Apr 30, 2017
Messages
8,149
Reaction score
7,035
Credits
31,506
OP
G

gwapo

New Member
Joined
Nov 26, 2022
Messages
4
Reaction score
1
Credits
53
i used the command mentioned " systemd-analyze blame" to produce this image . the "boot svg. is massive and i had issues posting it here, maybe size or file type. the information means nothing to me and i dont see anything about entering sleep mode or video input issues. if it means anything to anyone , great, otherwise i might just have to live with this in the hope future upgrades fix it. In the meantime i will look into the wizard's "unattended updates" and see if that helps at all. Thanks all for trying. If posting the "boot svg. might help someone spot an issue i will try it again
 

Attachments

  • Screenshot from 2022-11-27 10-47-48.png
    Screenshot from 2022-11-27 10-47-48.png
    33.8 KB · Views: 28

KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
8,157
Reaction score
6,994
Credits
66,234
i used the command mentioned " systemd-analyze blame" to produce this image .

The good news is those are all well within spec. So, your problem is not there. You can eliminate that as a problem.

Also, it's best to use text wrapped in the code tags.

xbWJQxo.png


That way we can highlight your text and do things like searches with modifiers.
 
OP
G

gwapo

New Member
Joined
Nov 26, 2022
Messages
4
Reaction score
1
Credits
53
as an update, i have turned off the unattended upgrades as suggested above. no difference. just in case there was a keyboard issue causing no lights on the keyboard during boot up i tried a different keyboard, no difference. in case there was a monitor issue i changed monitor to stop the "no video input" warning, no difference. i've also done a distribution update, no difference. i've counted the time from when i put my password in, to when the screen actually opens the desktop view, and it is around 35 seconds ,not 4 or 5 like it used to be. from the time i click shut down, it takes a little over a minute for the CPU to shut down, before it was again a handful of seconds. i guess i can live with this extra 2 minutes waiting time and go make a cup of coffee while whatever is happening. thanks all those who gave it a try, i wave the white flag on this.
 

KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
8,157
Reaction score
6,994
Credits
66,234
i wave the white flag on this.

Oh, we have some smart people here. So, there may be other ideas.

From looking at your startup processes, and how long they take, it's not that...

Do you have anything starting that is not starting with a systemd process, perhaps? Maybe something you set to start on boot, maybe something like Stacer?
 

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
5,617
Reaction score
4,696
Credits
34,228
Click on menu....type in 'Startup Applications'....take a screenshot and paste it in your next reply.

That instruction above is for Linux Mint....Ubuntu will be similar if not the same.
 

wizardfromoz

Administrator
Staff member
Gold Supporter
Joined
Apr 30, 2017
Messages
8,149
Reaction score
7,035
Credits
31,506
The above 2 Posts have given me an idea and I will test it on one or two of my stable of distros to be sure.

@gwapo can you let us know what version of Ubuntu you are using, please?

Back on my tomorrow

Wiz
 
$200 Digital Ocean Credit
Get a free VM to test out Linux!


Staff online


Latest posts

Top