Can't restore with Timeshift because I set to automatic update


New Member
Apr 6, 2020
Reaction score
I stupidly installed Uma because of a mistake, and then couldn't be bothered to change it, then I also set it at automatic update, since I anyway don't know enough to choose which update I want.

Now the computer sees my screen as larger than it is or something like that. I want to restore to a previous configuration saved with Timeshift, but since it is set to automatic update, the moment the machine starts, it also updates again, and we are back to the same idiot problem.

By the way, this screen problem also used to happen in the beginning when I had Linux, around four years ago, but then I could fix it by changing the display size to something useless, and then changing it back. This doesn't work now.

I have tried to remove Update Manager from Timeshift, but as I understand, that will only change the new updates. The latest experiment was to look at the oldest previous saved snapshot, click at "browse files", and then I removed the file called "update alternatives". Maybe I should remove all files from that saved version called something to do with "update", and then install update manager again afterwards?

P.S. How do I save the previous version on a memory stick?

Have you tried to undue what you did?

In other words, you set your distro to automatically update.
Can you go back to where you set it to that and change it back?

TRY this:

Last edited:
G'day Toove, Welcome to

Installing LM20.2 would rarely be a mistake. I run that myself and it is stable, solid as a rock.

Rather then look at the process through "Windows" eyes, as far as updates are concerned.....simply install ALL updates as they are offerred.
There is no reason to pick and choose between them.

Now the computer sees my screen as larger than it is or something like that.
I have no idea what you mean by that.

Is there any chance that you can reinstall and start again ? far down the track are you....what data do you have saved on that PC ?
I can show you how to make a full disc image if you need to....otherwise just have a full Timeshift snapshot.
Last edited:
FWIW, I installed Linux Mint Cinnamon 20.2 about 3 months ago and it's been running fine since.
I've installed every update and there haven't been any problems at all.
I likely have a solution to the Timeshift side of things, I just have to try a thing or two to confirm.

Back soon.

Welcome Toove,
One more vote for Linux Mint 20.2 uma.
Once up and running, just install all the updates that are suggested by update manager. No problems.
The Wiz from Oz, is our main Timeshift guy around here, so please pay close attention when he writes.
Last edited:

...but since it is set to automatic update, the moment the machine starts, it also updates again,...

That can be changed through the Update Manager "shield" in your System Tray.

Launch it and go to Edit - Preferences - Automation

You may have something looking like this


and you want to change it (will require password) to this


Once that is effected, you can also tweak the Options tab preferences if you need to.

You can then take a Timeshift snapshot that was taken before your screen resolution altered (if that is what you are talking about above), and restore the system to the way you prefer.

You can use the Comments section in Timeshift to put something meaningful to yourself, such as "This is the way my screen should be", and once you place comments, snapshots will not be culled by any culling schedule you have in place. That feature was incorporated with Timeshift 19.1 and we are on 21.9 now. If you wish a snapshot to be culled later, just remove the comments.

I would not be deleting anything through Timeshift's Browse feature, because it may compromise the Log Timeshift keeps after each snapshot (in /var/log/timeshift) for future restores.

Use it solely, for copying a file that you may have accidentally deleted and want back, or for checking that some file/s or folder/s were captured in a snapshot.

If you need more information on how to best set up your Timeshift for your environment, see me at

My Timeshift Thread here

and ask away. That includes an answer to

P.S. How do I save the previous version on a memory stick?

You will need to give me an idea of your PC specs - give us the output of

inxi -Fxz

and where you are storing your Timeshift snapshots currently.


Chris Turner

BTW @charlie.corder thanks for the vote of confidence, Charlie, hope I do it justice ;)
Hi again! It took some time to read through 14 pages of talk about Timeshift! LOL I couldn't find a solution to my problem, but learned some other stuff. Here you see a screenshot of the bottom of my screen. Only the top of the icons is visible, and when I watch film for example, and do "full screen", I can't see the little x to minimize again, and have to use Esc. Sometimes Esc is not an option, and I have to do a lot of messing around. And the panel is fixed there at all times.

Uma thinks that I have a screen of a different size than the actual size. The screen resolution is correct, and I messed around with it several times. Uma doesn't recognise the brand Finlux maybe?

I can set the updater manager for right now, no problem. No more automatic updates for me. The problem is that update manager in the timeshift snapshot I am using to restore is set to automatic update, so that immediately when I restore, it updates again everything.

I have actually decided to just wait until Uma figures it out and fixes it, because I got a bit tired of this tinkering. Now the sound works, that is important LOL. I can mess around a bit when the problem arrives, and work around it.

Do any of you have an idea of when Uma will officially out of beta = at least by then it should be fixed? Like I said, I had the same problem when I started with Linux Mint around four years ago, but it was fixed, so I presume that it is a known problem.


  • v4NLypw.png
    82.8 KB · Views: 244
Last edited:
Are you using Linux Mint 20.2 ?........I have had a quick read of the above posts, and it would appear to be 20.2

So, why do you ask when will Uma be officially out of Beta ??!!.....It is not in is a lts....(long term support release).......not due to expire until 2025.

You will note that I have highlighted Uma....

In the next week or so...maybe less maybe more......Linux Mint 20.3....Una will be released.(not a typo)
I don't know your set up there but methinks this would be a good time to do a fresh install, set screen resolutions to exactly what they should be etc etc etc....and then take a Timeshift snapshot of that.

From my post at #3 ........unanswered questions....

Rather than look at the process through "Windows" eyes, as far as updates are concerned.....simply install ALL updates as they are offerred.
There is no reason to pick and choose between them

what data do you have saved on that PC ?
If you have data/music/documents etc that must be saved, then you would do well to simply copy and paste them to an External hard drive. This will avoid writing over the top of them when you do a fresh install of Linux Mint 20.3 Una

Let us know just how trivial or otherwise it would be to do a fresh install.
OK Thank you. I don't know why I thought it was still in beta. That means that it is not going to get fixed unless I get hold of the developers, so it would probably be better for me to revert back to Ulyssa or one of those versions I had that worked fine. I honestly couldn't figure out how to write to developers. Just ended up wading through a lot of "don't write unless you know exactly what is wrong".

Yes, I have everything on back-up on memory sticks, so there is no problem with loosing files, but it is of course annoying to reinstall an older version. It is not too long since I did it, because I thought I had a Thunderbird problem, but it seems that my computer hangs now and then because of bluetooth. There are other people with the same freezing problem as me, probably with a similarly old computer (2009 mac mini), so I would like to tell the developers about it. But not until I have double checked by doing a "systemctl enable bluetooth" again to see if the problem comes back.

Thank you for all your help.

Members online