Can't Login to Debian KDE

Sevii

New Member
Credits
25
Whenever I try to login, I can type in my password but hitting enter does nothing. On the top left of the login screen, there are no options where it says "session." I am using a 2011 or 2012 macbook pro, Debian 10 KDE plasma. I was trying to get rocket league running through Epic (and later tried Legendary), and was messing with graphics card settings from my understanding. I also had issues with python and edited the etc/apt/sources.list file, but have since edited it back through the command line. I have tried running "sudo apt-get update --fix-missing" but it returns with a lot of "could not resolve" from websites lines. Leading up to the crash (trying to run Epic through Lutris), I did:

apt install dxvk
./setup_dxvk.sh
suso apt autoremove

Rebooting from there was fine. Then I did:

sudo add-apt-repository ppa:kisak/kisak-mesa"
sudo dpkg --add-architecture i386
sudo apt install libgl1-mesa-dri:i386
sudo apt install mesa-vulkan-drivers mesa-vulkan-drivers:i386

It was able to reboot after that and the Epic Launcher was able to run (however I couldn't login to Epic). From there I installed flatpak and learned about that (didn't help with rocket league sadly) and then I tried to install Legendary, an alternative launcher to Epic. I was having issues with python during the installment of Legendary, that's when I added to the sources.list file. I also (should've only done this) reinstalled python3 and that got Legendary working. Once it was running, I took a break and came back to a black screen. Upon rebooting it, we get to where I am now, unable to login to KDE and with a bunch of broken packages I am assuming. I would like to know what I did wrong and how to fix it so I can learn more about linux before I commit to running it on my future PC build.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top