Cant install Mint or Ubuntu as dual-boot with windows

1bit

New Member
Hi,

Im new to linux (other than trying a few live CDs) and me and my dad where wanting to install Linux alongside windows, I followed instructions on a fw webpages for both flavours but got stuck at the same exavt point, when the instructions tell me to select the "free space" that was made (prep for shrink) for the Linux OS to go on, it doesnt show the free space on ANY drive... it shows free space 1MB at the top of the System drive list and 0MB at the bottom of that drive list, unfortunately im unable to supply a screenshot, there is no "install alongside windows" option that other pages have said there should be?

can anyone please help as at the moment the only way I can see to install it is directly onto a drive overwriting whats on it.

thanks
 


1bit

New Member
do you mean leave Unallocated Space? Im quite tech savvy and know my way around windows, build PCs etc, just new to linux

thanks for the quick reply
 

1bit

New Member
ok ive managed to install it by leaving unallocated space. the instructions worked...but...the PC now boots directly into windows 10 (EFI) still...Ive tried to use EasyBCD to edit the bootloader but its been disabled as im running in EFI mode, is there any other way to set dual boot in windows so i can choose which OS to boot?
 

1bit

New Member
tried it and I don't have those options in BIOS or Boot Manager :(

Ive also put the boot mode as legacy and EasyBCD still says Windows is booting in EFI mode and thus its disabled the Linux option to 'add new entry'
 

atanere

Well-Known Member
First, get back into BIOS and put the system back in UEFI mode, not Legacy. From when I read above, you installed Linux in UEFI mode, so it will need to stay in UEFI to work. You do not need EasyBCD. Linux Mint and Ubuntu will both follow the same steps listed below, so doesn't matter which you installed.

After restoring to UEFI mode, if your Linux install was successful, you should be able to boot it with the "Boot Menu" when starting your computer (some special key, like ESC or F9, F10, etc). This is a one-time menu... you may have used it to boot on a DVD or USB before. At the Boot Menu, you should be able to follow steps similar to these:

1. Choose "Boot from EFI File" (ignoring the "OS" option that launches Windows 10)

2. Choose very long highlighted text, that starts with NO VOLUME LABEL (unless your hard drive happens to have a label, then choose that)

3. Choose <EFI>

4. Choose <ubuntu>

5. Next may be many .efi files to pick from. Choose grubx64.efi

6. Your GRUB menu should start... choose Linux and be sure it boots and runs.

If your Linux does not run, then do not follow this next step. If it does run, then go here and carefully follow the instructions (in Windows) exactly. Watch the spaces and curly braces... this command must be given exactly as shown. As I recall, Windows does not tell you it was successful (and it may not tell you if it fails).

If all that goes well, close the CMD window and reboot. With any luck, GRUB will be your primary bootloader now.

You might also consider the link @arochester gave above and it's recommendation that you disable hibernation in Windows if you plan to access files on your Windows partition from Linux (or maybe other shared storage partitions). Hibernation means that Windows is actually still running when you tell it to Shut Down... and Linux will refuse to access that partition in that state.... this protects you from corrupting Windows.

Cheers
 

1bit

New Member
thanks for your reply...ive got further before i read your reply... my boot menu has ACRONIS LOADER and SAMSUNG SSD among others (DVD, USB, HDD) - when I select ACRONIS LOADER windows 10 loads, when i select SAMSUNG SSD linux loads....so...Ive followed instructions for installing Grub Customizer BUT it does not have Windows in the list, it is as follows:

UBUNTU LOW LATENCY
UBUNTU
ADVANCED OPTIONS (all ubuntu)
MEMTEST86+
MEMTEST86+

in the video I followed it said there should be WINDOWS 10 in the list but there isnt.

my boot menu does not have "Boot from EFI File" (see above)

all I need now is to be able to set GRUB with dual-boot options as I can set SSD as default in BIOS
 

atanere

Well-Known Member
Okay, try this simple fix...

Boot into Ubuntu, open terminal and give this command:
Code:
sudo update-grub
Give your password, hit enter, and reboot back into Ubuntu. With luck, Windows will now show on the GRUB menu.

Cheers
 

1bit

New Member
tried that and result is the same, no windows in the grub list - now when i close GRUB CUSTOMIZER it says SAVED CONFIGURATION IS NOT UP TO DATE and to update...it says this every time regardless of updating or not since pushing that update command

Hibernate is (and has always been) disabled in my Windows OS (powercfg.exe /hibernate off)
 
Last edited:

atanere

Well-Known Member
Hibernation isn't an issue for booting, just for access to the Windows partition from Linux.

Hmmm. Like EasyBCD, Grub Customizer is not needed, and it may hurt more than help. I might uninstall it and try the steps above again.

I'm at work today and can't search well from my phone. Your solution may be in the "Advanced Options" for Ubuntu on the Grub menu if sudo update-grub still fails after removing Grub Customizer. I'm not an Ubuntu user and not familiar with those options.

Are Windows and Linux on the same hard drive? Your Boot Menu sounds like they may be different. If so, that may be a factor in setting this up correctly.
 

1bit

New Member
yeah still the same after uninstalling customizer, yes both OS's are on the same SSD
wheres this ADVANCED menu?

thanks for your help
 

atanere

Well-Known Member
UBUNTU LOW LATENCY
UBUNTU
ADVANCED OPTIONS (all ubuntu)
MEMTEST86+
MEMTEST86+
There, in the middle. :D

Oops... is that the Customizer? My mistake, I think. But doesn't GRUB also show some advanced options?
 

1bit

New Member
yeah that was customizer and in advanced it was all UBUNTU options hence (all ubuntu), how doI open grub? searching for grub doesnt bring anything up

i like the customizability in Linux
 

atanere

Well-Known Member
You can edit the GRUB menu directly, but I'd still hope to avoid that, if possible. A little Google-fu showed another command might help... try these two, one after the other, then reboot.
Code:
sudo os-prober
sudo update-grub
If it still fails... try "boot-repair" described further down the page on this link:
https://askubuntu.com/questions/197868/grub-does-not-detect-windows

That link also describes manually editing GRUB, but again, probably better to hold off on that if you can. Mistakes in there might leave it not booting at all.
 

1bit

New Member
what do I do after those two terminal commands? as I dontknow what Iam doing in linux, only the customizer allowed me access to GRUB and ive since removed that?

edit: after running those commands this is what it reported in the list:

Sourcing file `/etc/default/grub'
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.15.0-48-lowlatency
Found initrd image: /boot/initrd.img-4.15.0-48-lowlatency
Found linux image: /boot/vmlinuz-4.15.0-48-lowlatency
Found initrd image: /boot/initrd.img-4.15.0-48-lowlatency
Found linux image: /boot/vmlinuz-4.15.0-20-lowlatency
Found initrd image: /boot/initrd.img-4.15.0-20-lowlatency
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
done​

as there's no mention of windows there imguessing the grub still doesnt see it?>
 

atanere

Well-Known Member
Should just reboot after the commands, but you're right... it doesn't seem to see Windows. The link I gave directs you to install another program called "boot-repair" but it may or may not help too. You have to install this with a terminal... no problem if you want to wait a bit and pursue other possibilities. Others may jump in with more advice also.

What is the ACRONIS LOADER? I'm wondering why you see that in your BIOS Boot Menu instead of "Windows Boot Manager," which is more common. Maybe it is this that GRUB is not detecting?
 

atanere

Well-Known Member
Is Secure Boot enabled in BIOS?

If so, you might try to disable it and do the steps above again. Don't disable UEFI and switch to Legacy though if you don't have to. Some systems may toggle these settings together, but usually they are separate.
 

1bit

New Member
no rush as I can access it for now but it does need sorting out, I will try looking at that page..
also, im trying to install an Anti-Virus, I know a lot of people say you dont need one on Linux but imnot risking it, as linux becomes more popular malware authors will start to write more malware for linux...anyway...I decided to try and install SOPHOS, I had to download a TGZ file, then i used TERMINAL to run:-

chmod +x /path/to/yourscript.sh
sudo bash /path/to/yourscript.sh

this installed the software and says iam protected BUT theres no icon or program listing I can click on? am I just supposed to assume everything is ok? not what Iam wanting...

how do i uninstall Sophos and how do I install an Anti-virus with icons and GUI? my dad also needs to know

EDIT: no i dont have a secure boot option
EDIT2: Acronis Loader is Acronis Backup software loader that allows you to boot into its recovery console before windows launches, I guess it replaces the MBR with its own, I could revert it back to Windows but then I wont be able to restore windows if I cant log in, I dont have any DVDs or USB spare to put recovery console on.

thanks again
 
Last edited:

Members online


Top