Can't install Linux, Error: "AMD-Vi: Completion-Wait loop timed out"

hisakawa

New Member
Credits
20
Hey there. So I've been trying to install Ubuntu (full blown linux-noob, but I installed Ubuntu 1 month ago on a notebook without problems and sometimes use tails) yesterday which didn't really work out and today I tried to install Artix instead. Which had similar problems. All I found out googling was BIOS related, but I already run those settings like legacy boot enabled and SVM & IOMMU disabled. (I already have NX mode enabled and no Idea what it is just fyi).
With Ubuntu that screen appears after selecting "Ubuntu" out of the list of options, with Artix after selecting the installationsource, so I get to the menu in which I can select the language or keyboard layout.
Also good to know: I can boot tails from my USB without any complications.

As I said I already googled around looked up youtube tutorials, I couldn't really find anything really helpful. The only last thing I found mentioned and did not try yet, was a BIOS update, because I just build my computer 1 year ago.

My system is:
Radeon RX 580
AMD Ryzen 5 2600
32 GB (4x 8192MB) DDR4-3000
MSI B450 TOMAHAWK MAX AM4

I hope there's somebody who can help me, thanks a lot.
If you need more information or pictures, let me know.
 

Attachments



Alexzee

Well-Known Member
Credits
5,186
I had a simular error message like you when I tried to install an Arch based distro on one of my laptops last week. I looked for days and hours and nothing I tried worked.

In an effort to help you......
Some questions first so I can try to help you.

How much RAM do you have in that rig?

What program are you using to write the Linux .iso image to the USB or DVD?

Have you went into the BIOS and disabled 'secure boot'?

Do you have another operating system installed? Windows? Ubuntu?

This was the closest thread I could find: that is, provided it's a kernel issue with an iommu feature however; you have that disabled. Maybe try enableling it and see if Artix will boot. If not I'm not sure what else you could try.

 
Last edited:

Members online


Top