• Important: We recently upgraded our forum software - please let us know if you run into any issues.

Can't Boot Windows 7 after installing Kali Linux

GowthamK

New Member
I installed Kali Linux with Windows 7. I wanted to dual boot both the operating systems. So I used the option of Grub Loader while installing Kali and I am able to login into Kali Linux without any issues. When i switched on my laptop, directly Boot menu is appearing followed by the failure screen. with below screen shots.

Please help me out guys...
upload_2019-1-2_13-55-42.jpeg

upload_2019-1-2_13-56-8.jpeg
 


botnet

New Member
I'm going to try and keep this as simple as possible. The message above isn't too clear as well .
Windows 7 Uses MBR partitioning and if you used the UEFI it will not boot .Don't change the boot order from the boot menu .Do this :
1) Go into your bios
2) Look at boot devices and change it from there .You will be able to see the difference device's , You should see Network , Windows Boot manager , Hard drive (It won't say hard drive though , will be the hardware name ) .Change the boot order to the harddrive so it can read the Kali installation and launch grub .If that doesn't work change it to windows manager and launch your windows system and to the installation correctly .

Check your bios , Look at Legacy support under boot mode . I have legacy support with UEFI boot priority .You need to remember that Windows 7 is MBR which will need Legacy .In my case I use Debian and windows 10 .
I hope I didn't confuse you , but just FYI if you had ask a q like this you should install a different Linux distro.

All the best .
 

botnet

New Member
Your kali installation should show that on the grub loader (screen) .Windows manager and the Linux distro .If your partition tablets don't match it won't pickup.You can always go to the bios to change the boot entry and priority .

All the best..
 

Attachments

Condobloke

Well-Known Member
From a quick read I cannot see that anyone has asked you......Why Kali Linux ??
 

circuit lover

New Member
I think, your computer disk drive's cable is disconnected. Better u should check inside cpu. I recently encountered the same type of problem in my college lab computer(same error message what u got). I have found my disk drive's cable is disconnected. After i have connected, it is working fine.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
G'day all :)

(Wizard appears in a puff of smoke, belches and toasts the Kali Dragon by accident)

There is a little bit of confusion clouding this thread and so I would just like to set the record a little straighter. But first, my manners.

Welcome to linux.org to both of the OP (that is you @GowthamK ) and to @circuit lover :D. Hope you enjoy your time with us.

@botnet said

...but just FYI if you had ask a q like this you should install a different Linux distro
and Brian @Condobloke said

.....Why Kali Linux ??
I would agree. If this is your first venture into Linux, spend a year or two using easier Distros and then reconsider Kali.

But to answer some questions.

I recently encountered the same type of problem in my college lab computer(same error message what u got).
NOT necessarily for the same reasons, although I do not doubt you.

Here is a shot from my Dell Inspiron (not a very good one) and you can see the message is almost identical, if not identical.




SCREENSHOT 1 - WIZARD'S DELL RUNNING UNDER CSM CONDITIONS


While it may reference a legitimate cable problem, it also occurs when you are running a computer which has support for UEFI, and you are running it as BIOS-MBR.

In my case, the Dell Inspiron shipped as UEFI-GPT throughout (2TB SATA HDD /dev/sda and 256GB SSD /dev/sdb), and it is only that I have converted the HDD to MBR to run some experiments, that I see this startup message. There are also a couple of my Linux which have to be installed under Legacy conditions, and they include but are not limited to Linux Lite, and most UE (Ultimate Edition).

You can determine that your Kali was or was not installed under UEFI conditions by opening its File Manager, likely GNOME Nautilus aka Files, and checking for the existence of

/sys/firmware/efi

If that is not there, it's not installed under UEFI.

You can check if your Windows was installed under UEFI or Legacy by the following:

Check if UEFI or Legacy BIOS Mode in setupact.log in Windows 7, 8, and 10
1. In Windows Explorer, navigate to C:\Windows\Panther, you will see a file named setupact.log.

2. Open the setupact.log file with notepad, click Ctrl + F to open the Find dialog, enter Callback_BootEnvironmentDetect: Detected boot environment: in the Find dialog to search for a line begin with Callback_BootEnvironmentDetect: Detected boot environment:.

3. Once you find Detected Boot Environment, you will see it say EFI or BIOS.

The OP (Original Poster) is running from a Lenovo B480 (credit if you spotted that). Some Lenovos can be problematic with Linux.


I would first ask myself - Do I really need Kali?

Other than that, I would try rebooting. Your Lenovo may have options at F2, F10, F12 or Delete - perhaps two (2) options to enter the Setup. Try them to see if you can change from BIOS (CSM-Legacy) to UEFI, reboot and see what happens. It won't break anything, if nothing favourable occurs, just switch it back.

@arochester 's link above does take you to an article that is 4 years old, but in the first lines, links to an article here

http://linuxbsdos.com/2016/11/05/dual-boot-kali-linux-rolling-2016-2-windows-10-on-a-pc-with-uefi-firmware/

... which features a more recent side to the Kali part. So you might need to reference both articles to get the full picture.

The following might be of use to you, regarding your Lenovo

https://support.lenovo.com/au/en/solutions/ht103672

and

https://support.lenovo.com/au/en/solutions/ht070218

Good luck, and try to choose wisely. ;)

Chris Turner
wizardfromoz
 

Members online


Top