Can't Boot into the OS

milkias1710

New Member
Credits
0
I recently changed my distro to arch linux. During the installation process, my partition table got screwed up I don't know how. The actual size of /dev/sda4 is 60 gigabytes but on the partition table it says 460 gigabytes by considering that /dev/sda3 doesn't exist because /dev/sda3(my home partition) was an encrypted drive. I didn't want my home partititon to be encrypted so I went to gparted and formated it into ext4 and mounted that onto /home. Then on my next reboot, I can't boot into the machine and arch gives me the error message, unexpected inconsistency on /dev/sda4. Run fsck manually on /dev/sda4. But when I run fsck it says either the partition table or the superblock is screwed up and just aborts and does nothing. I even tried to boot into another linux live image by booting into my usb but it doesn't bring up anything, it just brings a black screen with a blinking cursor at the top right corner. I know this is caused because the partition table isn't showing the correct sizes of the partitons. And now when I boot into my harddrive now I get a grub rescue prompt. Thank you very much in advance.
 
Last edited:


hawkins

New Member
Credits
24
I'm not really sure about the partition part, but I had a problem with kali linux once with it always sending me to the grub rescue, I had to go into the bios, go to the custom boot option and then manually type the efi path. For kali it was EFI\kali\grubx64.efi, not sure what yours would be. Then put the custom boot option at the top of the boot order.
 

Alexzee

Well-Known Member
Credits
1,066
Here's what you can do at the grub rescue prompt.

 


Members online


Latest posts

Top