Can't boot Fedora System into Graphical Desktop

metafizik

New Member
Yesterday I ran switchdesk-gui on one of my systems and today when I rebooted the system it will not boot into a graphical environment. I ran the utility because I was configuring another system for a friend of mine and that utility wouldn't run on it. Turns out I was just entering the wrong command. Long story short I think I selected Mate from the dropdown and checked a box beside default. I have 3 Desktop Environments installed on that system (Mate, KDE and Gnome.) Whatever I did the system did not like it.

I can boot into runlevel 3 to edit files but I don't know what file I need to edit. I did a search on a couple of directories under / for files that were modified in the past 2 days but nothing came back that I would have expected. I have been booting into Mate on that system for a few years and that is what I want to configure it to boot into now. Could someone please tell me what I need to do to fix this problem?

Best Regards, ~metafizik
 


dos2unix

Active Member
... usually... did I say "usually".. you can do this.

dnf group reinstall -y "MATE Desktop"

Once you install gnome, it tries to take over everything. I have gotten, cinnamon, mate, kde, lxe
and a few others to play together... but whenever I install gnome, the other window managers are
usually done.

after this.. you may need to run systemctl set-default graphical.target
 
Last edited:

hooman

New Member
if it go to tty:
startx
for going to desktop
or
sudo systemctl start <name_of_dm> {like sddm or gdm}
for going to dm for login and etc there you can choose desktop and go to it
if it didn't work
dnf reinstall <desktop_name>
then try again
 



Members online


Latest posts


Top