• We had to restore from a backup today after a failed software update. Backup was from 0000 EDT and restored it at 0800 EDT so we lost about 8hrs. Today is 07/20/2024. More info here.

Can't add Discord as non-Steam game on Steam Deck?

MysticalJungle

New Member
Joined
May 12, 2024
Messages
19
Reaction score
4
Credits
189
Hello.

I can't seem to get Discord to add as a non Steam game. I'm in desktop mode, which allows you to add no Steam games to Steam for use in Gaming mode.

However, Discord is missing from the list.
There's also a browse option as I did that. But I don't really know where to look and where it's saved in. All I know that it's installed and I look for 'internet' in the KDE panel menu to see it there.

Is there a way to add Discord as non Steam game so I can use it in gaming mode?

Thanks.
 


Maybe it just me but why would you do that?
 
Yes, but that's the problem. Discord is not in the list somehow... When I try to add it.
I haven't tried it on my Steam Deck so not sure. Maybe you have to launch Discord once before it does or you can try browsing to the location of Discord which does seem to be an option to add a non-Steam game. And if that doesn't work maybe the Flatpak version was installed and not the native package version, don't know what Discover installs by default. That's what I would look at if I were to want to get it working.
 
I haven't tried it on my Steam Deck so not sure. Maybe you have to launch Discord once before it does or you can try browsing to the location of Discord which does seem to be an option to add a non-Steam game. And if that doesn't work maybe the Flatpak version was installed and not the native package version, don't know what Discover installs by default. That's what I would look at if I were to want to get it working.
I launched Discord a few times, logged in etc. I honestly don't know what Discover installs by default.
Haven't paid attention to it.

The rest all works as non Steam game, RetroArch, Parallel Launcher, Chrome.
 
I honestly don't know what Discover installs by default.
Haven't paid attention to it.
There's an Unofficial Discord Appimage, that is based on the official one.
Try downloading that and adding it to Steam by browsing to that path you place it.
Because when I do that on my pc with Steam Discord shows up as Non-Steam game.
 
I use Arch... btw ;)

Do the following.

Open terminal (Konsole by default)

If you haven't already, set user PW with

Code:
passwd

your default user is "deck". And by default, SteamDecks have no default user PW (crazy ik)

Execute the following commands, confirming with your newly set password.

Code:
# This disables read only, allowing you to install stuffs
sudo steamos-readonly disable

# these initialize and populate keys, just ensures everythings good n gravy.
sudo pacman-key --init
sudo pacman-key --populate

#updates system
sudo pacman -Syu

then

Code:
# installs discord
sudo pacman -S discord

right click discord, add as non steam game. Ensure you use headphones or your SFX will haunt your every vocal conversation while gaming and your friends will likely hate you, hog tie you and leave you in the corner until they're done.

Works on all 4 of my steam decks. LMK if you run into issues.
 

Members online


Latest posts

Top