Cannot dual boot linux into hp Pavilion 15-eh1xxx


New Member
Sep 24, 2021
Reaction score
I have already booted a coupple of my laptops but this one is giving me a hard time especially because of the bios version, it looks exactly like this :


except for the fact that i don't have the legacy option and everytime i disable secure boot (and save the changes), it will automatically re-enable it as soon as i quit the menu.
if i try to launch the boot anyway i get a message that says:

Invalid signature detected. Check secure boot policy (it clearly has something to do with that secure boot option).

I also tried booting my usb drive as a UEFI boot with Rufus and it didin't work and i tried again with Unetbootin but still no luck.
Btw with the UEFI boot i tried to launch it via advanced start up options.

What seems to be the problem? and if this is unusual, is there a different way that i can boot linux into the laptop? i am willing to lose my windows boot if that's what it takes.

Thanks for taking the time to read.


Well-Known Member
Mar 19, 2018
Reaction score
everytime i disable secure boot (and save the changes), it will automatically re-enable it as soon as i quit the menu
I have an older HP laptop that needs the following steps to disable Secure Boot:

1. Boot into BIOS and change Secure Boot from Enabled to Disabled
2. Go to Exit tab in BIOS and choose "Exit saving changes" and exit BIOS
3. Now WAIT... don't hit any keys that would interrupt the boot
4. I then get a black screen with a 4-digit code and some instructions. I have to type in this code (and hit Enter) so that the Secure Boot will actually be disabled. This "feature" is so that Secure Boot is not accidentally disabled by someone making BIOS changes.

Windows should start normally after doing these steps, and hopefully you can then install the Linux you are attempting. Most Linux (but not all) will boot with BIOS set in UEFI mode, so you will probably not need to switch to Legacy. Many Linux will boot with Secure Boot still enabled too, but you don't say what Linux you want to install.

It could be your problem is your USB. I've heard a lot of trouble reports of using both Rufus and Unetbootin to make Linux USBs. Sometimes these problems are also specific to certain Linux distros. Many folks here recommend balenaEtcher to burn the USB instead. It's drop-dead simple to use and rarely fails.

Good luck.

Staff online

Members online