Can not install package libwrap0-dev on KUbuntu1604

agatte

New Member
Credits
0
Hello,

I have a problem with installing missing package on KUbuntu1604.
[email protected]:~$ sudo apt-get install libwrap0-dev
[sudo] password for agatak:
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
libtiff5-dev : Depends: libtiffxx5 (= 4.0.6-1ubuntu0.6) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
[email protected]:~$ apt-get -f install
E: Could not open lock file /var/lib/dpkg/lock-frontend - open (13: Permission denied)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?
[email protected]:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
libtiffxx5
The following NEW packages will be installed:
libtiffxx5
0 upgraded, 1 newly installed, 0 to remove and 37 not upgraded.
1 not fully installed or removed.
Need to get 0 B/9'456 B of archives.
After this operation, 41.0 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 239181 files and directories currently installed.)
Preparing to unpack .../libtiffxx5_4.0.6-1ubuntu0.6_amd64.deb ...
Unpacking libtiffxx5:amd64 (4.0.6-1ubuntu0.6) ...
dpkg: error processing archive /var/cache/apt/archives/libtiffxx5_4.0.6-1ubuntu0.6_amd64.deb (--unpack):
trying to overwrite shared '/usr/share/doc/libtiffxx5/changelog.Debian.gz', which is different from other instances of package libtiffxx5:amd64
Processing triggers for libc-bin (2.23-0ubuntu11) ...
Errors were encountered while processing:
/var/cache/apt/archives/libtiffxx5_4.0.6-1ubuntu0.6_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
[email protected]:~$ ls
Desktop dev devk Documents Downloads Music Pictures Public Qt Templates test1 test2 Videos VirtualBox VMs
[email protected]:~$ dpkg -l libtiffxx5
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-=============================================================-===================================-===================================-===================================================================
in libtiffxx5:amd64 <none> amd64 (no description available)
ii libtiffxx5:i386 4.0.6-1ubuntu0.6 i386 Tag Image File Format (TIFF) library -- C++ interface
[email protected]:~$ apt-cache policy libtiffxx5
libtiffxx5:
Installed: (none)
Candidate: 4.0.6-1ubuntu0.6
Version table:
4.0.6-1ubuntu0.6 500
500 http://ch.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
4.0.6-1 500
500 http://ch.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

I would appreciate for any help . How I can fix this issue ?
bugInKUbuntu.png
 


agatte

New Member
Credits
0
Hey,

It was just installed last week.
I need to run the software on this version of ubuntu.
during building from source in cmake. It show up me info
CMake Error at CMake/mitkFunctionCheckPackageHeader.cmake:5 (message):
Could not find tcpd.h provided by libwrap0-dev. Please install the missing
package.
Call Stack (most recent call first):
SuperBuild.cmake:35 (mitkFunctionCheckPackageHeader)
CMakeLists.txt:511 (include)

and I started to install missing packages.
 

blackneos940

Active Member
Credits
31
Thanks.
Issue already fixed.
Glad to hear it!..... :3 Yeah, updating Ubuntu to the latest version available usually results in good things..... :3 If it's LTS, which means Long Term Support (suitable for Servers) it's at 18.04, and if it's non-LTS, it's at 19.04 I think..... :)
 


Members online


Latest posts

Top