• We had to restore from a backup today after a failed software update. Backup was from 0000 EDT and restored it at 0800 EDT so we lost about 8hrs. Today is 07/20/2024. More info here.

Solved Booting Mint fxce from live USB stops at flickering underscore in top left corner.

Solved issue

greenmarty

New Member
Joined
Jun 19, 2023
Messages
27
Reaction score
17
Credits
265
I can use same USB stick with same iso to boot on other PCs successfully.
I used it to install Linux mint fxce just few weeks ago on my other laptop.
Device that has trouble booting:
ComponentSpecification
ModelHP Pavilion g6-1258er
Operating SystemWindows 7 Home Basic updated to Win 10
ProcessorIntel Core i3 370M (2.4 GHz)
Number of Cores2
Chipset ModelIntel HM55
Memory6 GB DDR3
Display15.6-inch, 1366x768, widescreen
Graphics Chipset ModelNVIDIA GeForce GT 520M
Graphics Memory1 GB GDDR3
Storage Size500 GB Serial ATA Hard Drive
Hard Drive Speed5400 RPM
LAN/ModemNetwork 10/100 Mbit/s
Wireless CommunicationBluetooth, Wi-Fi 802.11n
InterfacesUSB 2.0x3, VGA (D-Sub), HDMI, microphone input, audio output/headphone, LAN (RJ-45)
Pointing Device TypeTouchpad

Reproduction steps
  1. Power on > F9 > choose USB storage as boot option
  2. in CRUD options chose standard or compatibility mode
  3. mint logo appears and changes into flickering cursor
  4. After few minutes mint logo appears again, resolution changes, 3 lines of text appear for less than second.
  5. it goes back to flickering cursor but in higher screen resolution.
  6. ctrl+alt+delete >shows mint logo and "Please remove the inst. media, then press ENTER" >enter restarts pc

What I've done so far
If i pres ctrl+alt+F2 i get to see prompt to insert password but i haven't had chance to set any PW yet at this point. This promt quickly goes disappears back to flickering cursor regardless whether i press enter or just ignore it.

Bios, Changed order of bootable sources
I've put USB Diskette on Key / USB Hard Disk as top.

Bios, Secure / Fast Boot
I tried to find secure/fast boot in bios but bios is quite limited in options.

Fast boot - managed to turn it off
Booted into Windows 10 > alt+R> powercfg.cpl > Choose what the power buttons do > Turn on fast startup

Test Booted from same USB stick into preview desktop on diferent HP device (ProBook 4310s) with no issue.

Tested with different USB ports - tried to boot from different USB ports on same laptop. (There's no hub/dock for this device)

Solution​

was to use nomodeset in CRUD command. Credit @kc1di in this comment.
I took liberty to format it into easy to follow steps guide
  1. in CRUD highlight Linux Mint <version>[/B] (top option)
  2. press e to edit commands before booting
  3. search & replace quite splash with nomodeset or nouveau.noaccel=1
  4. ctrl+x to start Mint preview desktop
  5. Run driver manager > get nVidia driver. (Probably no needed.)
  6. Proceed to test if everything works and install Linux Mint as usually by clicking the icon on desktop
After installation if it doesn't work (for me it endlessly printed intel ips 0000:00:1f.6: failed to disable graphics turbo) i did following.
  1. in CRUD > Advanced > Recovery mode
  2. check all packages (probably not needed but i did it)
  3. continue to boot > gives warning system might start without GPU driver = that is probably what allowed me to boot into desktop
  4. Connect to internet
  5. Run driver manager > get nVidia driver.
 
Last edited:


I've can use same USB stick with same iso to boot on other PCs successfully
G'day greenmarty, Welcome to Linux.org

That tells me the bios still has secure boot/fast boot enabled.

Look here if you are unsure:

reboot...go into bios and search for them....disable them
 
G'day greenmarty, Welcome to Linux.org

That tells me the bios still has secure boot/fast boot enabled.

Look here if you are unsure:

reboot...go into bios and search for them....disable them
Greetings. Thank you for welcoming me and fast reply.

I tried to find secure/fast boot in bios but bios is quite limited in options.
Only option regardless boot i could find was change order of bootable sources.
I've put USB Diskette on Key / USB Hard Disk as top option initially before posting this question.
 
Did the youtube video help at all?.....Being a HP the secure boot or fast boot option will be there....it is just a matter of opening the correct window/option in order to find it.

I think @Brickwizard has a few HP's in his stable, he may be able to give us a bit more focus.....

By mentioning his name here, I will have made him aware of the topic.
 
Did the youtube video help at all?.....Being a HP the secure boot or fast boot option will be there....it is just a matter of opening the correct window/option in order to find it.

I think @Brickwizard has a few HP's in his stable, he may be able to give us a bit more focus.....

By mentioning his name here, I will have made him aware of the topic.
Well boot options > other > shows about 20% of options that the one in the video. It's hard to make what is missing because video is bit of hard to see and has different bios structure.

But I've managed to boot into Windows > went to the power-setting > turned off fast-boot as in HP forum they said it's not possible to do it otherwise because fast boot is loaded before Bios ?? I find it weird but at least i turned that part off.

Edit: > still stuck at flickering underscore thing

Edit: this is my bios System Configuration > Boot options > Boot order
20230619_121858.jpg
20230619_121916.jpg
20230619_121937.jpg
 
Last edited:
I think @Brickwizard has a few HP's in his stable, he may be able to give us a bit more focus.....
OK, @greenmarty you have a lappy of about 2010 vintage, it should have fast-boot which you can disable as it is a part of the windows programming, I doubt it will have secure boot
are you trying to duel boot or clean install Linux only?
you do not need to change the boot order, just use the one time boot option on an HP it may be Esc or F9 juggle one of the keys as you power up [if one doesn't work power off then power on and try the other] with the usb inserted select usb from the list and click on it to start installation. my how do I install guide is exactly how i made mint [and other] installations to my HP.
Anyway I'm on holiday, its a lovely sunny day here in Kernow, so we are going out for a drive.. back later in the day
 
OK, @greenmarty you have a lappy of about 2010 vintage, it should have fast-boot which you can disable as it is a part of the windows programming, I doubt it will have secure boot
are you trying to duel boot or clean install Linux only?
you do not need to change the boot order, just use the one time boot option on an HP it may be Esc or F9 juggle one of the keys as you power up [if one doesn't work power off then power on and try the other] with the usb inserted select usb from the list and click on it to start installation. my how do I install guide is exactly how i made mint [and other] installations to my HP.
Anyway I'm on holiday, its a lovely sunny day here in Kernow, so we are going out for a drive.. back later in the day

@Brickwizard I'll reply in bullet points to maximaize readability and keep it concise.
  • Turned off fast-boot via Windows 10 power-setting.
  • Didn't find any secure boot so i guess it realy doesn't have it.
  • I can "boot" into live USB via F9 > USB > CRUD > Choose Mint /compatibility / memtest > problem starts afterward. In my previous experience after like minute, Mint OS should start from USB with desktop and icon that is named install Mint.
  • Only reason why i changed booting order was that it was highlighted as important steps on multiple online guides. Never had to do that before but since I'm straw catching at this point i tried that.
  • It doesn't have to be dual boot but I'd prefer to keep Win 10 on it at least until i managed to run Mint on it. Win 10 is the only OS that works so far.
Enjoy your holiday ;)

edit:
 
Last edited:
The problem will be in your Nvidia Graphics card you may need to install a new driver. From the Mint desktop if you can get there go to Menu>Administration>Driver Manger and see what it recommends. Install and reboot. Should fix the problem.

If in the live session you should boot it via the nomodeset parameter. See Here for details.
Scroll down to the section

Solving freezes during the boot sequence​

Watch the video and add nomodeset to your grub boot line.
Good luck.
 
Last edited:
The problem will be in your Nvidia Graphics card you may need to install a new driver. From the Mint desktop if you can get there go to Menu>Administration>Driver Manger and see what it recommends. Install and reboot. Should fix the problem.

If in the live session you should boot it via the nomodeset parameter. See Here for details.

Scroll down to the section

Solving freezes during the boot sequence​

Watch the video and add nomodeset you your grub boot line.
Good luck.
Edit:
You are golden ! Thank you.

This works. It's nVidia issue.
Add the "nomodeset" option as illustrated below:

  1. in CRUD highlight Linux Mint <version> (top option)
  2. press e to edit commands before booting
  3. search & replace quite splash with nomodeset
  4. Mint preview desktop starts
  5. Connect to internet
  6. Run driver manager > after it checks download nVidia driver.
  7. Proceed to test if everything works and install Linux Mint as usually by clicking the icon on desktop
 
Last edited:
The nvidia GT520M graphics card is supported by nouveau. Can be checked here: https://nouveau.freedesktop.org/CodeNames.html.

Because the usb stick installed on one computer, doesn't automatically mean that it will install on any other computer. It seems like that ought to be the case, but usb ports can be very finicky, so if difficulty arises with one port, trying different ones on the computer is the next step. That's happened in my case, with all ports failing, but resolved in the end by writing a new usb with the iso (not using the original usb that failed), and verifying it with the checksum. YMMV.
 
The nvidia GT520M graphics card is supported by nouveau. Can be checked here: https://nouveau.freedesktop.org/CodeNames.html.
It is indeed problem with GPU. I've managed to bypass the "issue" and then used driver manager to fetch recommened nvidia driver. Now I'm about to install Mint. (Need to do some partition management with gparted first - nothing complicated but takes long time.)

Because the usb stick installed on one computer, doesn't automatically mean that it will install on any other computer.
Well i understand that HW of each device is different and thus requires different drives and such.
I meant to say that probability that USB stick or data on USB stick being damaged is quite low.

It seems like that ought to be the case, but usb ports can be very finicky, so if difficulty arises with one port, trying different ones on the computer is the next step. That's happened in my case, with all ports failing, but resolved in the end by writing a new usb with the iso (not using the original usb that failed), and verifying it with the checksum. YMMV.
I have tried different USB ports to no avail.
It was faster to replace two words in CRUD command then to get new bootable stick and it indeed was nVidia not being supported out of box by the default CRUD command of Mint.
 
Glad you found a way forward. Enjoy!
Ok not really it worked for live USB boot but same trick doesn't work for installed mint.
Now It gets stuck at intel ips 0000:00:1f.6: failed to disable graphics turbo
 
Ok not really it worked for live USB boot but same trick doesn't work for installed mint.
Now It gets stuck at intel ips 0000:00:1f.6: failed to disable graphics turbo
That output looks like an unfixed bug noted here:

It's noted there that "nomodeset" didn't fix that problem for the user of the report, but newer kernel apparently did.

As a speculation, it sounds odd that the machine with nvidia graphics card is halting on an intel graphics element. Maybe to do with the intel CPU graphics involvement.

Nevertheless, there is a work around from here:
which may be useful:

1. add intel_ips to the blacklist
echo "blacklist intel_ips" >> /etc/modprobe.d/blacklist.conf

On another matter from post #11:
I meant to say that probability that USB stick or data on USB stick being damaged is quite low.

The inference in post #10 was not that the usb was damaged, but rather that some machine BIOS firmwares don't read all usbs. There are a number of reasons why they don't, one being that sometimes usb isos have padded bytes that throw some readers off, so they fail to read, but other readers can adjust for this. The usb therefore behaves differently in different machines without itself being damaged, though perhaps not written to the usb optimally.
 
@osprey
wow, I've been searching all over but could not find anything useful.

In meanwhile I've solved problem by:
restart > CRUD > advanced > recovery mode> continue to boot > warning with GPU drivers won't be loaded > OK
Above bypassed GPU issue and i've logged into desktop.

(Found out wifi is connected, shows 80MB/s speed, IP, Gate, etc but i'm offline. So i've reinstalled wifi driver via command line which gave aprox 20secs of online in which i've downloaded propriatary network driver. )

Run driver manager to download nVidia drivers once again.
Now it seem to be working as expected , i hope

Thank you and everyone else for being very helpful in your free time :)


Edit:
@osprey
it sounds odd that the machine with nvidia graphics card is halting on an intel graphics element. Maybe to do with the intel CPU graphics involvement.
Well it seems to have integrated intel GPU as well as nVidia GPU according to the system report.
 
Last edited:
@osprey
wow, I've been searching all over but could not find anything useful.



Edit:

Well it seems to have integrated intel GPU as well as nVidia GPU according to the system report.
Glad to hear of a resolution.
I suspected an integrated intel GPU, but when I looked at the specs here:
it was similar to the specs in post #1 which showed only the nvidia, so looked no further, but ought to have looked at the HP site.
 
Glad to hear of a resolution.
I suspected an integrated intel GPU, but when I looked at the specs here:
it was similar to the specs in post #1 which showed only the nvidia, so looked no further, but ought to have looked at the HP site.
Yeah i also trusted specs i got.
BTW system terminal printed multiple packages that contain ...amd64... in their name during first boot and it did so during aptitude upgrade as well.
It seems to be used on intel devices as well but It bugs me little nevertheless. PC runs smooth.
 
BTW system terminal printed multiple packages that contain ...amd64..
AMD 64 is the protocol for all 64 bit AMD and Intel chips [but not ARM], this is because AMD 64 hit the market first, and was adopted by manufacturers before Intel's own 64 bit processor became available and flopped, Intel pay for the licence to use it.
 
AMD 64 is the protocol for all 64 bit AMD and Intel chips [but not ARM], this is because AMD 64 hit the market first, and was adopted by manufacturers before Intel's own 64 bit processor became available and flopped, Intel pay for the licence to use it.
Good to know it's not next ticking bomb. Thank you for clarifying it.
 
Good to know it's not next ticking bomb
That is under construction, several chip manufacturers including the big 2, are working on the next generation of bit processing, but who will get there first and win the prize...well your guess is as good as any other's
 


Top