Boot USB via Grub doesn't work (Unsupported start_image)

Eldritch Horror

New Member
May 9, 2022
Reaction score
Hello everybody!

Since it might be seen as a little rude, if I'd just stumble onto this platform with nothing but a technical problem, I thought, that it might be appropriate to give a little backstory, what lead me here:

First of all I have to admit, that I am not at all well-versed, when it comes to Linux. Shame on me! I am mainly using Linux Mint on my Netbook, because that device has VEEERY little disk space. And the countless updates of the pre-installed Windows OS have slowly but surely littered the hard drive so full, that there was barely 1 GB left for me to work with. With Linux Mint I've had 20 GB free and it runs a lot smoother. (I've even thought about getting Knoppix instead of Mint, but that's a different Story.)

Unfortunately yesterday I totally messed up by trying to correct the time and date ... It would be too embarrassing to go into detail, what went wrong there. Suffice to say: The Linux OS has been destroyed and I need to reinstall it using a USB-Stick, that I've made bootable with UNetbootin. (Luckily I didn't have any important data on the device, that might get lost now due to my foolishness. I just want to get my sweet little netbook to work again.)

The problem now is, that the damn thing refused to let me boot from that stick, even though I set the USB-port to the very first position of the boot order in the BIOS. No matter, what I do, I always end up in the grub menu. So, I need to manually boot from there, which should not be too difficult - or so I thought.

Using "ls" showed me, that my netbook recognizes the USB-stick as (hd0,msdos1). I've verified that through:

ls (hd0,msdos1)

which gave me the UUID of the stick: 349B-50B3. I then proceeded like this:

insmod part_gpt
insmod fat
insmod search_fs_uuid
insmod chain
search --fs-uuid --set=root 349B-50B3
chainloader /EFI/BOOT/bootx64.efi

(Side-note: The File-Names of "EFI" and "BOOT" are indeed capitalized like that.)

Anyways... All of that only resulted in an error-message shortly being shown on screen, that read:

Failed to find fs: Unsupported
Failed to load image \EFI\BOOT\bootx64.efi: Unsupported start_image() returned Unsupported

And that's pretty much, where I give u, because I have no idea, what this means or how I could proceed. I'd be very grateful, if someone could help me getting my netbook to work again.

Last edited:

Welcome to the forums, and what is your netbook [make and full model number]? Your Linux may not be destroyed,
remove all usb drives switch on the machine pressing [now this is where it is multiple choice depending on the machine] shift or esc or ctrl one of these should open the boot menu, find mint advance options [usually 2nd one down] click to open, look down to fix broken packages and run it, this often fixes most problems,
If yoc an get a terminal up try sudo update-grub
Hi and thank you for your reply. =)

I've already tried to repair the damage done to the OS, but that doesn't work, mainly due to the internet connection not working on this thing. I'm pretty sure the internal WLAN-device is broken (just like some other hardware components). After all this thing is 8 years old and has suffered quite a lot of abuse.

I'm not quite sure about the exact model-number of this thing, but if I'm not mistaken it's an Acer Aspire ES1-111M-C56A. It's definitly part of the Acer ES1-111 series.

When I start the netbook normally, it presents me with 3 choices:

Linux Mint 20.2 Xfce
*Advanced options for Linux Mint 20.2 Xfce
UEFI Firmware Settings

The first option leads to this:
[ 9.640420] Bluetooth: hci0: command 0x1003 tx timeout
[ 9.641313] Bluetooth: hci0: unexpected event for opcode 0x1003

The third option leads to the BIOS.

And the second option presents me with another choice:
*Linux Mint 20.2 Xfce, with Linux 5.4.0-74-generic
*Linux Mint 20.2 Xfce, with Linux 5.4.0-74-generic (recovery mode)

The first one produces this:

[ OK ] Stopped Login Service.
[FAILED] Failed to start Login Service.
See 'systemctl status systemd-logind.service' for details
[ OK ] Finished Hold until boot process finishes up.
[ OK ] Finished Terminate Plymouth Boot Screen.
[ 9.449429] Bluetooth: hci0: command 0x1003 tx timeout
[ 9.450562] Bluetooth: hci0: unexpected event for opcode 0x1003

The second one (recovery mode) leads me to the Recovery Menu (filesystem state: read-only)

resume ________________ Resume normal boot
clean __________________ Try to make free space
dpkg __________________ Repair broken packages
fsck ___________________ Check all file systems
grub __________________ Update grub bootloader
network _____________ Enable networking
root __________________ Drop to root shell prompt
system-summary ____ System summary

I can give further information about the latter menu, if needed.
[FAILED] Failed to start Login Service.
To recover from systemd-logind not starting, try the following

Boot your computer;
Press SHIFT key while booting;
Select Advanced mode -> any recover booting option;
When recover menu appears, select to go to ROOT prompt;
Enter your root password;
Type in terminal
cp -r /var/run/* /run
cd /var
The above command has to show '/var'

rm -rf run
ln -s /run

hopefully it is working
Last edited by a moderator:
Hey. Thanks for your comment. =)
Unfortunately this doesn't work either. When I select "root" in the Recovery Menu I get this:

sulogin: cannot open password database
sulogin: cannot open password database
It seems that you may have corrupted your /etc/passwd file

Try to boot a rescue system from the LiveUSB. Then try to mount the root partition and inspect the /etc/passwd.

On normal systems the credentials are in the file /etc/shadow. Either disable this behavior with shadowconfig off or take care that both files are in sync.
It seems that you may have corrupted your /etc/passwd file

Try to boot a rescue system from the LiveUSB. Then try to mount the root partition and inspect the /etc/passwd.

On normal systems the credentials are in the file /etc/shadow. Either disable this behavior with shadowconfig off or take care that both files are in sync.

I'm afraid I have no idea, how I could do that.
As I said: Booting from USB doesn't work for some weird reason.
1. Power up the system and Keep tapping on F2
2. Enter BIOS,
3. Go to the Main tab and Enable the Secure boot
4. Set the Boot mode in Legacy
5. Enable the F12 and Press F10 to Save and Exit
6. Upon restarting , Keep tapping F12 until the Boot menu will appear
7. Choose " USB Removable device "

Note: By changing to Legacy whatever was on there will not longer be accessible - does your USB work?
I hate to tell you this, but in the meantime, I've found a way to screw things up even further.


I have actually managed to successfully boot Linux Mint from USB. (Hurray!) But at a high cost.

There's now a (severe) problem with the hard-drive - as in: Linux Mint does not find the netbook's own disc-space AT ALL in the menu for partinioning. I seem to have not only obliterated the previous OS, but also the hard-drive itself.

Right now I'm trying to use the OEM install, which is stuck at this step for almost an hour now:

Creating ext4 file system for / in partition #2 of MMC/SD card #2 (mmcblk1)

It doesn't seem like this is going to progress any further. So I'm not sure, if I should just abort this installation and try something else. I mean: How long could this possibly take?


Now I have restarted the whole thing and tried to boot Linux from USB again (not the OEM install).

Booting from USB works. But when I try to install Linux Mint I get this:

"Do you want to resume partitioning?
The attempt to mount a file system with type vfat in MMC/SD card #2, partition #1 (mmcblk1p1) at /boot/efi failed.
You may resume partitioning from the partitioning menu."


Maybe these screenshots can illustrate the whole mess:

Screenshot 1.jpg

Screenshot 2.jpg

Screenshot 3.jpg

So Linux Mint eventually DID decide to recognize the hard-drive. But for some reason, it thinks, the hard-drive is an SD-card?!?! (Which it is obviously not.) I'm pretty sure that thing there named "HBG4e" IS the harddrive, since it is embarrassingly small (about 30 GB).
Last edited:
Since it appears the your partitioning is messed up - I would use Gparted on the LiveUSB since it now boots and redo the partitions simply delete the old ones and create a new one - Also check the Bios to see if you can set it to Legacy as per my post #8
If your Bios can be set to Legacy you only need two partitions 1) is 512MBs formatted to FAT32 with a boot flag and 2) the rest of the drive to ext4 set as primary - This is my Acer Laptop an Aspire E5-575G with Legacy Bios and partitioning my drive is a SSD at 256GBs - (see image)
The installer for Mint should do this - I have not used Mint in a while but it use to be the Ubiquity Installer which is what Ubuntu uses. - So delete all partitions then create one partition and format the drive, then try to install Mint

Okay, that seems like a good way to go... However, there's already an obstacle: When I set the boot option in the BIOS menu to Legacy it says:
"No bootable device -- insert boot disk and press any key
This is not a bootable disk. Please insert a bootable floppy and press any key to try again ..."

Gparted does work however... I'm trying to fiddle around with that a little.
Okay, I managed to (somehow) install Linux Mint on my drive. At least I think, that it has worked.

However, the newly installed OS still won't boot on its own.

So I followed these instructions (#12) exactly step by step. But for some reason, it STILL doesnt't boot Linux Mint from the hard-drive.

When I'm starting the netbook it just says:

"Default Boot Device Missing or Boot Failed
Insert Recovery Media and Hit any key
Then Select 'Boot Manager' to choose a new Boot Device or to Boot Recovery Media"
Most likely need to change the BIOS again - here is youtube video a bit hard to understand the person most likely from India based on the accent
If I see correctly, that video only shows, how to switch to Legacy, which I've tried before.

Doing so leads to this:

Intel UNDI, PXE-2.1 (build 083)
Copyright (C) 1997-2000 Intel Corporation

This Product is covered by one or more of the following patents:
US6,570,884, US6,115,776 and US6,327,625

Realtek PCIe GBE Family Controller Series v2.59 (01/13/14)
PXE-E61:Media test failure, check cable

PXE-M0F: Exiting PXE ROM.
No bootable device -- insert boot disk and press any key

Pressing Enter only leads to that message being repeated identically.

If I disable "network boot" in the BIOS menu I get this:

No bootable device -- insert boot disk and press any key

So for some reason, the BIOS doesn't recognize Linux Mint on the hard-drive as OS.

Going back to the other boot-option I have booted Linux Mint from USB again to have another look at the partitions. I must have made a mistake, but I don't know what it is.

Last edited:
When opening Gparted from the terminal it should be
sudo gparted
Gparted needs Admin privileges

Since Gparted is showing EFI System Partition you need a linux-swap partition - the old way was to make your swap twice the amount of ram but this is no longer the case - you only need about 2GBs of swap space - In fact, Ubuntu automatically creates a swap file of 2 GB in size by default. This should give you an indication that having some swap space is recommended. How big to make the swap partition is of different opinions

For example - Cent OS recommends - Twice the size of RAM if RAM is less than 2 GB or if the Size of RAM + 2 GB if RAM size is more than 2 GB i.e. 6GB of swap for 4GB of RAM

Ubuntu has a different perspective on the swap size as it takes Hibernation into consideration - If RAM is more than 1 GB, swap size should be at least equal to the square root of the RAM size and at most double the size of RAM and If hibernation is used.

For example - Under Ubuntu - if your machine has 8 GBs of ram with no hibernation you would take the Square Root of 8 which is 2.828 so you would round up to 3 so your swap file size for no hibernation is 3GBs
If you are using Hibernation the it would be 8GBs of RAM + the Square Root of the RAM so that would be 11Gbs of swap space

Since Mint is based on Ubuntu then I would use Ubuntu's recommendation method

You can decrease the size of your primary partition by the amount you want your new swap to be in Gparted
OH MY GOD! It actually works now. Thank you SO MUCH for your help. I was about to lose my mind over this. You're a hero. :cool:

Hooowever, this thing still does something weird. Whenever I start the netbook, it STILL says this:


But when I press "Ok", I actually get to the Boot Manager:


And when I select the ominous "unknown device", it ACTUALLY boots Linux Mint from the harddrive. It's a little slow, but all in all, that's not a big problem. If I can't get rid of this quirk, it wouldn't be too bad, I guess.

Members online