• NOTICE: If you are reading this, you are hitting our new server. We expect there to be some bugs - please let us know if you come across anything, THANKS!

Boot problems with Ubuntu - boot hangs

yetanotherjohn

New Member
Ubuntu hangs during boot. I am using an HP 14-CF1 laptop currently running windows 10. I have a 100GB partition unallocated on NVMe SSD waiting for ubuntu install and 8 gigs of RAM. Fastboot and secureboot are both disabled. UEFI bios. I have a USB stick with 18.04 created with Rufus using MBR and BIOR or UEFI. (I have also tried using GPT and UEFI). I editied the "Try ubuntu" grub to remove the "quiet splash" and replace it with "nomodeset" so I could see where the boot was hanging. Boot hangs at "A start job is running for monitoring of LVM2 mirrors, snapshot, etc using DMEVENTED or progress polling" it sits on that for 30 seconds and then hangs.

I exchanged the PC (still under warranty) and get the same problem, so it isn't bad hardware. Any ideas on how to get Ubuntu to boot? I have been told that Ubuntu booting is pretty bulletproof, but there seems to be a hole in the armor.
 
Last edited:


atanere

Well-Known Member
Hi John, and welcome. Some Googling around found a few things that might help, but I'm far from certain. It may be a BIOS/UEFI setting that still needs tweaking, beyond what you've already done. And it may be related to the NVMe drive... they are not always Linux friendly. Ubuntu is a good choice though. There are many people using it and someone, somewhere, will have the solution.

BIOS/UEFI (things to consider or try... you may not have all of these):
1. SATA controller to AHCI
2. Disable TPM
3. Disable RAID
4. Disable "Intel Rapid Storage Technology"

Ubuntu Boot:
Instead of nomodeset, replace quiet splash with "nvme_load=YES" (without quotes)

Some of these tips came from here and here. Some came from memory (which isn't that good anymore).

You'll get there. But it can be difficult in the beginning, and even more so with more modern hardware.

Good luck!
 

yetanotherjohn

New Member
Thanks for the reply atanere.

I first tried replacing the quiet splash with nvme_load=yes (I used lower case, don't know if that would effect things) and same result.
The second thing I tried was disabling the TPM. The boot hung in a different place
"Begin: Preconfiguring networking … … [48.12]nvme ncme0: controller is down; will reset; csts = 0xffffffff, pci_status = 0xffff"
I'm not sure what that is about.
I don't have raid drives so can't disable that.
Found "Intel rapid storage technology" in bios but no raid drives so couldn't disable.
Not sure how to set SATA controller to ACHI. No SATA controller, just NVME.
Any other ideas?

I went back and tried nvme_load=YES with TPM disables. Same result. boot hung at
"Begin: Preconfiguring networking … … [48.193664]nvme ncme0: controller is down; will reset; csts = 0xffffffff, pci_status = 0xffff"

It does appear that the issue is the nvme controller vs SATA controller.

I tried one more thing, I set Clear TPM to yes in the bios (with TPM disabled). Same NVME controller is down message.
I also tried with Ubuntu 19.04.
 
Last edited:

atanere

Well-Known Member
Hey John... that's it, try different things, along with Googling around some more. I'll try to look more also. Something may pop up, but some things I saw earlier today also indicated some trouble may not be overcome (as in, it may depend on what brand drive your nvme is, for example). I like HP products and have several in use, but nothing as new as yours. If a UEFI update is available, by all means try that also.

If you're up for it, try other distros too. Linux Mint is based on Ubuntu... but sometimes works better. Very popular right now (on DistroWatch) is MX-Linux and Manjaro. Try booting on both USB and DVD if you have a DVD drive. An external DVD burner is something I keep around for rare/strange circumstances.

Although the nvme drive does seem to be highly suspect, don't let that focus blind you to other things. Video adapters can also be notorious for hanging/freezing Linux booting (especially nVidia adapters). And maybe it is something else in UEFI settings other than what we've already covered.

I hope you have also made a backup of anything super critical on your Windows partition... unless it wouldn't matter to you if you lost it. You probably won't... but I have had enough "oops!" moments that it is always good to remind folks that Linux can be very unforgiving sometimes.

If nothing else seems to work, you might also try installing VirtualBox or other virtualization software in Windows, and then install Linux in a virtual machine. It may not be quite as good as a bare-metal install, but it might be the quickest way to get your feet wet with Linux. And its an excellent way to experiment with a variety of distros without hosing up hard drive partitions.
 

yetanotherjohn

New Member
Thanks for the encouragement atanere. I have tried a lot. I have tried 6 different kinds of Linux. The ubuntu line of Linux (like Linux mint) hang in the same way. Debian and redhat lines hung also, but differently.
Video adaptor is intel 620. Given that it is LVM2 causing the hang, pretty sure it is the SSD as the3 problem, but would love other things to try.
I have done lots of googling, even found this exact problem from someone last April, but haven't seen any answer to the problem.
Any suggestions on things to try gratefully received.
 
Last edited:

atanere

Well-Known Member
Given that it is LVM2 causing the hang
Hmmm, I wonder. Your Linux USB is not formatted in LVM, nor is your NVMe drive. So why hang on something that isn't in use? I wonder if there is a boot command that could disable the LVM2 sequence? Something to think about, but I'm not sure if possible, or how.
 

atanere

Well-Known Member
Another stab in the dark: Go back into your Windows Disk Management and delete the unallocated space you created for Linux. It should rejoin the space back to your Windows partition... be sure it does. Then try booting on your Ubuntu, or whatever.

Crazy idea that LVM is looking at that space and complaining.
 

yetanotherjohn

New Member
I got Ubuntu to boot. In the grub, I added acpi=off. It means the SSD drive on the laptop is off. I then was able to boot Ubuntu. I am now trying to get Ubuntu installed on my USB drive so I can operate off of it (since the SSD drive is not working under Linux). What I hope then is to find drivers under Linux that will enable me to get the SSD back. Thanks for the help.
 

atanere

Well-Known Member
Great! :D Sort of... o_O

I realize your battle may not be over yet, but it's great news that you've finally made some forward progress with it. The parameter acpi=off is quite common to apply to Linux booting, but it does seem strange in your situation (and was obviously not on my radar from your symptoms).

But that's how we all learn stuff here, and I hope that your struggle will benefit others after you too. Please keep us posted with your experience!

Cheers
 

webbi87

New Member
Hi! I have a Dell Inspiron 5575 (Ryzen 5 + Vega8) with WD BLUE SN500 NVME SSD 256GB, and trying to install any ubuntu flavour without success.

Tried everything on grub boot (nomodeset, pci=nomsi,noaer, irqpoll, noapic, noacpi, etc.) without luck.

Symptoms are the same than @yetanotherjohn with "nvme controller is down", however didn't try "acpi=off" yet.

Do you found a solution to this problem?

Thanks!
 

atanere

Well-Known Member
Symptoms are the same than @yetanotherjohn with "nvme controller is down", however didn't try "acpi=off" yet.

Do you found a solution to this problem?
Hi @webbi87, and welcome. Last we heard from John, the "acpi=off" did the trick for him... at least it allowed him to boot on the NVMe drive. Give it a try to see if it helps your Dell. If not, please open a new thread to pursue the problem with your computer. Thanks!

Cheers
 

webbi87

New Member
@atanere Thanks for the welcome!
I'll be trying it in a few hours and posting if that did the trick.

Besides if "acpi=off" make it to boot, I concern about how it affect the correct functioning of the drive, I've read that it disables the power control and can produce some fails if the laptop is suspended.

Anyway, step by step, I'll be back with news
 

webbi87

New Member
Hello there! Good news here, I found the solution.

Problem was linux support with my SSD (Western Digital Blue SN500). As far as I understood, latest kernel comes with support for Samsung devices, but none talks about WD.
After a big research found that there is some sort of timeout that have to be changed for this kind of devices.

So, on the grub boot screen, press 'e' and edit the line that ends with 'quiet splash ---' to 'quiet splash nvme_core.default_ps_max_latency_us=5500', and that's all.

Finally I have to add that param to the grub config file so I dont have to add it on every boot.

Everything else appear to be working fine, almost what I have already tested.

Hope this helps for future reference, and thanks for your help!
 

Top