Bluetooth will not turn on on my laptop

ZennMystic

Member
Joined
Jul 7, 2021
Messages
48
Reaction score
12
Credits
449
Screenshot from 2024-05-13 22-09-04.png



I could not get the slider to work. So I bought a Bluetooth thing and plugged it in to the USB.
The slider now moves on or off, but nothing happens. Bluetooth is still off.

What information can I post for help? What commands should I run?

Thank you for your time.
 


You will need to furnish more info......which OS and which version of that os....is it updated completely etc
 
Try this

sudo apt-get install pulseaudio-module-bluetooth
reboot your system.

sudo systemctl start bluetooth.service
now open the GUI utility for the Bluetooth and make sure Bluetooth is set on "on"
in the terminal type
bluetoothctl
make sure that the command
actually shows something similar to
bluetooth]# show
Controller 20:16:D8:95:E5:03 (public)
Name: debian
Alias: debian
Class: 0x007c010c
Powered: yes
Discoverable: no
DiscoverableTimeout: 0x000000b4
Pairable: yes

Does it work?
 
I still could not get this ti work after...
sudo systemctl start bluetooth.service

So I did more reading and tried pipewire instead and that didn't work either....
So I did more searching and found multiple references to install ibluez* and blueman so I did that.
Then I tried sudo systemctl start bluetooth.service again and it worked.

I did blueroothctl and it said agent registered. I did show and it said No default controller available
Yet still no Bluetooth it still off even though slider is on
 
it was a typo bluez*

I really don't want to do a complete re-install to see if it will fix the issue. But I do not know what else to do. As I have tried what seems to be the most popular fix above.

Anyone?

Thank you for you time.
 
Screenshot of my software manager
2024-05-17_04-45.png

That is taken with a dongle inserted in a usb port

and using the command from above....
brian@brian-desktop:~$ inxi -Eaz
Bluetooth:
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
driver: btusb v: 0.8 bus-ID: 1-2:7 chip-ID: 0a12:0001 class-ID: e001
Report: hciconfig ID: hci0 rfk-id: 0 state: up address: <filter>
bt-v: 1.2 lmp-v: 2.0 sub-v: c5c hci-v: 2.0 rev: c5c
Info: acl-mtu: 310:10 sco-mtu: 64:8 link-policy: rswitch hold sniff park
link-mode: peripheral accept
service-classes: rendering, capturing, object transfer, audio, telephony
brian@brian-desktop:~$

Not sure if this helpful or not.

Also in software manager, there is: Bluez-obexd & Bluez-cups (probably printer related)... which are also installed
 
inxi -Eaz

Bluetooth:
Device-1: TP-Link UB500 Adapter type: USB driver: btusb v: 0.8
bus-ID: 2-1.1:3 chip-ID: 2357:0604 class-ID: e001 serial: <filter>
Report: hciconfig ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Info: acl-mtu: 0:0 sco-mtu: 0:0 link-mode: peripheral accept
 
Need to check for missing firmware now
lsusb; dmesg | egrep -i 'blue|firm'
or you can run
sudo dmesg | grep -i bluetooth
and post back the results - if it is missing firmware it should show something like
RTL: firmware file rtl_bt/rtl8761b_fw.bin not found
 
Last edited:
OK so I ran both of those commands here are the results:

lsusb; dmesg | egrep -i 'blue|firm'
Bus 002 Device 004: ID 04f2:b230 Chicony Electronics Co., Ltd Integrated HP HD Webcam
Bus 002 Device 003: ID 2357:0604 TP-Link TP-Link UB500 Adapter
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 138a:003c Validity Sensors, Inc. VFS471 Fingerprint Reader
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
dmesg: read kernel buffer failed: Operation not permitted


sudo dmesg | grep -i bluetooth
[ 19.818841] Bluetooth: Core ver 2.22
[ 19.818869] NET: Registered PF_BLUETOOTH protocol family
[ 19.818872] Bluetooth: HCI device and connection manager initialized
[ 19.818878] Bluetooth: HCI socket layer initialized
[ 19.818881] Bluetooth: L2CAP socket layer initialized
[ 19.818892] Bluetooth: SCO socket layer initialized
[ 19.983517] Bluetooth: hci0: RTL: examining hci_ver=0a hci_rev=000b lmp_ver=0a lmp_subver=8761
[ 19.984486] Bluetooth: hci0: RTL: rom_version status=0 version=1
[ 19.984492] Bluetooth: hci0: RTL: loading rtl_bt/rtl8761bu_fw.bin
[ 19.984520] bluetooth hci0: firmware: failed to load rtl_bt/rtl8761bu_fw.bin (-2)
[ 19.984571] bluetooth hci0: firmware: failed to load rtl_bt/rtl8761bu_fw.bin (-2)
[ 19.984587] bluetooth hci0: Direct firmware load for rtl_bt/rtl8761bu_fw.bin failed with error -2
[ 19.984591] Bluetooth: hci0: RTL: firmware file rtl_bt/rtl8761bu_fw.bin not found
[ 27.468082] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 27.468093] Bluetooth: BNEP filters: protocol multicast
[ 27.468102] Bluetooth: BNEP socket layer initialized
 

Members online


Top