Bluetooth low range issue

Maubriel

New Member
Joined
May 25, 2024
Messages
5
Reaction score
1
Credits
51
Hello!
I'm running Fedora 40 on my Dell Inspiron 7386 and having problems when I connect my mouse Logitech M650 and headset Redragon H848 with Bluetooth. The laptop connects successfully with both devices but has very low range; i.e., I can't move the mouse 15 cm away from the laptop without the cursor moving laggy and if I sit properly (my head 50 cm away from the laptop) the headset reproduce choppy audio, everything works normal only if both devices are super close to the laptop.
Also, I'll like to note that when I try to use the dongles of both devices, neither of them works, I don't know if this issue is related. Fortunately I can wire the headset but the mouse is wireless only.

I searched for solutions but what I found are some commands to check if the Bluetooth is working fine and I think the outputs says it's fine. Although I don't fully understand what I'm reading.
Code:
[maubriel@fedora ~]$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 27c6:538c Shenzhen Goodix Technology Co.,Ltd. Fingerprint Reader
Bus 001 Device 003: ID 0c45:671b Microdia Integrated_Webcam_HD
Bus 001 Device 004: ID 8087:0aaa Intel Corp. Bluetooth 9460/9560 Jefferson Peak (JfP)
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

[maubriel@fedora ~]$ lsmod | grep bluetooth
bluetooth            1064960  60 btrtl,btmtk,btintel,btbcm,bnep,btusb,rfcomm
rfkill                 40960  11 iwlmvm,bluetooth,dell_laptop,cfg80211

[maubriel@fedora ~]$ rfkill
ID TYPE      DEVICE      SOFT      HARD
 0 bluetooth hci0   unblocked unblocked
 1 wlan      phy0   unblocked unblocked

[maubriel@fedora ~]$ ps -e | grep pipewire
   1349 ?        00:00:33 pipewire
   2015 ?        00:00:28 pipewire-pulse

[maubriel@fedora ~]$ systemctl status bluetooth
● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; preset: enabled)
    Drop-In: /usr/lib/systemd/system/service.d
             └─10-timeout-abort.conf
     Active: active (running) since Fri 2024-05-24 19:07:29 -04; 1h 22min ago
       Docs: man:bluetoothd(8)
   Main PID: 881 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 9095)
     Memory: 3.2M (peak: 6.8M)
        CPU: 1.889s
     CGroup: /system.slice/bluetooth.service
             └─881 /usr/libexec/bluetooth/bluetoothd

[maubriel@fedora ~]$ lsusb -v | grep Bluetooth | grep DeviceProtocol
Couldn't open device, some information will be missing
Couldn't open device, some information will be missing
Couldn't open device, some information will be missing
Couldn't open device, some information will be missing
Couldn't open device, some information will be missing
  bDeviceProtocol         1 Bluetooth

[maubriel@fedora ~]$ lsusb -t | grep Wireless
    |__ Port 010: Dev 004, If 0, Class=Wireless, Driver=btusb, 12M
    |__ Port 010: Dev 004, If 1, Class=Wireless, Driver=btusb, 12M
 


@Maubriel
Welcome to the forums!

How do you connect to the internet? WI-FI or LAN cable?

If you connect with wireless then it's very likely that there is signal interference between blutooth and wi-fi.
I suggest you disconnect from internet and bring wi-fi card down (turn off) and then test your bluetooh devices to see if that's the case.
 
@Maubriel
Welcome to the forums!

How do you connect to the internet? WI-FI or LAN cable?

If you connect with wireless then it's very likely that there is signal interference between blutooth and wi-fi.
I suggest you disconnect from internet and bring wi-fi card down (turn off) and then test your bluetooh devices to see if that's the case.
I disabled the WI-FI service in the BIOS and things improved a bit.
The mouse now works in an acceptable range, although it lagged a bit in one test and I have to turn off and on the bluetooth to fix it (a bit annoying if it happens often).
The headset improved a bit but still lacks range. Now I can sit properly and the sound is fine, but if move away a little the audio cuts out for a second from time to time. And if I move away more there is not sound.

It's possible to have more range and not have the interference between wifi and bluetooth?
 
@Maubriel
Since the issue improved but persists after turning off your wi-fi then other wi-fi networks around you are influencing bluetooth frequency.

Bluetooth frequency can't be changed AFAIK.

Please connect to wi-fi, open your terminal and resize it to consume full screen then run nmcli dev wifi

Take screenshot of command output and share the screenshot here.

NOTE: You might not want to share wi-fi networks in public forums, in that case copy output to notepad and anonymize network names and share anonymized output here.
 
@CaffeineAddict
I put the command multiple times and got different outputs. I think the BSSID is what I have to censor.
Claro2021 is my wifi.

wifi.jpg
 
Those networks in channel range 1-11 are which work on around same frequency as bluetooth.

Question, was your bluetooth headset and stuff expensive or very cheap one? I suspect it doesn't have strong enough receive\transmit power.

Do you have make and model of your BT headset?
 
My headset is the Redragon Ire Pro H848 that costs 43 USD in Amazon, I think it is neither cheap or expensive.
This headset has high range when I connect to mi smartphone though. And I didn't have problems with the bluetooth of my laptop when the OS was Windows 10.
 
This headset has high range when I connect to mi smartphone though. And I didn't have problems with the bluetooth of my laptop when the OS was Windows 10.
OK, another question, I see you have your wifi set to both 5Ghz and 2.4Ghz.
Is that necessary?

Your 2.4Ghz network has inconsistent channeling, this is likely caused by router.
Since bluetooth works also on 2.4Ghz (2483.5 Mhz) I suggest you set a fixed channel that's as far away from that value as possible, and that would be channel 1, but since there are other networks operating on same channel you might want to later set to channel 2 or max 3 in case if wifi gets degraded.

But for bluetooth testing you want channel 1 which operates at 2401 - 2423 Mhz which is as far away from bluetooth as possible.

To change the channel of your 2.4Ghz wifi you need to log-in to router and set fixed channel to 1 so that it stays 1 (ex. static, not dynamic channel)
Leave 5Ghz wifi alone or if not needed for testing purposes disable it.

Alternatively, disable 2.4 and leave 5Ghz wifi only which should be even better approach if nothing works.

EDIT:

@Maubriel
Your headset supports 2.4G wifi and wired connectivity in addition to bluetooth.

If my steps with channles in previous post don't work I suggest you connect it via wifi or via cable.
antena power is 10db which is good enough, but sadly that doesn't help with BT.
Alternatively you might want to check if wifi in the headset itself can be turned off as that might cause BT to not work well.
 
Last edited:
@CaffeineAddict Hi, sorry for the late reply
I couldn't access the router since I don't have the login information and my Intenet provider didn't want to give me the information. What I could do is split the wifi 5Ghz and 2.4Ghz and now I'm connected only to the 5Ghz, but I couldn't disable the 2.4Ghz. The problem persists.

About the 2.4G connection, that's only with the dongle that comes with the headset, the laptop detects it and I can set the headset as the audio output but there is no sound at all.
Only the wired connection works well, though sometimes when I pause a video and then resume, the output switches to the laptop speakers and I have to turn off and on the headset to make it work again.
 


Top