<!DOCTYPE html>
<html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs uix_javascriptNeedsInit LoggedOut Sidebar  Responsive pageIsLtr hasWelcomeBlock  hasTabLinks  hasSearch   is-sidebarOpen hasRightSidebar is-fullWidth navStyle_0 pageStyle_0 hasFlexbox" xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png">
<link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32">
<link rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16">
<link rel="manifest" href="/manifest.json">
<link rel="mask-icon" href="/safari-pinned-tab.svg" color="#5bbad5">
<meta name="theme-color" content="#ffffff">
<meta charset="utf-8"/>
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1"/>
<meta name="viewport" content="width=device-width, initial-scale=1"/>
<base href="https://www.linux.org/"/>
<title>Bluetooth and Linux | Linux.org</title>
<noscript><style>.JsOnly,.jsOnly{display:none!important;}</style></noscript>
<link rel="stylesheet" href="css.php?css=xenforo,form,public&amp;style=3&amp;dir=LTR&amp;d=1497569485"/>
<link rel="stylesheet" href="css.php?css=BRMI_forum_list_sidebar,EWRporta2_Global,bb_code,login_bar,message,message_user_info,moderator_bar,notices,polls,share_page,thread_view,uix_extendedFooter,uix_welcomeBlock,wf_default&amp;style=3&amp;dir=LTR&amp;d=1497569485"/>
<link rel="stylesheet" href="css.php?css=uix,uix_style&amp;style=3&amp;dir=LTR&amp;d=1497569485"/>
<style></style>
<link rel="stylesheet" href="css.php?css=EXTRA&amp;style=3&amp;dir=LTR&amp;d=1497569485"/>
<style></style>
<link href="styles/uix/uix/css/font-awesome.min.css" rel="stylesheet">
<link href='//fonts.googleapis.com/css?family=Open+Sans:300,400,700,600' rel='stylesheet' type='text/css'>
<!--[if lt IE 9]>
	

<![endif]-->
<link href="/favicon.ico" rel="icon" type="image/x-icon"/>
 
<link rel="alternate" type="application/rss+xml" title="RSS feed for Linux.org" href="forums/-/index.rss"/>
<link rel="canonical" href="https://www.linux.org/threads/bluetooth-and-linux.4555/"/>
<meta name="description" content="Bluetooth is a wireless technology mainly for close range. The technology is managed by the Bluetooth Special Interest Group (SIG).

Most devices have..."/> <meta property="og:site_name" content="Linux.org"/>
<meta property="og:image" content="https://www.linux.org/data/avatars/m/29/29858.jpg?1495487162"/>
<meta property="og:image" content="https://www.linux.org/images/linuxfav.png"/>
<meta property="og:type" content="article"/>
<meta property="og:url" content="https://www.linux.org/threads/bluetooth-and-linux.4555/"/>
<meta property="og:title" content="Bluetooth and Linux"/>
<meta property="og:description" content="Bluetooth is a wireless technology mainly for close range. The technology is managed by the Bluetooth Special Interest Group (SIG).

Most devices have..."/>
<meta name="theme-color" content="rgb(73, 147, 197)">
<meta name="msapplication-TileColor" content="rgb(73, 147, 197)">
</head>
<body class="node178 node192 node170 node171 SelectQuotable">
<div id="loginBar">
<div class="pageContent">
<span class="helper"></span>
</div>
<div class="pageWidth">
</div>
</div>
<div class="js-uix_panels uix_panels ">
<aside class="js-sidePanelWrapper sidePanelWrapper  sidePanelWrapper--left">
<a href="#" class="js-panelMask uix_panelMask"></a>
<div class="sidePanel sidePanel--nav">
<nav>
<ul class="sidePanel__navTabs">
 
 
<li class="navTab articles ">
<a href="https://www.linux.org/" class="navLink">Home</a>
<a href="https://www.linux.org/" class="SplitCtrl"><i class="uix_icon js-offcanvasIcon uix_icon-expandDropdown"></i></a>
<div class="tabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="find-new/posts" rel="nofollow">Recent Posts</a></li>
<li><a href="recent-activity/">Recent Activity</a></li>
<li style="width: 50px; height: 10px;"></li>
<li><a href="articles/authors">Authors</a></li>
</ul>
</div>
</li>
 
<li class="navTab forums selected">
<a href="https://www.linux.org/forums/" class="navLink">Forums</a>
<a href="https://www.linux.org/forums/" class="SplitCtrl"><i class="uix_icon js-offcanvasIcon uix_icon-expandDropdown"></i></a>
<div class="tabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="search/?type=post">Search Forums</a></li>
<li><a href="find-new/posts" rel="nofollow">Recent Posts</a></li>
</ul>
</div>
</li>
 
 
<li class="navTab members ">
<a href="https://www.linux.org/members/" class="navLink">Members</a>
<a href="https://www.linux.org/members/" class="SplitCtrl"><i class="uix_icon js-offcanvasIcon uix_icon-expandDropdown"></i></a>
<div class="tabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="members/">Notable Members</a></li>
<li><a href="online/">Current Visitors</a></li>
<li><a href="recent-activity/">Recent Activity</a></li>
<li><a href="find-new/profile-posts">New Profile Posts</a></li>
</ul>
</div>
</li>
 
<li class="navTab siropuCustomTab custom-tab-1 ">
<a href="https://www.linux.org/account/upgrades" class="navLink Tooltip" title="Purchase a membership upgrade!">Membership Upgrade</a>
</li>
<li class="navTab siropuCustomTab custom-tab-2 ">
<a href="https://www.linux.org/forums/#linux-articles-and-tutorials.122" class="navLink Tooltip" title="Linux Tutorials">Linux Tutorials</a>
<a href="https://www.linux.org/forums/#linux-articles-and-tutorials.122" class="SplitCtrl"><i class="uix_icon js-offcanvasIcon uix_icon-expandDropdown"></i></a>
<div class="tabLinks">
<ul class="secondaryContent blockLinksList">
<li><a href="https://www.linux.org/forums/beginner-tutorials.123/" class="">Beginner Linux Tutorials</a></li>
<li><a href="https://www.linux.org/forums/intermediate-tutorials.124/" class="">Intermediate Linux Tutorials</a></li>
<li><a href="https://www.linux.org/forums/advanced-tutorials.125/" class="">Advanced Linux Tutorials</a></li>
</ul>
</div>
</li>
<li class="navTab siropuCustomTab custom-tab-6 ">
<a href="https://www.linux.org/pages/download/" class="navLink">Download Linux</a>
</li>
<li class="navTab siropuCustomTab custom-tab-8 ">
<a href="/docs/" class="navLink Tooltip" title="Linux man pages">Linux Man Pages</a>
</li>
</ul>
</nav>
</div>
</aside>
<aside class="js-sidePanelWrapper sidePanelWrapper  sidePanelWrapper--right">
<a href="#" class="js-panelMask uix_panelMask"></a>
<div class="sidePanel sidePanel--login">
<form action="login/login" method="post" class="xenForm--uixLoginForm xenForm">
<dl class="ctrlUnit fullWidth">
<dt><label for="ctrl_pageLogin_login">Your name or email address:</label></dt>
<dd><input type="text" name="login" value="" id="ctrl_pageLogin_login" class="textCtrl uix_fixIOSClickInput" tabindex="21"/></dd>
</dl>
<dl class="ctrlUnit fullWidth">
<dt><label for="ctrl_pageLogin_password">Password:</label></dt>
<dd>
<input type="password" name="password" class="textCtrl uix_fixIOSClickInput" id="ctrl_pageLogin_password" tabindex="22"/>
<div><a href="lost-password/" class="OverlayTrigger OverlayCloser" tabindex="26">Forgot your password?</a></div>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dd>
<input type="submit" class="button primary" value="Log in" data-loginPhrase="Log in" data-signupPhrase="Sign up" tabindex="24"/>
<label class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_pageLogin_remember" tabindex="23"/> Stay logged in</label>
</dd>
</dl>
<input type="hidden" name="cookie_check" value="1"/>
<input type="hidden" name="_xfToken" value=""/>
<input type="hidden" name="redirect" value="/threads/bluetooth-and-linux.4555/"/>
</form>
</div>
</aside>
<div class="mainPanelWrapper">
<a href="#" class="js-panelMask uix_panelMask"></a>
<div class="uix_wrapperFix" style="height: 1px; margin-bottom: -1px;"></div>
<div id="uix_wrapper">
<div class="uix_wrapperFix" style="height: 1px; margin-bottom: -1px;"></div>
<div id="headerMover">
<div id="headerProxy"></div>
<header>
<div id="header">
<div id="logoBlock" class="header__blockItem withSearch">
<div class="pageWidth">
<div class="pageContent">
<div id="logo"><a href="https://www.linux.org/">
<span></span>
<img src="styles/uix/uix/logo.png" alt="Linux.org"/>
</a></div>
<div id="searchBar" class="hasSearchButton">
<i id="QuickSearchPlaceholder" class="uix_icon uix_icon-search" title="Search"></i>
<div id="uix_searchMinimal">
<form action="search/search" method="post">
<i id="uix_searchMinimalClose" class="uix_icon uix_icon-close" title="Close"></i>
<i id="uix_searchMinimalOptions" class="uix_icon uix_icon-cog" title="Options"></i>
<div id="uix_searchMinimalInput">
<input type="search" name="keywords" value="" placeholder="Search..." results="0"/>
</div>
<input type="hidden" name="_xfToken" value=""/>
</form>
</div>
<fieldset id="QuickSearch">
<form action="search/search" method="post" class="formPopup">
<div class="primaryControls">
 
<i class="uix_icon uix_icon-search" onclick='$("#QuickSearch form").submit()'></i>
<input type="search" name="keywords" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter" id="QuickSearchQuery"/>
 
</div>
<div class="secondaryControls">
<div class="controlsWrapper">
 
<dl class="ctrlUnit">
<dt></dt>
<dd><ul>
<li><label><input type="checkbox" name="title_only" value="1" id="search_bar_title_only" class="AutoChecker" data-uncheck="#search_bar_thread"/> Search titles only</label></li>
</ul></dd>
</dl>
<dl class="ctrlUnit">
<dt><label for="searchBar_users">Posted by Member:</label></dt>
<dd>
<input type="text" name="users" value="" class="textCtrl AutoComplete" id="searchBar_users"/>
<p class="explain">Separate names with a comma.</p>
</dd>
</dl>
<dl class="ctrlUnit">
<dt><label for="searchBar_date">Newer Than:</label></dt>
<dd><input type="date" name="date" value="" class="textCtrl" id="searchBar_date"/></dd>
</dl>
<dl class="ctrlUnit">
<dt></dt>
<dd><ul>
<li><label title="Search only Bluetooth and Linux"><input type="checkbox" name="type[post][thread_id]" value="4555" id="search_bar_thread" class="AutoChecker" data-uncheck="#search_bar_title_only, #search_bar_nodes"/> Search this thread only</label></li>
<li><label title="Search only Linux Networking"><input type="checkbox" name="nodes[]" value="178" id="search_bar_nodes" class="Disabler AutoChecker" checked="checked" data-uncheck="#search_bar_thread"/> Search this forum only</label>
<ul id="search_bar_nodes_Disabler">
<li><label><input type="checkbox" name="type[post][group_discussion]" value="1" id="search_bar_group_discussion" class="AutoChecker" data-uncheck="#search_bar_thread"/> Display results as threads</label></li>
</ul></li>
</ul></dd>
</dl>
</div>
 
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
<input type="submit" value="Search" class="button primary Tooltip" title="Find Now"/>
<a href="search/" class="button moreOptions Tooltip" title="Advanced Search">More...</a>
<div class="Popup" id="commonSearches">
<a rel="Menu" class="button NoPopupGadget Tooltip" title="Useful Searches" data-tipclass="flipped"><span class="arrowWidget"></span></a>
<div class="Menu">
<div class="primaryContent menuHeader">
<h3>Useful Searches</h3>
</div>
<ul class="secondaryContent blockLinksList">
 
<li><a href="find-new/posts?recent=1" rel="nofollow">Recent Posts</a></li>
 
</ul>
</div>
</div>
</dd>
</dl>
</div>
<input type="hidden" name="_xfToken" value=""/>
</form>
</fieldset>
</div>
<span class="helper"></span>
</div>
</div>
</div>
<div id="navigation" class="header__blockItem  stickyTop">
<div class="sticky_wrapper">
<div class="uix_navigationWrapper">
<div class="pageWidth">
<div class="pageContent">
<nav>
<div class="navTabs">
<ul class="publicTabs navLeft">
<li id="logo_small">
<a href="https://www.linux.org/">
<img src="styles/uix/uix/logo_small.png">
</a>
</li>
<li class="navTab  navTab--panelTrigger navTab--navPanelTrigger PopupClosed">
<a class="navLink js-leftPanelTrigger" href="#">
<i class="uix_icon uix_icon-menu"></i><span class="trigger__phrase">Menu</span>
</a>
</li>
 
 
<li class="navTab articles Popup PopupControl PopupClosed">
<a href="https://www.linux.org/" class="navLink">Home</a>
<a href="https://www.linux.org/" class="SplitCtrl" rel="Menu"></a>
<div class="Menu JsOnly tabMenu articlesTabLinks">
<div class="primaryContent menuHeader">
<h3>Home</h3>
<div class="muted">Quick Links</div>
</div>
<ul class="secondaryContent blockLinksList">
<li><a href="find-new/posts" rel="nofollow">Recent Posts</a></li>
<li><a href="recent-activity/">Recent Activity</a></li>
<li style="width: 50px; height: 10px;"></li>
<li><a href="articles/authors">Authors</a></li>
</ul>
</div>
</li>
 
<li class="navTab forums selected">
<a href="https://www.linux.org/forums/" class="navLink">Forums</a>
<a href="https://www.linux.org/forums/" class="SplitCtrl" rel="Menu"></a>
<div class="tabLinks forumsTabLinks">
<div class="primaryContent menuHeader">
<h3>Forums</h3>
<div class="muted">Quick Links</div>
</div>
<ul class="secondaryContent blockLinksList">
<li><a href="search/?type=post">Search Forums</a></li>
<li><a href="find-new/posts" rel="nofollow">Recent Posts</a></li>
</ul>
</div>
</li>
 
 
<li class="navTab members Popup PopupControl PopupClosed">
<a href="https://www.linux.org/members/" class="navLink">Members</a>
<a href="https://www.linux.org/members/" class="SplitCtrl" rel="Menu"></a>
<div class="Menu JsOnly tabMenu membersTabLinks">
<div class="primaryContent menuHeader">
<h3>Members</h3>
<div class="muted">Quick Links</div>
</div>
<ul class="secondaryContent blockLinksList">
<li><a href="members/">Notable Members</a></li>
<li><a href="online/">Current Visitors</a></li>
<li><a href="recent-activity/">Recent Activity</a></li>
<li><a href="find-new/profile-posts">New Profile Posts</a></li>
</ul>
</div>
</li>
 
<li class="navTab siropuCustomTab custom-tab-1 PopupClosed">
<a href="https://www.linux.org/account/upgrades" class="navLink Tooltip" title="Purchase a membership upgrade!">Membership Upgrade</a>
</li>
<li class="navTab siropuCustomTab custom-tab-2 Popup PopupControl PopupClosed">
<a href="https://www.linux.org/forums/#linux-articles-and-tutorials.122" class="navLink Tooltip" title="Linux Tutorials">Linux Tutorials</a>
<a href="https://www.linux.org/forums/#linux-articles-and-tutorials.122" class="SplitCtrl" rel="Menu"></a>
<div class="Menu JsOnly tabMenu siropuCustomTab custom-tab-2TabLinks">
<div class="primaryContent menuHeader">
<h3>Linux Tutorials</h3>
<div class="muted">Quick Links</div>
</div>
<ul class="secondaryContent blockLinksList">
<li><a href="https://www.linux.org/forums/beginner-tutorials.123/" class="">Beginner Linux Tutorials</a></li>
<li><a href="https://www.linux.org/forums/intermediate-tutorials.124/" class="">Intermediate Linux Tutorials</a></li>
<li><a href="https://www.linux.org/forums/advanced-tutorials.125/" class="">Advanced Linux Tutorials</a></li>
</ul>
</div>
</li>
<li class="navTab siropuCustomTab custom-tab-6 PopupClosed">
<a href="https://www.linux.org/pages/download/" class="navLink">Download Linux</a>
</li>
<li class="navTab siropuCustomTab custom-tab-8 PopupClosed">
<a href="/docs/" class="navLink Tooltip" title="Linux man pages">Linux Man Pages</a>
</li>
 
<li class="navTab navigationHiddenTabs navTab--justIcon Popup PopupControl PopupClosed" style="display:none">
<a rel="Menu" class="navLink NoPopupGadget uix_dropdownDesktopMenu"><i class="uix_icon uix_icon-navOverflow"></i><span class="uix_hide menuIcon">Menu</span></a>
<div class="Menu JsOnly blockLinksList primaryContent" id="NavigationHiddenMenu"></div>
</li>
 
</ul>
<ul class="navRight visitorTabs">
<li class="navTab audentio_postPagination" id="audentio_postPagination"></li>
<li class="navTab login PopupClosed">
<a href="login/" class="navLink uix_dropdownDesktopMenu OverlayTrigger" data-cacheOverlay="false">
<strong class="loginText">Log in</strong>
</a>
</li>
<li class="navTab register PopupClosed">
<a href="register/" class="navLink">
<strong>Sign up</strong>
</a>
</li>
</ul>
</div>
<span class="helper"></span>
</nav>
</div>
</div>
</div>
</div>
</div>
</div>
</header>
<div id="content" class="thread_view">
<div class="pageWidth">
<div class="pageContent">
 
<div class="breadBoxTop  ">
<nav>
<fieldset class="breadcrumb">
<a href="misc/quick-navigation-menu?selected=node-178" class="OverlayTrigger jumpMenuTrigger" data-cacheOverlay="true" title="Open quick navigation"><i class="uix_icon uix_icon-sitemap"></i> </a>
<div class="boardTitle"><strong>Linux.org</strong></div>
<span class="crumbs">
<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="https://www.linux.org/" class="crumb" rel="up" itemprop="url"><span itemprop="title"><i class="uix_icon uix_icon-home" title="Home"></i><span class="uix_breadcrumb__home__title">Home</span></span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="https://www.linux.org/forums/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Forums</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
<span class="crust" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="https://www.linux.org/forums/#linux-org-articles-and-tutorials.192" class="crumb" rel="up" itemprop="url"><span itemprop="title">Linux.org Articles and Tutorials</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
<span class="crust" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="https://www.linux.org/categories/linux-original-content.170/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Linux Original Content</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
<span class="crust" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="https://www.linux.org/categories/linux-articles.171/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Linux Articles</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
<span class="crust" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
<a href="https://www.linux.org/forums/linux-networking.178/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Linux Networking</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
<div class="sectionMain funbox">
<div class="funboxWrapper">
<div align="center">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
 
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4059641217434021" data-ad-slot="6079404386" data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div>
</div>
<div id="uix_welcomeBlock" class="">
<span class="uix_welcomeBlock__icon"><i class="uix_icon fa fa-info-circle"></i></span>
<a href="#" class="close"><i class="uix_icon uix_icon-close"></i></a>
<div class="uix_welcomeBlock__content">
<h3 class="uix_welcomeBlock__header">Welcome to Our Community</h3>
<p class="uix_welcomeBlock__message">While Linux.org has been around for a while, we recently changed management and had to purge most of the content (including users). If you signed up before April 23rd please sign up again.
Thanks!</p>
<div class="uix_welcomeBlock__button"><a href="index.php?register" class="signupButton"><span>Sign Up</span></a></div>
</div>
</div>
<div class="uix_contentFix">
<div class="mainContainer">
<div class="mainContent">
<!--[if lt IE 8]>
							<p class="importantMessage">You are using an out of date browser. It  may not display this or other websites correctly.<br />You should upgrade or use an <a href="https://www.google.com/chrome/browser/" target="_blank">alternative browser</a>.</p>
						<![endif]-->
<div class="FloatingContainer Notices">
<div class="DismissParent Notice notice_1 " data-notice="1" data-delay-duration="0" data-display-duration="0" data-auto-dismiss="0">
<div class="floatingItem primary">
<a href="account/dismiss-notice?notice_id=1" title="Dismiss Notice" class="DismissCtrl Tooltip" data-offsetx="7" data-tipclass="flipped">Dismiss Notice</a>
<div class=" baseHtml noticeContent">
<a href="http://www.linux.org/threads/linux-org-under-new-management.1/">Linux.org under new management -
click here for details</a>
</div>
</div>
</div>
</div>
 
<div class="titleBar">
<h1>Bluetooth and Linux</h1>
<p id="pageDescription" class="muted ">
Discussion in '<a href="forums/linux-networking.178/">Linux Networking</a>' started by <a href="members/jarret-b.29858/" class="username" dir="auto">Jarret B</a>, <a href="threads/bluetooth-and-linux.4555/"><span class="DateTime" title="May 29, 2017 at 6:45 PM">May 29, 2017</span></a>.
</p>
</div>
 
<div class="pageNavLinkGroup">
<div class="linkGroup SelectionCountContainer">
</div>
</div>
<div class="sectionMain funbox">
<div class="funboxWrapper">
<div align="center">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
 
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4059641217434021" data-ad-slot="9743574380" data-ad-format="link"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div>
</div>
<form action="inline-mod/post/switch" method="post" class="InlineModForm section" data-cookieName="posts" data-controls="#InlineModControls" data-imodOptions="#ModerationSelect option">
<ol class="messageList" id="messageList">
<li id="post-12685" class="sectionMain message     uix_threadAuthor uix_discussionAuthor" data-author="Jarret B">
<div class="uix_message ">
<div class="messageUserInfo" itemscope="itemscope" itemtype="http://data-vocabulary.org/Person">
<div class="messageUserBlock  is-expanded ">
<div class="avatarHolder is-expanded">
<div class="uix_avatarHolderInner">
<span class="helper"></span>
<a href="members/jarret-b.29858/" class="avatar Av29858m" data-avatarhtml="true"><img src="data/avatars/m/29/29858.jpg?1495487162" width="96" height="96" alt="Jarret B"/></a>
 
</div>
</div>
<h3 class="userText">
<div class="uix_userTextInner">
<a href="members/jarret-b.29858/" class="username" dir="auto" itemprop="name">Jarret B</a>
<em class="userTitle" itemprop="title">Member</em>
</div>
 
</h3>
<div class="extraUserInfo is-expanded">
<dl class="pairsJustified">
<dt>Joined:</dt>
<dd>May 22, 2017</dd>
</dl>
<dl class="pairsJustified">
<dt>Messages:</dt>
<dd><a href="search/member?user_id=29858" class="concealed" rel="nofollow">69</a></dd>
</dl>
<dl class="pairsJustified">
<dt>Likes Received:</dt>
<dd>3</dd>
</dl>
</div>
<span class="arrow"><span></span></span>
</div>
</div>
<div class="messageInfo primaryContent">
<div class="messageContent">
<article>
<blockquote class="messageText SelectQuoteContainer ugc baseHtml">
Bluetooth is a wireless technology mainly for close range. The technology is managed by the Bluetooth Special Interest Group (SIG).<br/>
<br/>
Most devices have Bluetooth ability such as smart phones, speakers, headphones, laptops, keyboards, mice, printers gaming consoles, etc. Having a basic understanding of Bluetooth will help you when dealing with the devices.<br/>
<br/>
<b>Bluetooth Overview</b><br/>
<br/>
The name Bluetooth came from the head of the Intel technological development, Jim Kardach. At the time, he was reading ‘The Long Ships’ which is about vikings and the Herald Bluetooth who brought the Danish together into one a kingdom. In connection, the Bluetooth standard would bring together multiple various devices to communicate together.<br/>
<br/>
Bluetooth uses the 2.4 GHz band similar to Wi-Fi, specifically from 2.400-2.485 GHz. The initial Bluetooth standard was created to replace RS-232 connections with a wireless method. The RS-232 connections are for communication (COM) or serial ports on computers.<br/>
<br/>
Bluetooth allows for a connection of seven devices. One device acts as a ‘master’ device, sometimes called a transmitter, while the other devices are considered ‘slaves’, sometimes called receivers. For example, a Bluetooth dongle on a PC (or one built in) will act as a ‘master’ and send audio signals to a headphone, which is the ‘slave’ device. Devices can switch their roles as ‘master’ and ‘slave’. For example, headphones may initiate a call from a smart phone. The headphones are initially the ‘master’. After a call is connected form the smart phone then the phone can become the ‘master’ and the headphones the ‘slave’.<br/>
<br/>
When a device is connected to another device the two devices are considered a ‘piconet’. Again, up to seven devices can be a ‘piconet’. It is possible for a ‘master’ or ‘slave’ to belong to a second ‘piconet’ which is then considered a ‘scatternet’.<br/>
<br/>
When a ‘piconet’ is established it is possible for the ‘master’ device to send a broadcast meant for all devices or to communicate with only one device. A round-robin method is used as needed. The round-robin method is where each device is communicated with one after another in succession. The ‘slave’ devices will receive the signals from the ‘master’, but only act on those meant for itself.<br/>
<br/>
<b>Bluetooth Communications</b><br/>
<br/>
Packets are sent by Bluetooth on channels. On the used band each channel is 1 MHz from the next channel making for a total of 79 channels. For Low Energy (LE) Bluetooth the channels are separated by 2 MHz allowing for only 40 channels. Around 800 packets can be sent in a second.<br/>
<br/>
Because the ‘piconet’ is set up as a ‘master/slave’ configuration all of the devices work off of the clock of the ‘master’. The ‘master’ clock will ‘tick’ every 312.5 micro-seconds or every 312.5 millionths of a second. The ‘master’ will transmit on even ticks and receive data on odd ticks. The ticks are arranged in ‘slots’ and a packet can take up 1, 3 or 5 slots. Each slot is 625 micro-seconds.<br/><div align="center">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
 
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4059641217434021" data-ad-slot="6079404386" data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<br/>
<b>Bluetooth Classes</b><br/>
<br/>
Each Bluetooth device may be listed under a specific Class. The Class is not to be confused with the Bluetooth Version which describes the protocol standards and abilities. The Class is mainly used to specify the hardware ability for connection range.<br/>
<br/>
There are four Classes used in Bluetooth Hardware.<br/>
<br/>
Class 1 allows for a range for nearly 300 ft (100 m).<br/>
<br/>
Class 2 provides a maximum distance of 30 ft (10 m).<br/>
<br/>
Class 3 give a maximum range of around 3 ft (1 m).<br/>
<br/>
Class 4 has a maximum range of about 1.5 ft (.5 m).<br/>
<br/>
When you buy a Bluetooth device you may want to be aware of the distance limitations of the device if the specific Class under which the device operates is listed.<br/>
<br/>
<b>Bluetooth Versions</b><br/>
<br/>
Each version of the Bluetooth standard provides various functionality built off of the previous version. There is backwards compatibility, but the devices may not function as planned. For example, some low power functions are not supported by older devices and the two may not work together. Personally, I have a pair of headphones which will not work with an older version Bluetooth dongle.<br/>
<br/>
There are currently 5 main Bluetooth Versions and a few minor versions. The Versions are as follows:<br/>
<br/>
<ul>
<li>Version 1.0 and 1.0b<ul>
<li>Had problems with devices working together</li>
</ul></li>
<li>Version 1.1<ul>
<li>Fixed a lot of errors for Versions 1.0 and 1.0b</li>
</ul></li>
<li>Version 1.2<ul>
<li>Provides faster connection and discovery of devices.</li>
<li>Allows for Adaptive Frequency Hopping (AFH) to spread the signal over multiple frequencies</li>
<li>Higher speeds up to 721 Kb/s</li>
</ul></li>
<li>Version 2.0+EDR (2004)<ul>
<li>Enhanced Data Rate (EDR) which if supported by both devices can reach 2 Mb/s</li>
</ul></li>
<li>Version 2.1+EDR (2007)<ul>
<li>Included support for secure paining of two devices</li>
<li>Extended Inquiry Response (EIR) to provide more device information when two devices inquire about each other</li>
</ul></li>
<li>Version 3.0+HS (2009)<ul>
<li>Includes High Speed (HS) which has a theoretical speed of 24 Mb/s. The actual data is transferred over IEEE 802.11 (Wi-Fi)</li>
<li>Enhanced power control to reduce or increase range to keep device connected</li>
<li>L2CAP to provide a reliable channel connection</li>
<li>Streaming Mode (SM) to send data on unreliable channels</li>
<li>Unicast Connection to send service data and not have an L2CAP channel connection</li>
</ul></li>
<li>Version 4.0+LE (2010)<ul>
<li>Provides low-energy consumption</li>
<li>Single-mode – only Low Energy protocols used</li>
<li>Dual-mode – uses either a Bluetooth Smart or Classic chip</li>
</ul></li>
<li>Version 4.1 (2013)<ul>
<li>Adds features for usability</li>
</ul></li>
<li>Version 4.2 (2014)<ul>
<li>Introduces Internet of Things (IoT)</li>
</ul></li>
<li>Version 5 (2016)<ul>
<li>Added more features for IoT</li>
<li>Decided for no more minor upgrades, only major (no more ‘.#’)</li>
<li>Quadrupled effective range</li>
<li>Double effective speed</li>
</ul></li>
</ul><b>Bluetooth Interference</b><br/>
<br/>
Because of the transfer within the same band as Wi-Fi there can be interference. Usually interference only occurs when using earlier versions of Bluetooth.<br/>
<br/>
Bluetooth uses the band between 2.400-2.485 GHz. Wi-Fi uses the range from 2.400-2.482 GHz. You can see that nearly the whole range is overlapped.<br/>
<br/>
Since Bluetooth Version 1.2 introduced Adaptive Frequency Hopping most interference has been eliminated. Since the Bluetooth signal is being transferred across frequencies the time that there is interference is only in the milliseconds. If a frequency is found to produce interference then AFH will not use the specific frequency until it is free from interference.<br/>
<br/>
Assume you are using a Bluetooth device such as your phone and a pair of headphones to listen to music. If there is interference it would only last a few milliseconds at a time and you would not notice it. It is possible to get interference from another Bluetooth device such as a mouse. Every time you move your mouse the music becomes ‘choppy’ and when you stop moving the mouse the music is fine. In this case you need to use a new Bluetooth ‘master’ device for the mouse, preferably one that is Bluetooth Version 1.2 or greater.<br/>
<br/>
To find the version of a Bluetooth adapter type the command:<br/>
<br/>
<i>hciconfig -a</i><br/>
<br/>
You should get an output similar to Figure 1. The third last line shows the information ‘HCI Version: 2.0 (0x3)’ which is Bluetooth Version 2.0.<br/>
<br/>
<img src="https://www.linux.org/attachments/figure-01-jpg.655/" alt="Figure 01.jpg" class="bbCodeImage LbImage"/>
<br/>
<b>FIGURE 1</b><br/>
<br/>
The address ‘(0x3)’ also shows the address for the Version number as shown:<br/>
<br/>
0 - <i>Bluetooth</i> Core Specification 1.0b<br/>
1 - Bluetooth Core Specification 1.1<br/>
2 - Bluetooth Core Specification 1.2<br/>
3 - Bluetooth Core Specification 2.0 + EDR<br/>
4 - Bluetooth Core Specification 2.1 + EDR<br/>
5 - Bluetooth Core Specification 3.0 + HS<br/>
6 - Bluetooth Core Specification 4.0<br/>
7 - Bluetooth Core Specification 4.1<br/>
8 - Bluetooth Core Specification 4.2<br/>
9 - Bluetooth Core Specification 5.0<br/>
<br/>
As you can see from the chart ‘0x3’ or ‘3’ is for ‘Bluetooth 2.0+EDR’.<br/>
<br/>
If no Bluetooth adapter is found on your system then the command ‘hciconfig -a’ will not return any information. Even if my system has a Bluetooth dongle for a Logitech keyboard and mouse I do not get a result for the dedicated adapter.<br/>
<br/>
Another type of interference is signal blockage. Let’s say you have a Bluetooth single ear piece in your right ear and place your smart phone in your left back pocket. The signal will have to travel through your body to reach the device. In this case your body is blocking the signal between the devices. Try, if possible, to keep all Bluetooth devices in the same ‘piconet’ within close proximity and nothing to block the signal between them.<br/>
<br/>
I hope you understand Bluetooth a little better now and can make your ‘piconets’ work better.
<div class="messageTextEndMarker">&nbsp;</div>
</blockquote>
</article>
</div>
<div class="baseHtml signature messageText ugc">
<div class="uix_signatureWrapper uix_signatureToggleHover">
<div class="uix_signatureWrapperInner">
<aside class="uix_signature">
I work at home and I have an extremely beautiful wife named Cassandra. We&#039;ve been married nearly 24 years. We have four children at home: Eilly, Alyse, Morgan and Grant.<br/>
<br/>
I had a book come out called <b>EPUB: From the Ground Up</b>.<br/>
<br/>
Go to Amazon or Barnes and Noble to order a copy.<br/>
<br/>
<img src="http://img2.imagesbn.com/p/9780071830539_p0_v1_s260x420.JPG" class="bbCodeImage" alt="[&#x200B;IMG]" data-url="http://img2.imagesbn.com/p/9780071830539_p0_v1_s260x420.JPG"/><br/>
<br/>
You can contact me through <b>Linux.org</b> or at <a href="/cdn-cgi/l/email-protection#bcd6ddceced9c8dec9cfd9fcd4d3c8d1ddd5d092dfd3d1"><span class="__cf_email__" data-cfemail="89e3e8fbfbecfdebfcfaecc9e1e6fde4e8e0e5a7eae6e4">[email&#160;protected]</span><script data-cfhash='f9e31' type="text/javascript">/* <![CDATA[ */!function(t,e,r,n,c,a,p){try{t=document.currentScript||function(){for(t=document.getElementsByTagName('script'),e=t.length;e--;)if(t[e].getAttribute('data-cfhash'))return t[e]}();if(t&&(c=t.previousSibling)){p=t.parentNode;if(a=c.getAttribute('data-cfemail')){for(e='',r='0x'+a.substr(0,2)|0,n=2;a.length-n;n+=2)e+='%'+('0'+('0x'+a.substr(n,2)^r).toString(16)).slice(-2);p.replaceChild(document.createTextNode(decodeURIComponent(e)),c)}p.removeChild(t)}}catch(u){}}()/* ]]> */</script></a>.
</aside>
</div>
</div>
</div>
<div class="messageDetails">
<a href="threads/bluetooth-and-linux.4555/" title="Permalink" class="item muted postNumber hashPermalink OverlayTrigger" data-href="posts/12685/permalink">#1</a>
<span class="item muted">
<span class="authorEnd"><a href="members/jarret-b.29858/" class="username author" dir="auto">Jarret B</a>,</span>
<a href="threads/bluetooth-and-linux.4555/" title="Permalink" class="datePermalink">
<span class="DateTime" title="May 29, 2017 at 6:45 PM">May 29, 2017</span>
</a>
</span>
</div>
<div id="likes-post-12685"></div>
</div>
</div>
</li>
</ol>
<input type="hidden" name="_xfToken" value=""/>
</form>
<div class="pageNavLinkGroup">
<div class="linkGroup">
<a href="login/" class="concealed element OverlayTrigger">(You must log in or sign up to post here.)</a>
</div>
<div class="linkGroup" style="display: none"><a href="javascript:" class="muted JsOnly DisplayIgnoredContent Tooltip" title="Show hidden content by ">Show Ignored Content</a></div>
</div>
<div class="sharePage">
<h3 class="textHeading larger">Share This Page</h3>
<div class="tweet shareControl">
<a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-lang="en-US" data-url="https://www.linux.org/threads/bluetooth-and-linux.4555/" data-text="Bluetooth and Linux">Tweet</a>
</div>
<div class="plusone shareControl">
<div class="g-plusone" data-size="medium" data-count="true" data-href="https://www.linux.org/threads/bluetooth-and-linux.4555/"></div>
</div>
<div class="facebookLike shareControl">
<div class="fb-like" data-href="https://www.linux.org/threads/bluetooth-and-linux.4555/" data-width="400" data-layout="standard" data-action="recommend" data-show-faces="true" data-colorscheme="light"></div>
</div>
</div>
 
<form action="login/login" method="post" class="xenForm " id="login" style="display:none">
<div class="ctrlWrapper">
<dl class="ctrlUnit">
<dt><label for="LoginControl">Your name or email address:</label></dt>
<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101"/></dd>
</dl>
<dl class="ctrlUnit">
<dt>
<label for="ctrl_password">Do you already have an account?</label>
</dt>
<dd>
<ul>
<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105"/>
No, create an account now.</label></li>
<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler"/>
Yes, my password is:</label></li>
<li id="ctrl_registered_Disabler">
<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102"/>
<div class="lostPassword"><a href="lost-password/" class="OverlayTrigger OverlayCloser" tabindex="106">Forgot your password?</a></div>
</li>
</ul>
</dd>
</dl>
<dl class="ctrlUnit submitUnit">
<dt></dt>
<dd>
<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginPhrase="Log in" data-signupPhrase="Sign up"/>
<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103"/> Stay logged in</label>
</dd>
</dl>
</div>
<input type="hidden" name="cookie_check" value="1"/>
<input type="hidden" name="redirect" value="/threads/bluetooth-and-linux.4555/"/>
<input type="hidden" name="_xfToken" value=""/>
</form>
</div>
</div>
 
<aside class="uix_mainSidebar">
<div class="inner_wrapper">
<div class="sidebar">
<div class="section funbox">
<div class=" funboxWrapper">
<a target="_blank" href="https://www.linuxforum.com"><b>LinuxForum.com domain is for sale</b></a><br/><br/>
<a target="_blank" href="https://www.webmasterbrigade.com"><img src="/images/wb-250.png" border="0"></a><br/><br/>
</div>
</div>
<div class="section loginButton">
<div class="secondaryContent">
<label id="SignupButton"><a href="login/" class="inner OverlayTrigger" data-cacheOverlay="false">Sign up now!</a></label>
</div>
</div>
<div class="section funbox">
<div class=" funboxWrapper">
<div align="center">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
 
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4059641217434021" data-ad-slot="6079404386" data-ad-format="rectangle"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div>
</div>
<div class="section">
<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Poll" id="widget-13">
<h3><a href="threads/favorite-password-manager.12406/">What Password Manager do you use?</a></h3>
<div id="PollContainer" class="NoAutoHeader PollContainer widget-poll">
<form action="threads/favorite-password-manager.12406/poll/vote" method="post" class="pollBlock AutoValidator PollVoteForm" data-container="#PollContainer" data-max-votes="1">
<div class="pollContent">
<div class="overlayScroll pollResultsOverlay">
<ol class="pollResults noResults">
<li class="pollResult ">
<div class="votedIconCell"></div>
<h3 class="optionText">
Pass
</h3>
<div class="count" class="Tooltip" title="10.0%">
1 vote(s)
</div>
</li>
<li class="pollResult ">
<div class="votedIconCell"></div>
<h3 class="optionText">
LastPass
</h3>
<div class="count" class="Tooltip" title="20.0%">
2 vote(s)
</div>
</li>
<li class="pollResult ">
<div class="votedIconCell"></div>
<h3 class="optionText">
KeePass
</h3>
<div class="count" class="Tooltip" title="30.0%">
3 vote(s)
</div>
</li>
<li class="pollResult ">
<div class="votedIconCell"></div>
<h3 class="optionText">
KeePassX
</h3>
<div class="count" class="Tooltip" title="30.0%">
3 vote(s)
</div>
</li>
<li class="pollResult ">
<div class="votedIconCell"></div>
<h3 class="optionText">
Password Safe
</h3>
<div class="count" class="Tooltip" title="0.0%">
0 vote(s)
</div>
</li>
<li class="pollResult ">
<div class="votedIconCell"></div>
<h3 class="optionText">
Universal Password Manager
</h3>
<div class="count" class="Tooltip" title="0.0%">
0 vote(s)
</div>
</li>
<li class="pollResult ">
<div class="votedIconCell"></div>
<h3 class="optionText">
Dashlane
</h3>
<div class="count" class="Tooltip" title="0.0%">
0 vote(s)
</div>
</li>
<li class="pollResult ">
<div class="votedIconCell"></div>
<h3 class="optionText">
Encryptr
</h3>
<div class="count" class="Tooltip" title="0.0%">
0 vote(s)
</div>
</li>
<li class="pollResult ">
<div class="votedIconCell"></div>
<h3 class="optionText">
EnPass
</h3>
<div class="count" class="Tooltip" title="10.0%">
1 vote(s)
</div>
</li>
<li class="pollResult ">
<div class="votedIconCell"></div>
<h3 class="optionText">
Password Gorilla
</h3>
<div class="count" class="Tooltip" title="0.0%">
0 vote(s)
</div>
</li>
</ol>
</div>
</div>
<input type="hidden" name="_xfToken" value=""/>
<input type="hidden" name="_fromWidget" value="1"/>
</form>
</div>
</div>
</div><div class="section BRMIcontainer">
<div class="secondaryContent brmiMailchimpForm">
<h3>Newsletter</h3>
<div class="innerContent"></div>
</div>
</div>
<div class="section funbox">
<div class=" funboxWrapper">
<div align="center">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
 
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4059641217434021" data-ad-slot="6079404386" data-ad-format="rectangle"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div>
</div>
</div>
</div>
</aside>
</div>
<div class="breadBoxBottom">
<nav>
<fieldset class="breadcrumb">
<a href="misc/quick-navigation-menu?selected=node-178" class="OverlayTrigger jumpMenuTrigger" data-cacheOverlay="true" title="Open quick navigation"><i class="uix_icon uix_icon-sitemap"></i> </a>
<div class="boardTitle"><strong>Linux.org</strong></div>
<span class="crumbs">
<span class="crust homeCrumb">
<a href="https://www.linux.org/" class="crumb"><span><i class="uix_icon uix_icon-home" title="Home"></i><span class="uix_breadcrumb__home__title">Home</span></span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb">
<a href="https://www.linux.org/forums/" class="crumb"><span>Forums</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
<span class="crust">
<a href="https://www.linux.org/forums/#linux-org-articles-and-tutorials.192" class="crumb"><span>Linux.org Articles and Tutorials</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
<span class="crust">
<a href="https://www.linux.org/categories/linux-original-content.170/" class="crumb"><span>Linux Original Content</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
<span class="crust">
<a href="https://www.linux.org/categories/linux-articles.171/" class="crumb"><span>Linux Articles</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
<span class="crust">
<a href="https://www.linux.org/forums/linux-networking.178/" class="crumb"><span>Linux Networking</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav></div>
</div>
</div>
</div>
</div>
<footer>
<div class="footer">
<div class="pageWidth">
<div class="pageContent">
<dl class="choosers chooser_widthToggle">
<dt>Toggle Width</dt>
<dd><a href="javascript: uix.toggleWidth.toggle()" class='Tooltip' title="Toggle Width" rel="nofollow"><span class="uix_icon js-widthIcon uix_icon-compressWidth"></span></a></dd>
</dl>
<ul class="footerLinks">
<li><a href="https://www.linux.org/" class="homeLink">Home</a></li>
<li><a href="misc/contact" class="OverlayTrigger" data-overlayOptions="{&quot;fixed&quot;:false}">Contact Us</a></li>
<li><a href="help/">Help</a></li>
<li><a href="help/terms">Terms and Rules</a></li>
<li class="topLink"><a href="/threads/bluetooth-and-linux.4555/#XenForo"><i class="uix_icon uix_icon-jumpToTop"></i> <span class="uix_hide">Top</span></a></li>
</ul>
<span class="helper"></span>
</div>
</div>
</div>
<div id="uix_stickyFooterSpacer"></div>
<div class="bigFooter">
<div class="pageWidth">
<div class="pageContent">
<ul class="bigFooterRow bigFooterRow--mainRow bigFooterRow--has4Columns">
<li class="bigFooterCol bigFooterCol--col1">
<div class="section">
<h3 class="bigFooterHeader">
<i class="uix_icon fa fa-caret-square-o-right"></i>
About Us
</h3>
Linux.org is a friendly community where you won't be berated for asking questions.
<br/><br/>
We're all here to learn and help solve Linux issues. Some of us novice, others experts.
<br/><br/>
Sign up and let us know what you're working on!
</div>
</li>
<li class="bigFooterCol bigFooterCol--col2">
<div class="section">
<h3 class="bigFooterHeader">
<i class="uix_icon fa fa-caret-square-o-right"></i>
Quick Navigation
</h3>
<ul class="footerMenu">
<li><a href="/">Home</a></li>
<li><a href="/">Forums</a></li>
<li><a href="/pages/download/">Downloads</a></li>
<li><a href="/misc/contact">Contact</a></li>
</ul>
<p>Open the <a href="misc/quick-navigation-menu" class="OverlayTrigger jumpMenuTrigger" data-cacheoverlay="true" title="Open quick navigation">Quick Navigation</a></p>
</div>
</li>
<li class="bigFooterCol bigFooterCol--col3">
<div class="section">
<h3 class="bigFooterHeader">
<i class="uix_icon fa fa-facebook-square"></i>
Like us on Facebook
</h3>
<div id="fb-root"></div>
<div class="fb-page" data-href="https://www.facebook.com/TheLinuxForum/" data-tabs="timeline" data-height="260" data-small-header="true" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/TheLinuxForum/"><a href="https://www.facebook.com/TheLinuxForum/">Linux.org</a></blockquote></div></div>
</div>
</li>
<li class="bigFooterCol bigFooterCol--col4">
<div class="section">
<h3 class="bigFooterHeader">
<i class="uix_icon fa fa-users"></i>
Membership Upgrade
</h3>
The management works very hard to make sure the community is running the best software, best designs, and all the other bells and whistles. Support the site by purchasing a membership upgrade. We'd really appreciate it!
<br><br>
<a class="callToAction" href="/account/upgrades"><span>More Information</span></a>
</div>
</li>
</ul>
</div>
</div>
</div>
<div class="footerLegal">
<div class="pageWidth">
<div class="pageContent">
<ul class="uix_socialMediaLinks">
<li class="uix_socialLink uix_socialLink--facebook"><a href="https://www.facebook.com/TheLinuxForum/" target="_blank"><i class="uix_icon uix_icon-facebook"></i></a></li>
<li class="uix_socialLink uix_socialLink--twitter"><a href="https://twitter.com/LinuxDotOrg" target="_blank"><i class="uix_icon uix_icon-twitter"></i></a></li>
<li class="uix_socialLink uix_socialLink--googleplus"><a href="https://plus.google.com/u/0/+Linuxorg1" target="_blank"><i class="uix_icon uix_icon-googlePlus"></i></a></li>
<li class="uix_socialLink uix_socialLink--contact"><a href="misc/contact" class="OverlayTrigger" data-overlayOptions="{&quot;fixed&quot;:false}"><i class="uix_icon uix_icon-email"></i></a></li>
 
<li class="uix_socialLink uix_socialLink--rss"><a href="forums/-/index.rss" rel="alternate}" target="_blank"><i class="uix_icon uix_icon-rss"></i></a></li>
</ul>
<div id="copyright"><div><a href="https://marketplace.digitalpoint.com/digital-point-ad-positioning.989/item" target="_blank">Advertising Positioning</a> by <a href="https://www.digitalpoint.com/" target="_blank">Digital Point</a></div>
<a href="https://xenforo.com" class="concealed">Forum software by XenForo&trade; <span>&copy;2010-2017 XenForo Ltd.</span></a>
<div class="thCopyrightNoticeStyle">Theme designed by <a href="https://www.themehouse.com/xenforo/themes" title="Premium XenForo Themes" rel="nofollow" target="_blank">ThemeHouse</a>.</div>
</div>
<div id="BRCopyright" class="concealed muted" style="float:left;margin-left: 10px;"><style>@media (max-width:480px){.Responsive #BRCopyright span{display:none;}}</style><div class="muted"><a href="http://brivium.com/" class="concealed" title="Brivium Limited"><span>XenForo </span>Add-ons by Brivium<span> &trade; &copy; 2012-2017 Brivium LLC.</span></a></div></div>
<span class="helper"></span>
</div>
</div>
</div>
<div id="uix_jumpToFixed">
<a href="#XenForo" title="Top" data-position="top"><i class="uix_icon uix_icon-jumpToTop"></i></a>
<a href="#XenForo" title="Bottom" data-position="bottom"><i class="uix_icon uix_icon-jumpToBottom"></i></a>
</div>
</footer>
</div>
<div class="uix_wrapperFix" style="height: 1px; margin-top: -1px;"></div>
</div>
</div>
<div class="breadcrumbMeta">
<nav>
<fieldset class="breadcrumb">
<a href="misc/quick-navigation-menu?selected=node-178" class="OverlayTrigger jumpMenuTrigger" data-cacheOverlay="true" title="Open quick navigation"><i class="uix_icon uix_icon-sitemap"></i> </a>
<div class="boardTitle"><strong>Linux.org</strong></div>
<span class="crumbs">
<span class="crust homeCrumb">
<a href="https://www.linux.org/" class="crumb"><span><i class="uix_icon uix_icon-home" title="Home"></i><span class="uix_breadcrumb__home__title">Home</span></span></a>
<span class="arrow"><span></span></span>
</span>
<span class="crust selectedTabCrumb">
<a href="https://www.linux.org/forums/" class="crumb"><span>Forums</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
<span class="crust">
<a href="https://www.linux.org/forums/#linux-org-articles-and-tutorials.192" class="crumb"><span>Linux.org Articles and Tutorials</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
<span class="crust">
<a href="https://www.linux.org/categories/linux-original-content.170/" class="crumb"><span>Linux Original Content</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
<span class="crust">
<a href="https://www.linux.org/categories/linux-articles.171/" class="crumb"><span>Linux Articles</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
<span class="crust">
<a href="https://www.linux.org/forums/linux-networking.178/" class="crumb"><span>Linux Networking</span></a>
<span class="arrow"><span>&gt;</span></span>
</span>
</span>
</fieldset>
</nav>
</div>
 
<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.linux.org/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script><script>

	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
	
	ga('create', 'UA-3314314-270', 'auto');
	ga('send', 'pageview');

</script><script src="js/jquery/jquery-1.11.0.min.js"></script><script src="js/xenforo/xenforo.js?_v=ae6c8d87"></script><script src="js/xenforo/discussion.js?_v=ae6c8d87"></script><script src="js/brivium/MailchimpIntegrate/newsletter.js?_v=ae6c8d87"></script><script src="//cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.2/html5shiv.min.js"></script><script src="//cdnjs.cloudflare.com/ajax/libs/respond.js/1.4.2/respond.js"></script><script src="//cdnjs.cloudflare.com/ajax/libs/selectivizr/1.0.2/selectivizr-min.js"></script><script>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</script><script src="js/audentio/uix_style/functions.min.js?_v=ae6c8d87_1.5.13.0_1"></script><script>
	uix.adminJsError = function(errMsg) {
		console.error(errMsg);

		
	}

	uix.fixJsVisibility = function() {
		var userBar = $('.hasJs #userBar');
		var nodeList = $('.hasJs #forums, .hasJs .category_view .nodeList, .hasJs .watch_forums .nodeList');
		var panels = $('.js-uix_panels')
		if (userBar.length) userBar.css('display', 'block');
		if (nodeList.length) nodeList.css('visibility', 'visible');
		if (panels.length) $('.js-uix_panels').removeClass('needsInit');
		$('html').removeClass('uix_javascriptNeedsInit');
	}

	uix.catchJsError = function(err) {
		console.log("\n\n############============   Begin Copying Here   ============############\n\n")
		var errMsg = "Uh Oh!  It looks like there's an error in your page's javascript.  There will likely be significant issues with the use of the forum until this is corrected.  If you are unable to resolve this and believe it is due to a bug in your Audentio Design theme, contact Audentio support and include a copy of the text between the designated areas from your javascript console.  This is the error: \n\n" + err ;
		uix.fixJsVisibility();
		uix.adminJsError(errMsg);
		console.log("\n\n");
		console.log(err);
		console.log("\n\n");
		try {
			uix.debug(true);
		} catch (err) {
			console.log("Unable to include uix.debug();");
		}

		console.log("\n\n############============   End Copying Here   ============############\n\n");
	}

	$(document).ready(function(){
		if (typeof(audentio) === 'undefined' || typeof(uix.jsVersion) === 'undefined') {
			var errMsg = 'Uh Oh!  It looks like the javascript for your theme was not found in /js/audentio/uix_style/.\n\n';
			if (uix.jsGlobal) {
				errMsg += 'Your forum is set to use the same javascript directory for all your themes.  Consider disabling this or modifying the directory.  Options are located under Options > [UI.X] General.\n\n'
			} else {
				errMsg += 'Your theme has set the location of its javascript directory.  You may need to modify the javascript directory location style property located under [UI.X] Global Settings > Javascript Path.\n\n'
			}
			errMsg += 'If your files are in the directory specified, ensure that your file permissions allow them to be read.  There will likely be significant issues with the use of the forum until this is corrected.  If you are unable to resolve this, contact Audentio support.  This error has also been logged to the javascript console.';

			uix.fixJsVisibility();

			uix.adminJsError(errMsg);
		} else if (uix.jsHeadVersion.split('_')[0] != uix.jsVersion.split('_')[0]) {
			var errMsg = 'Uh Oh! It looks like the version of your javascript functions file does not match the version of your page_container_js_head template.  \n\nYour javascript functions file is version "' + uix.jsVersion + '". \nYour page_container_js_head is version "' + uix.jsHeadVersion + '".  \n\nIf your functions file version number is higher, ensure that you have merged all templates (especially page_container_js_head).  If your page_container_js_head version number is higher, ensure that you have correctly uploaded the latest version of the javascript functions file and that you have cleared anything that could cache an old version of the javascript (CDN / Cloudflare / etc.). \n\nThis issue could cause parts of your forum to not display or function correctly.  If this does not resolve the issue contact Audentio support.  This error has also been logged to the javascript console.';
			
			uix.fixJsVisibility();
			
			uix.adminJsError(errMsg);
		}
	});
</script><script>
	try {
		uix.dateHelper.phrase = {
			now: 'now',
			second: 's',
			minute: 'm',
			hour: 'h',
			day: 'd',
			week: 'w',
			year: 'y',
			century: 'c',
			ago: '{time} ago',
			future: 'in {time}'
		}


		uix.sticky.stickyMinDist = parseInt('50');

		$(document).ready(function(){
			try {
				
				
					audentio.pagination.enabled = true;
					
						audentio.grid.parentEle = 'navigation';
					
					audentio.pagination.outOfPhrase = '<span id="audentio_postPaginationCurrent" class="uix_postPagination_x"></span> / <span id="audentio_postPaginationTotal" class="uix_postPagination_y"></span>';
					audentio.pagination.enterIndexPhrase = 'Enter Index';
					audentio.pagination.offset = parseInt('0px');
				

				uix.initFunc();
			} catch (err) {
				uix.catchJsError(err);
			}
		});
	} catch (err) {
		uix.catchJsError(err);
	}
</script><script>(function(d, s, id) {
        var js, fjs = d.getElementsByTagName(s)[0];
        if (d.getElementById(id)) return;
        js = d.createElement(s); js.id = id;
        js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5&appId=235988599753831";
        fjs.parentNode.insertBefore(js, fjs);
        }(document, 'script', 'facebook-jssdk'));</script><script>


jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1497592416,
		today: 1497567600,
		todayDow: 5
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "0.5",
	_overlayConfig:
	{
		top: "10%",
		speed: 100,
		closeSpeed: 50,
		mask:
		{
			color: "rgb(255, 255, 255)",
			opacity: "0.6",
			loadSpeed: 100,
			closeSpeed: 50
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"EWRporta2_Global":true,"thread_view":true,"message":true,"bb_code":true,"message_user_info":true,"share_page":true,"wf_default":true,"polls":true,"BRMI_forum_list_sidebar":true,"login_bar":true,"moderator_bar":true,"uix_welcomeBlock":true,"notices":true,"uix_extendedFooter":true,"js\/xenforo\/discussion.js?_v=ae6c8d87":true,"js\/brivium\/MailchimpIntegrate\/newsletter.js?_v=ae6c8d87":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "login/csrf-token-refresh",
	_jsVersion: "ae6c8d87",
	_noRtnProtect: false,
	_noSocialLogin: false
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;


</script><script>

</script><script>/* <![CDATA[ */(function(d,s,a,i,j,r,l,m,t){try{l=d.getElementsByTagName('a');t=d.createElement('textarea');for(i=0;l.length-i;i++){try{a=l[i].href;s=a.indexOf('/cdn-cgi/l/email-protection');m=a.length;if(a&&s>-1&&m>28){j=28+s;s='';if(j<m){r='0x'+a.substr(j,2)|0;for(j+=2;j<m&&a.charAt(j)!='X';j+=2)s+='%'+('0'+('0x'+a.substr(j,2)^r).toString(16)).slice(-2);j++;s=decodeURIComponent(s)+a.substr(j,m-j)}t.innerHTML=s.replace(/</g,'&lt;').replace(/\>/g,'&gt;');l[i].href='mailto:'+t.value}}catch(e){}}}catch(e){}})(document);/* ]]> */</script></body>
</html>