Purchase Linux CDs / DVDs / Flash Drives at OSDisc.com

Welcome to Our Community

While Linux.org has been around for a while, we recently changed management and had to purge most of the content (including users). If you signed up before April 23rd please sign up again. Thanks!

Blank screen even with Nvidia drivers

Discussion in 'Linux Audio / Video' started by Desenski, May 6, 2015.

  1. Desenski

    Desenski Guest

    Alrigth let me first off explain my setup and how it currently is. I have an i7 3770k cpu, and 2 GTX 970's connected with an SLI bridge (for when im gaming in Windows). I have 2 monitors. Currently one of them is plugged into the mobo, and the other is connected to the first GPU. When I boot up using the GPU as my primary video adapter, I get a couple lines of text for a brief moment, and then it goes blank. When I boot up using onboard graphics, everything works perfectly. I have used lspci -k | grep -A 2 -E "(VGA|3D)" and it shows I have the nvidia drivers installed and in use. Yet I still can't see anything on the screen when I try to use it. I have spent the better part of 12 hours trying to fix this, only to cause other issues (mainly because im a linux newbie, but hey we all were at one time). Any help on how to fix this would be awesome. Id really rather not have to use onboard graphics whenever im using linux.

  2. arochester

    arochester Guest

    You do not say which distro of Linux you are using.

    I maybe wrong, perhaps someone will correct me, but does a GPU card not switch off the on-board Graphics? I think you may be able to do one or the other but not both? You might need something like 2 GPU cards...
  3. Desenski

    Desenski Guest

    I'm sorry, I'm using Arch Linux. And yes, when a dedicated graphics card is plugged in it disables onboard graphics. I went into the mobo and forced it to use onboard graphics so I could see something and install Linux. Now that it's installed, I have tried switching the primary video adapter back to PCI-e (from onboard). Now when I boot, I see like 2 short lines of text for a brief moment and then nothing.
  4. ryanvade

    ryanvade Guest

    Have you enabled SLI in Xorg?

    And, for the sake of being absolutely clear, you did run
    pacman -S nvidia
    I just ask to be absolutely sure.
  5. Desenski

    Desenski Guest

    Yes I did run
    sudo pacman -S nvidia
    sudo pacman -S nvidia-libgl
    however I am not sure if I enabled SLI in Xorg. I have reinstalled Arch so many times trying to figure stuff out (kept breaking different things) that I can't remember if I did on this install or not. I will try that and get back to you.
  6. Desenski

    Desenski Guest

    Alright so I think I found the issue. When I open xorg.conf There is nothing there. It's completely blank. And when I run the command to insert it
    nvidia-xconfig --busid=PCI:1:00.0 --sli=AA
    (using lspci | grep VGA shows that one of my GPU's is 01:00.0 and the other is 02:00.0) I get the warning "Unable to locate/open X configuration file." ," Unable to parse X,org version string." Error: "Unable to write to directory '/etc/X11'."
  7. ryanvade

    ryanvade Guest

  8. Desenski

    Desenski Guest

    Running that in root created the X11 file. Then I go to restart (still using onboard graphics) and now I get a Xorg error (EE) no screens found. And when I boot in using the GPU, I still have nothing in the screen

Share This Page