Black Screen OR Corrupted-Looking Screen After Suspend.


Jul 11, 2018
Reaction score
Just about every time I close my laptop and reopen it, the fans run, ethernet and wifi works, but the screen stays black. (And no, function keys don't work. I've been told to do fn+f4 and fn+f1 and neither work.) My second issue is when I suspend while laptop is open and then try to wake it up, only a green corrupted screen shows up and the same things work/don't work as said above^. The only way to escape those screens and boot normally is to remove the battery and put it back in. I can boot totally fine, suspending is my only issue. I am a newbie to Linux and I don't understand *too* much about the OS but I'm getting there. I am set up for dual boot with Linux Mint and Windows 10, and my folder is not encrypted. I know of other people getting this issue, but everything people say to do, is not working. I have been told to write "pci=nomsi" after the kernel entry in /etc/default/grub and I've done that, but I haven't seen if it did anything or not. (Again, it doesn't black out every time.) If anyone has any other suggestions or have a fix that worked for them, please do let me know.

Hi @_Default and welcome to :)

(Wizard appears in a puff of smoke, carrying a chicken under his arm. Chicken looks concerned about whether it will see its next meal)

  1. Which version of Linux Mint? Down to the DE (desktop environment) eg MATE, Cinnamon, &c.
  2. but everything people say to do, is not working
    - give us a broad idea of what has been tried so far, including links if possible
  3. Can you give us the specs for your computer? At Linux Terminal type in and enter following
    inxi -Fxs
    - there's no compromise on privacy, and it will also tell us your Linux Mint. Mine is seen when you click the Spoiler below, taken from an Ubuntu I am in for someone else, but I run 43 Linux, so likely have your Mint.
I am from DownUnder (Australia) so you will see me in and out at different times. However we have some good hardware-savvy folks here, whom may swing by to assist with a simple solution. Might include turning off suspend.

Wizards inxi specs from this Distro

chris@ArtfulMATE-Study:~$ inxi -Fxs
System: Host: ArtfulMATE-Study Kernel: 4.13.0-43-generic x86_64
bits: 64 gcc: 7.2.0
Desktop: MATE 1.18.0 (Gtk 3.22.25-0ubuntu0.1) Distro: Ubuntu 17.10
Machine: Device: laptop System: TOSHIBA product: Satellite S70t-A v: PSKNEA-04G034 serial: N/A
Mobo: Type2 - Board Vendor Name1 model: Type2 - Board Product Name1 v: Type2 - Board Version serial: N/A
UEFI: Insyde v: 1.60 date: 04/18/2014
Battery BAT1: charge: 43.8 Wh 100.0% condition: 43.8/48.6 Wh (90%)
model: Panasonic PA5109U-1BRS status: Full
CPU: Quad core Intel Core i7-4700MQ (-HT-MCP-)
arch: Haswell rev.3 cache: 6144 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 19155
clock speeds: max: 3400 MHz 1: 2385 MHz 2: 2384 MHz 3: 2394 MHz
4: 2395 MHz 5: 2388 MHz 6: 2393 MHz 7: 2394 MHz 8: 2392 MHz
Graphics: Card-1: Intel 4th Gen Core Processor Integrated Graphics Controller
bus-ID: 00:02.0
Card-2: NVIDIA GK208M [GeForce GT 740M] bus-ID: 01:00.0
Display Server: x11 (X.Org 1.19.5 )
drivers: (unloaded: fbdev,vesa) FAILED: modesetting,nouveau
Resolution: [email protected]
OpenGL: renderer: Mesa DRI Intel Haswell Mobile
version: 4.5 Mesa 17.2.8 Direct Render: Yes
Audio: Card-1 Intel 8 Series/C220 Series High Def. Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
driver: snd_hda_intel bus-ID: 00:03.0
Sound: Advanced Linux Sound Architecture v: k4.13.0-43-generic
Network: Card-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
driver: ath9k bus-ID: 0d:00.0
IF: wlp13s0 state: up mac: a4:db:30:2c:2d:75
Card-2: Qualcomm Atheros AR8161 Gigabit Ethernet
driver: alx port: 3000 bus-ID: 0e:00.0
IF: enp14s0 state: down mac: 08:9e:01:e7:f7:0a
Drives: HDD Total Size: 5001.0GB (0.5% used)
ID-1: /dev/sda model: TOSHIBA_MQ01ABD1 size: 1000.2GB
ID-2: USB /dev/sdb model: My_Book_25EE size: 4000.8GB
Partition: ID-1: / size: 15G used: 9.8G (71%) fs: ext4 dev: /dev/sda22
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 55.0C mobo: N/A gpu: 48.0
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 222 Uptime: 18 min Memory: 1827.6/7900.8MB
Init: systemd runlevel: 5 Gcc sys: N/A
Client: Shell (bash 4.4.121) inxi: 2.3.37

One more question, when you added the line in /etc/default/grub (I am guessing on the same line as eg "quiet splash"), did you, after exiting and saving, run

sudo update-grub


sudo grub-mkconfig -o /boot/grub/grub.cfg

# the first is a stub for the 2nd.


Chris Turner
1. Linux Mint 19 Cinnamon.
2. I've been told to up my brightness to over 80%, I tried to install the latest AMD driver but unfortunately mine is literally the ONLY ONE not supported on AMD. (Pretty mad about it, too.) I did the line of code thing and ran "sudo update-grub". And unfortunately I have no links to share.
3. Here are my specs:
System: Host: UA-Mint Kernel: 4.15.0-24-generic x86_64 bits: 64 gcc: 7.3.0
Desktop: Cinnamon 3.8.7 (Gtk 3.22.30-1ubuntu1)
Distro: Linux Mint 19 Tara
Machine: Device: laptop System: HP product: HP Notebook v: Type1ProductConfigId serial: N/A
Mobo: HP model: 81F9 v: 67.37 serial: N/A
UEFI: Insyde v: F.21 date: 10/27/2016
Battery BAT1: charge: 28.4 Wh 93.7% condition: 30.3/31.1 Wh (97%)
model: Hewlett-Packard PABAS0241231 status: Discharging
CPU: Quad core AMD A12-9700P RADEON R7 10 COMPUTE CORES 4C+6G (-MCP-)
arch: Excavator rev.1 cache: 4096 KB

flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 19964
clock speeds: max: 2500 MHz 1: 1344 MHz 2: 1306 MHz 3: 1369 MHz
4: 1580 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] Carrizo bus-ID: 00:01.0
Display Server: x11 (X.Org 1.19.6 )
drivers: ati,amdgpu (unloaded: modesetting,fbdev,vesa,radeon)
Resolution: [email protected]
OpenGL: renderer: AMD CARRIZO (DRM 3.23.0 / 4.15.0-24-generic, LLVM 6.0.0)
version: 4.5 Mesa 18.0.5 Direct Render: Yes
Audio: Card-1 Advanced Micro Devices [AMD] Device 157a
driver: snd_hda_intel bus-ID: 00:09.2
Card-2 Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio
driver: snd_hda_intel bus-ID: 00:01.1
Sound: Advanced Linux Sound Architecture v: k4.15.0-24-generic
Network: Card-1: Realtek RTL8101/2/6E PCIE Fast/Gigabit Ethernet controller
driver: r8169 v: 2.3LK-NAPI port: 3000 bus-ID: 01:00.0
IF: enp1s0 state: down mac: 40:b0:34:6b:2c:ec
Card-2: Intel Wireless 3165 driver: iwlwifi bus-ID: 02:00.0
IF: wlo1 state: up mac: 58:fb:84:c3:f2:a8
Drives: HDD Total Size: 1000.2GB (3.6% used)
ID-1: /dev/sda model: TOSHIBA_MQ01ABD1 size: 1000.2GB
Partition: ID-1: / size: 321G used: 34G (12%) fs: ext4 dev: /dev/sda6
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 20.0C mobo: 0.0C gpu: 46.0
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 207 Uptime: 2:59 Memory: 2128.5/7504.9MB
Init: systemd runlevel: 5 Gcc sys: 7.3.0
Client: Shell (bash 4.4.191) inxi: 2.3.56

Edit: After around 12 hours passed i opened my laptop and i didnt get a black screen. Instead i see my unlocked desktop, but i cant move the mouse or do anything. I restarted the laptop, got into my bootloader and when i clicked linux mint, i go into a black screen (but screen is on as i can see backlight) so i restarted again and it is followed up by a TON of code and now i am stuck here. It is showing alot of lines talking about corrupted low memory.
Last edited:
Thanks for the specs, bummer about where you are stuck now :(. I take it you have access to another computer?

With the specs, if you revisit mine, I had my Toshiba laptop

Machine: Device: laptop System: TOSHIBA product: Satellite S70t-A v: PSKNEA-04G034 serial: N/A

Yours has

Machine: Device: laptop System: HP product: HP Notebook v: Type1ProductConfigId serial: N/A

... are you able to tell us a Model and Number?

and it is followed up by a TON of code and now i am stuck here. It is showing alot of lines talking about corrupted low memory.

Are you able to tell us a bit more about that? Can you take a picture with your mobile (cell) phone and upload it as an attachment?

Or else if you are registered with an imaging host site, such as Imgur, Photobucket, TinyPic or other, you could copy the image location to here such as my (example only) screenshot below.



Now, the above is a part of my Grub Menu from some weeks ago. Given you are dualbooting, you will have a Grub Menu, yes? Featuring Win 10 and Tara.

If you are up to it, I would like to get an additional two (2) photos:

  1. At your initial Grub Menu, there will be a number of options eg you can see a part of it with mine "Enter to boot the selected OS, 'e' to edit the commands before booting and 'c' for a command-line". Take a pic of that initial page, and then choose 'e'
  2. In the page that is revealed, there will be a number of lines, and I need the focus to be on one which might feature "quiet splash"
  3. I lied ... 3 photos. After 2. Esc back out and there will be on the initial grub page an option under the Tara entry for eg "Advanced Options" . Enter that and there will be a couple of lines of the type featuring kernel 4.15.0-24 &c. Take a pic of that, then you can Escape out of there.
I note from the Meta Tag at the end of your Spoiler that perhaps you are a native French speaker, so we just need to see if we have to make adjustments.

It is possible, on that page with the quiet splash, that we may try inserting a command "nomodeset" and see if that gets you in past the graphics difficulties, but we'll see what you come back with.


I cannot do it atm, but do you think i should clean install linux mint and go from the start? I dont have anything important on my system other than my windows 10 dual boot
I understand, and it certainly wouldn't hurt to try if you have the patience? :) We have a young fella @Vencorr recently joined whose credo is

Oops, I broke something...
Time to reinstall!

... and given as you can see from my screenshot I run 40 or more Linux at a time, I can certainly subscribe to that philosophy :p

If it still goes pear-shaped, then at least we may establish a pattern, and if need be, also take a look at some logs (definite Spoiler material, :D).

You are the driver behind the wheel of your computer, so we will go with your choices, and try to have your back ;)

BTW, I have 2 Dells arriving tomorrow, both with AMD innards I think, so if this drags out (& hopefully not, for your sake) I may be able to get more insight that will assist. My strong points are software and multi-multi-booting, not hardware, so if someone else better than I happens along (we are all volunteers from around the globe), you will likely be in good hands.

Cheers and let us know how you go?

I was told to install the propriety driver for my graphics card but mine is the only one not supported. I dont know what to do because many people said thats the only thing that worked for them so maybe i just cant use linux on mh laptop :(
Don't give up too soon let's see if we can turn that :( into a :D?

When you get a chance, see if you can come up with that stuff I asked after at #4.

Many, many times, we find that adding "nomodeset" in the right spot in the startup sequence will get you into a session, but only lasts for the session. Once we establish that that works, then we can write it permanently into a file called grub (/etc/default/grub) which will perpetuate the change until the good folk (mostly volunteers) in The Community catch up with your Radeon.

Now I have your card details, I'll do a little "Googling" and see what I find.


Do you have an external method of discussion? Skype, telegram, etc?
Sorry, if you mean one-on-one tutoring or mentoring, no.

If you take a look around this site, you'll see I am pretty busy, helping, yes, individuals, but also for the benefit of the many. As do a number of us, it is just a rare occasion that I have been the only one on the scene, here, so far :D.

If you have something else in mind, just start a Conversation with me - hold your pointing device over your avatar top right of this page, and choose Conversations.


Right, thats okay. I was just looking for an easy way to send a picture of my problem. Is there an easy way to do so?
From the little information I can find on AMD Graphics (it is a nightmare) your Radeon R7 is actually GCN 3 (AKA 3rd Generation GCN). With that being the case, you should be using the AMDGPU driver and not the proprietary drivers (NOT AMDGPU Pro) and not the older open source radeon drivers.

More information:
The AMDGPU drivers are included with the Linux Kernel itself and do not require extra installation on Mint 19. You should disable the proprietary drivers and the kernel will switch back to the open source drivers. I can't tell you how to disable the proprietary drivers as I'm unsure how you installed them initially.
Right, thats okay. I was just looking for an easy way to send a picture of my problem. Is there an easy way to do so?

Take a look here, where it says Posting a Screenshot

... and I am looking to do up something more comprehensive soon.

This one sort of completes the picture

As for the drivers, I have only installed Tara MATE edition so far, but I can cross-reference that and an LM18.3 Cinnamon and provide further input.

Give me 10 minutes or so and then I'm out of here for the afternoon.


Hi Ryan ;)
I didnt have any propriety drivers.. my driver menu was completely empty.
OK, so when you say that - I have below 2 screenshots, one is of my Linux Mint 19.0 'Tara' MATE


and the other is from my Linux Mint 18.3 'Sylvia' Cinnamon


You'll note a slight difference in format, also mine is nVidia-Intel where yours is Radeon.

If you have nothing listed there, I would wonder about the integrity of the original install.

Do you still have the original medium (I take it you do if doing a reinstall), ie DVD or USB stick, and which?

I have to go, but for the benefit of others I am looking at shasum checking.



Members online