Black screen after upgrade 20.04 to 22.04.1

whoopyWat

New Member
Joined
Feb 21, 2023
Messages
3
Reaction score
0
Credits
32
Hello the wise ones,

I was remotely updating Ubuntu on my granny's computer from 20.04 to 22.04. the installation succeeded, the computer restarted and then we saw the the usual grub menu:
  1. Ubuntu
  2. Advanced boot options for Ubuntu
  3. Windows boot manager (on dev/sda1)
  4. UEFI Firmware settings
when selecting Ubuntu, I see a short console screen with the following:
1677008832099.png

and after that I see a black screen with an underscore in the top left corner.

Here are the options for advanced boot options for Ubuntu:
1677012433932.png


selecting the first one gets me black screen with an underscore in the top left corner.
second one gets recovery mode stuff.
the 3rd one boots ubuntu normally.
the 4th one I did not try.
after managing to start Ubuntu with the third option, I decided to restart it to see what happens. Turns out that we get the same thing (i.e. it doesn't work with the default Ubuntu option from the grub menu)

how to solve this problem?

thank you in advance!
P.S. My search for answers came up with various things including disabling Fast Boot and Secure Boot. I disabled Fast boot option and tried to disable Secure Boot option, but did not have an option to do so:
1677012721743.png
 


My usual advice in this situation is kinda a 'wait and see' suggestion.

For now, boot to the working kernel. Update as normal (but don't autoremove, or delete the working kernel) after that. When the next kernel comes down the pipe, it might resolve your issue.

That's what I'd do. Wait and see if the next kernel fixes it.
 
did you try option 2
 
alternative
boot the working installation
install Ubuntu boot repair from the repository [follow the instructions ] and run boot repair re=start when finished.

 
did you try option 2
thank you for the answer!

yes, this is what we saw:
1677016598849.png


Resume - was giving the same result as booting normally.
Repair - gave this:
1677016728376.png


We did not try other options. if you have recommendations, let me know.
 
My usual advice in this situation is kinda a 'wait and see' suggestion.

For now, boot to the working kernel. Update as normal (but don't autoremove, or delete the working kernel) after that. When the next kernel comes down the pipe, it might resolve your issue.

That's what I'd do. Wait and see if the next kernel fixes it.
thanks! this will be my backup option. I will the the one suggested by the @Brickwizard tomorrow.
 
When you get the recovery screen, you select and run dpkg, but try boot repair first
 
Just another reason why I always do a clean install vs. a distro upgrade - too many things can go wrong
 
Aah, hindsight, Your Lordship, lol.

@whoopyWat welcome to linux.org :)

This is obviously not your first time with Linux, given you are updating Gran's Linux remotely, so I am guessing you know how to edit and upgrade Grub Menu, is that so?

So given Option 3 works in Advanced, with the 5.15.0-60-generic choice, I would be inclined, for now to edit /etc/default/grub, change the line which starts with

GRUB_DEFAULT=

to read

Code:
GRUB_DEFAULT="Advanced options for Ubuntu>Ubuntu, with Linux 5.05.0-60-generic"


// save and close the file and then run


sudo update-grub



and reboot.

There are options to move the Advanced Options content to the front page, and to use a numeric identification of entry line numbers (starts with 0 zero) at the GRUB_DEFAULT= LINE, but those might not persist after kernel updates and so on.

This will allow breathing space to further troubleshooting if you wish, and a seamless bootup for Granny.

Just a thought.

Chris Turner
wizardfromoz
 


Latest posts

Top