Audio broken on Asus Fx505 GE - Maybe a kernel bug...


New Member
Aug 11, 2020
Reaction score
I have been trying to get my audio working on Asus fx 505GE. My goto distro was ManjaroKDE but I noticed that my on board sound didn't work (It was showing as dummy output in pulseaudio). I searched for a while but nothing worked. I tried alsamixer with no success. I even switched to different distros including : Arch - Manjaro, EndevourOs ; Debian - Ubuntu, Kubuntu, Linux Mint, KDE neon, Elementary OS. On board sound didn't work in any of them. I then tried to boot into non-free and that broke both my wifi and sound. I took a system info ( inxi ) and it showed that both my sound cards are detected. I dont know what else to try. Just in case I then booted into windows and everything was working.

I have attached a screen shot of my inxi output.

Here is a link to amazon listing of the laptop.


  • photo_2020-08-11_06-17-08.jpg
    138.8 KB · Views: 440

I would think the Intel CannonLake is supported. But I don't have any systems with that
chipset, so I can't verify.

Members online