Solved Attempting to run "sudo updatedb" for the locate command - getting a permission denied error.

Solved issue
I forgot if Debian lists the the packages and dependencies that will get removed or not when you remove a dependency. I'm trying to figure out what package on your system uses those installed packages, so these ones: gvfs gvfs-backends gvfs-common gvfs-daemons gvfs-fuse gvfs-libs. That way you will see what program uses those and if you actually installed it yourself and then you will know if you use it yourself, if you don't you can remove it and then try again by using "sudo" with "updatedb"


Seems like "gvfs" is causing the problems and not "sudo" since you have the same with th root account.
Wouldn't that also be the case with the doc file?
 


Wouldn't that also be the case with the doc file?
One thing at a time.

Do you have this file under /etc/gvfs/gvfsd.conf , if so can you share the contents?
 
Thanks: no offense to anyone - but I was confused about why was aide mentioned (I don't know what that is exactly), or how it pertained to my issue of just trying to get the updatedb command to work.

Slight aside, I will mention that this isn't the first time I've had a sudo command return with a "Permission Denied" error. While I can't remember the particulars (as it doesn't happen often), has anyone else run into that?
I was trying to tell you that certain file systems that are mounted under certain directories are not normal file systems and should not be included when running things like updatedb or aide. aide (advanced intrusion detection environment) is an IDS (intrusion detection system). It tells you when files have been added, removed, or modified. Programs like updatedb or aide should not be allowed to look in directories like /dev, /proc, /run, and /sys since these are not normal directories. Allowing them to do so can result in the error that you are getting and even crash your system. It would appear that I don't even have an updatedb command available on my Linux system. What package did you install to get this?

Signed,

Matthew Campbell
 
One thing at a time.

Do you have this file under /etc/gvfs/gvfsd.conf , if so can you share the contents?
No dice, unfortunately:

priestapostate@XXXXXXX:~$ ls /etc/gvfs
ls: cannot access '/etc/gvfs': No such file or directory

priestapostate@XXXXXXX9:~$ su -
Password:
root@XXXXXXX:~# ls /etc/gvfs
ls: cannot access '/etc/gvfs': No such file or directory
root@XXXXXXX:~#
 
Last edited:
I was trying to tell you that certain file systems that are mounted under certain directories are not normal file systems and should not be included when running things like updatedb or aide.
updatedb should work even with those paths there but it's an idea.

Try adding "/run" to this file -> /etc/updatedb.conf , at the end of the already existing list for the "PRUNEPATHS=" variable than try running "updatedb" again.
 
It would appear that I don't even have an updatedb command available on my Linux system. What package did you install to get this?
That would be the "locate" package: it was mentioned as one of the testing objectives in the LPIC-1 - but I found that it wasn't natively installed on my Debian system.

On a somewhat related front, I found that I did have GNOME installed upon my system (even though I am using Plasma on Wayland: while I remember performing multiple reinstall attempts during my last wipe/reinstall attempt, I eliminated GNOME from my second to last install - but not the last install. As such, I am researching on how to delete these display managers safely - without having to reinstall again, as it seems that this install picked up ALL the GNOME display managers).
 
Last edited:
I eliminated GNOME from my second to last install - but not the last install. As such, I am researching on how to delete these display managers safely - without having to reinstall again.
Probably one of these.
Code:
sudo apt remove gnome
sudo apt remove gnome-core
Try that, it should probably than remove those gvfs packages as well?
 
Probably one of these.
Code:
sudo apt remove gnome
sudo apt remove gnome-core
Try that, it should probably than remove those gvfs packages as well?


Currently, these are the GNOME options listed:
1. GNOME Classic on Wayland (Wayland)
2. GNOME Classic (Wayland)
3. GNOME on Wayland (Wayland)
4. GNOME (Wayland)
5. GNOME Classic on Xorg
6. GNOME Classic
7. GNOME on Xorg
8. GNOME

I don't know what I was thinking during that install attempt (maybe try them out, and see if maybe I'm being too harsh on GNOME? shrugs) - but as I like Plasma on Wayland, trying the others seems a bit pointless.
As of now, I'll try out those commands, in the hopes that it removes all GNOME from my system without rendering it a paperweight.
 
1. GNOME Classic on Wayland (Wayland)
2. GNOME Classic (Wayland)
3. GNOME on Wayland (Wayland)
4. GNOME (Wayland)
5. GNOME Classic on Xorg
6. GNOME Classic
7. GNOME on Xorg
8. GNOME
I was telling you how to uninstall Gnome as how they have documented it on the Debian Gnome page.
Screenshot from 2024-06-23 20-24-05.png


Open a terminal and run the following, then all the Gnome packages should be removed.
Code:
apt remove gnome gnome-core
 
Listed where, at the GDM login screen?
Correct - those are the ones at the login screen. Aside from having my last install hit every branch on the GNOME tree on the way down, I also have Plasma X11, and the Plasma on Wayland I mentioned.

Also trying out your commands now. It appears that LibreOffice relies on GNOME, though: as I use that, I'm trying to find a way to make sure that that won't be affected.
 
Of the ones originally listed:

1. GNOME Classic on Wayland (Wayland)
2. GNOME Classic (Wayland)
3. GNOME on Wayland (Wayland)
4. GNOME (Wayland)
5. GNOME Classic on Xorg
6. GNOME Classic
7. GNOME on Xorg
8. GNOME

These remain:
1. GNOME on Wayland (Wayland)
2. GNOME (Wayland)
3. GNOME on Xorg
4. GNOME

Now that gvfs is removed, doc seems to be the only roadblock:

priestapostate@XXXXXX:~$ sudo updatedb
[sudo] password for priestapostate:
/usr/bin/find: '/run/user/1000/doc': Permission denied

priestapostate@XXXXXX:~$ su -
Password:
root@scion0829:~# updatedb
/usr/bin/find: '/run/user/1000/doc': Permission denied
root@XXXXXX:~#
 
Would it be advisable to run "apt remove gdm3?"
If "sddm" is installed yes.

Run.
Code:
sudo systemctl enable sddm --now
If that works then you can remove gdm3 and reboot the system after you have done that. Then try running "sudo updatedb" again?
 
No dice:



Code:
priestapostate@XXXXXX:~$ sudo systemctl enable sddm --now

[sudo] password for priestapostate:

Synchronizing state of sddm.service with SysV service script with /lib/systemd/systemd-sysv-install.

Executing: /lib/systemd/systemd-sysv-install enable sddm


priestapostate@XXXXXX:~$ sudo updatedb

/usr/bin/find: '/run/user/1000/doc': Permission denied


priestapostate@XXXXXX:~$ su -

Password:


root@XXXXXX:~# updatedb

/usr/bin/find: '/run/user/1000/doc': Permission denied

root@XXXXXX:~#
 
Try adding "/run" to this file -> /etc/updatedb.conf , at the end of the already existing list for the "PRUNEPATHS=" variable than try running "updatedb" again.
This? So that this line looks like this.
PRUNEPATHS="/tmp /var/spool /media /var/lib/os-prober /var/lib/ceph /home/.ecryptfs /var/lib/schroot /run"

Share the output of the following.
Code:
dpkg --list | grep gvfs
 
There is no updatedb.conf file in the /etc directory.

The readout of dpkg --list | grep gvfs shows this:
priestapostate@XXXXXX:~$ dpkg --list | grep gvfs
ii gvfs:amd64 1.50.3-1
amd64 userspace virtual filesystem - GIO module
ii gvfs-backends 1.50.3-1
amd64 userspace virtual filesystem - backends
ii gvfs-common 1.50.3-1
all userspace virtual filesystem - common data files
ii gvfs-daemons 1.50.3-1
amd64 userspace virtual filesystem - servers
ii gvfs-libs:amd64 1.50.3-1
amd64 userspace virtual filesystem - private libraries
priestapostate@XXXXXX:~$
 
There is no updatedb.conf file in the /etc directory.
It should be there, it is on Debian when I install mlocate. Maybe try reinstalling it?
Code:
sudo apt reinstall mlocate
The readout of dpkg --list | grep gvfs shows this:
Try removing those.
Code:
sudo apt remove gvfs gvfs-backends gvfs-common gvfs-daemons gvfs-libs
 
Just removed, rebooted, re-installed locate, rebooted. ran your apt remove command, and rebooted...no change to the /etc/ directory (in that the updatedb.conf command is still not there).

"su -" is also still being denied.
 

Members online


Latest posts

Top